summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-27 16:35:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-27 16:35:06 +0000
commit0a030ce476c376229fbec3502d58274999b3fc90 (patch)
tree7db1d09450ca9b0e8a2941627d122421c6f02abb
parentRemoving unused gbp.conf. (diff)
downloadnetdata-0a030ce476c376229fbec3502d58274999b3fc90.tar.xz
netdata-0a030ce476c376229fbec3502d58274999b3fc90.zip
Updating rules to use current dh features.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xdebian/rules15
1 files changed, 3 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index 794653bf..a55ba3e7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,7 +25,7 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
%:
dh ${@} --with apache2
-override_dh_autoreconf:
+execute_before_dh_autoreconf:
rm -f debian/configure.ac.orig
cp configure.ac debian/configure.ac.orig
@@ -35,20 +35,14 @@ override_dh_autoreconf:
-e 's/^\(define(\[VERSION_SUFFIX]\).*/\1, [$(VERSION_SUFFIX)])/' \
configure.ac
- dh_autoreconf
-
-override_dh_autoreconf_clean:
+execute_before_dh_autoreconf_clean:
if [ -e debian/configure.ac.orig ]; \
then \
rm -f configure.ac; \
mv debian/configure.ac.orig configure.ac; \
fi
- dh_autoreconf_clean
-
-override_dh_auto_clean:
- dh_auto_clean
-
+execute_after_dh_auto_clean:
rm -rf build-core
rm -rf build-core-no-sse debian/tmp-core-no-sse
@@ -185,9 +179,6 @@ override_dh_installlogrotate:
dh_installlogrotate -p netdata-core-no-sse --name=netdata
dh_installlogrotate --remaining-packages
-override_dh_missing:
- dh_missing --fail-missing
-
override_dh_fixperms-arch:
dh_fixperms -a