summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-26 08:03:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-26 08:03:52 +0000
commit429584306fe731af42618c4d45b315ba68134b7f (patch)
tree68461e04aa6337a54db761a84dc74c7afcc79a0e
parentReleasing debian version 1.29.3-1. (diff)
downloadnetdata-429584306fe731af42618c4d45b315ba68134b7f.tar.xz
netdata-429584306fe731af42618c4d45b315ba68134b7f.zip
Applying patch from Gianfranco Costamagna <locutusofborg@debian.org> to lower optimization level on s390x to fix FTBFS with new gcc.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 89119ae0..794653bf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,8 +10,16 @@ VERSION_MINOR := $(word 2, $(subst ., ,$(VERSION)))
VERSION_FIX := $(word 3, $(subst -, ,$(subst ., ,$(VERSION))))
VERSION_SUFFIX := -$(word 4, $(subst -, ,$(subst ., ,$(VERSION))))
+include /usr/share/dpkg/architecture.mk
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+ifeq ($(DEB_HOST_ARCH),s390x)
+export DEB_CFLAGS_MAINT_APPEND = -Wall -O2
+else
export DEB_CFLAGS_MAINT_APPEND = -Wall -O3
+endif
+
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
%: