summaryrefslogtreecommitdiffstats
path: root/collectors/node.d.plugin/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-11-28 04:53:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-11-28 04:53:29 +0000
commit17c93e2be4ad7b3af0cd6878bdd5d8a4a3e6da99 (patch)
tree3e0c96613972e8bb4afdeeb97a034806363ddfa9 /collectors/node.d.plugin/Makefile.am
parentReleasing debian version 1.18.1-1. (diff)
downloadnetdata-17c93e2be4ad7b3af0cd6878bdd5d8a4a3e6da99.tar.xz
netdata-17c93e2be4ad7b3af0cd6878bdd5d8a4a3e6da99.zip
Merging upstream version 1.19.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'collectors/node.d.plugin/Makefile.am')
-rw-r--r--collectors/node.d.plugin/Makefile.am44
1 files changed, 24 insertions, 20 deletions
diff --git a/collectors/node.d.plugin/Makefile.am b/collectors/node.d.plugin/Makefile.am
index 3b5a0a518..411bce9ec 100644
--- a/collectors/node.d.plugin/Makefile.am
+++ b/collectors/node.d.plugin/Makefile.am
@@ -2,8 +2,8 @@
MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
CLEANFILES = \
- node.d.plugin \
- $(NULL)
+ node.d.plugin \
+ $(NULL)
include $(top_srcdir)/build/subst.inc
SUFFIXES = .in
@@ -13,25 +13,29 @@ dist_libconfig_DATA = \
$(NULL)
dist_plugins_SCRIPTS = \
- node.d.plugin \
- $(NULL)
+ node.d.plugin \
+ $(NULL)
dist_noinst_DATA = \
- node.d.plugin.in \
- README.md \
- $(NULL)
+ node.d.plugin.in \
+ README.md \
+ $(NULL)
usernodeconfigdir=$(configdir)/node.d
dist_usernodeconfig_DATA = \
.keep \
$(NULL)
+# Explicitly install directories to avoid permission issues due to umask
+install-exec-local:
+ $(INSTALL) -d $(DESTDIR)$(usernodeconfigdir)
+
nodeconfigdir=$(libconfigdir)/node.d
dist_nodeconfig_DATA = \
$(NULL)
dist_node_DATA = \
- $(NULL)
+ $(NULL)
include fronius/Makefile.inc
include named/Makefile.inc
@@ -41,18 +45,18 @@ include stiebeleltron/Makefile.inc
nodemodulesdir=$(nodedir)/node_modules
dist_nodemodules_DATA = \
- node_modules/netdata.js \
- node_modules/extend.js \
- node_modules/pixl-xml.js \
- node_modules/net-snmp.js \
- node_modules/asn1-ber.js \
- $(NULL)
+ node_modules/netdata.js \
+ node_modules/extend.js \
+ node_modules/pixl-xml.js \
+ node_modules/net-snmp.js \
+ node_modules/asn1-ber.js \
+ $(NULL)
nodemoduleslibberdir=$(nodedir)/node_modules/lib/ber
dist_nodemoduleslibber_DATA = \
- node_modules/lib/ber/index.js \
- node_modules/lib/ber/errors.js \
- node_modules/lib/ber/reader.js \
- node_modules/lib/ber/types.js \
- node_modules/lib/ber/writer.js \
- $(NULL)
+ node_modules/lib/ber/index.js \
+ node_modules/lib/ber/errors.js \
+ node_modules/lib/ber/reader.js \
+ node_modules/lib/ber/types.js \
+ node_modules/lib/ber/writer.js \
+ $(NULL)