summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/adaptec_raid
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 11:19:16 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:07:37 +0000
commitb485aab7e71c1625cfc27e0f92c9509f42378458 (patch)
treeae9abe108601079d1679194de237c9a435ae5b55 /collectors/python.d.plugin/adaptec_raid
parentAdding upstream version 1.44.3. (diff)
downloadnetdata-upstream.tar.xz
netdata-upstream.zip
Adding upstream version 1.45.3+dfsg.upstream/1.45.3+dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--collectors/python.d.plugin/adaptec_raid/Makefile.inc13
-rw-r--r--collectors/python.d.plugin/adaptec_raid/metadata.yaml167
l---------src/collectors/python.d.plugin/adaptec_raid/README.md (renamed from collectors/python.d.plugin/adaptec_raid/README.md)0
-rw-r--r--src/collectors/python.d.plugin/adaptec_raid/adaptec_raid.chart.py (renamed from collectors/python.d.plugin/adaptec_raid/adaptec_raid.chart.py)0
-rw-r--r--src/collectors/python.d.plugin/adaptec_raid/adaptec_raid.conf (renamed from collectors/python.d.plugin/adaptec_raid/adaptec_raid.conf)0
-rw-r--r--src/collectors/python.d.plugin/adaptec_raid/integrations/adaptecraid.md (renamed from collectors/python.d.plugin/adaptec_raid/integrations/adaptecraid.md)12
6 files changed, 6 insertions, 186 deletions
diff --git a/collectors/python.d.plugin/adaptec_raid/Makefile.inc b/collectors/python.d.plugin/adaptec_raid/Makefile.inc
deleted file mode 100644
index 716cdb235..000000000
--- a/collectors/python.d.plugin/adaptec_raid/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_python_DATA += adaptec_raid/adaptec_raid.chart.py
-dist_pythonconfig_DATA += adaptec_raid/adaptec_raid.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += adaptec_raid/README.md adaptec_raid/Makefile.inc
-
diff --git a/collectors/python.d.plugin/adaptec_raid/metadata.yaml b/collectors/python.d.plugin/adaptec_raid/metadata.yaml
deleted file mode 100644
index c69baff4a..000000000
--- a/collectors/python.d.plugin/adaptec_raid/metadata.yaml
+++ /dev/null
@@ -1,167 +0,0 @@
-plugin_name: python.d.plugin
-modules:
- - meta:
- plugin_name: python.d.plugin
- module_name: adaptec_raid
- monitored_instance:
- name: AdaptecRAID
- link: "https://www.microchip.com/en-us/products/storage"
- categories:
- - data-collection.storage-mount-points-and-filesystems
- icon_filename: "adaptec.svg"
- related_resources:
- integrations:
- list: []
- info_provided_to_referring_integrations:
- description: ""
- keywords:
- - storage
- - raid-controller
- - manage-disks
- most_popular: false
- overview:
- data_collection:
- metrics_description: |
- This collector monitors Adaptec RAID hardware storage controller metrics about both physical and logical drives.
- method_description: |
- It uses the arcconf command line utility (from adaptec) to monitor your raid controller.
-
- Executed commands:
- - `sudo -n arcconf GETCONFIG 1 LD`
- - `sudo -n arcconf GETCONFIG 1 PD`
- supported_platforms:
- include: []
- exclude: []
- multi_instance: false
- additional_permissions:
- description: "The module uses arcconf, which can only be executed by root. It uses sudo and assumes that it is configured such that the netdata user can execute arcconf as root without a password."
- default_behavior:
- auto_detection:
- description: "After all the permissions are satisfied, netdata should be to execute commands via the arcconf command line utility"
- limits:
- description: ""
- performance_impact:
- description: ""
- setup:
- prerequisites:
- list:
- - title: Grant permissions for netdata, to run arcconf as sudoer
- description: |
- The module uses arcconf, which can only be executed by root. It uses sudo and assumes that it is configured such that the netdata user can execute arcconf as root without a password.
-
- Add to your /etc/sudoers file:
- which arcconf shows the full path to the binary.
-
- ```bash
- netdata ALL=(root) NOPASSWD: /path/to/arcconf
- ```
- - title: Reset Netdata's systemd unit CapabilityBoundingSet (Linux distributions with systemd)
- description: |
- The default CapabilityBoundingSet doesn't allow using sudo, and is quite strict in general. Resetting is not optimal, but a next-best solution given the inability to execute arcconf using sudo.
-
- As root user, do the following:
-
- ```bash
- mkdir /etc/systemd/system/netdata.service.d
- echo -e '[Service]\nCapabilityBoundingSet=~' | tee /etc/systemd/system/netdata.service.d/unset-capability-bounding-set.conf
- systemctl daemon-reload
- systemctl restart netdata.service
- ```
- configuration:
- file:
- name: "python.d/adaptec_raid.conf"
- options:
- description: |
- There are 2 sections:
-
- * Global variables
- * One or more JOBS that can define multiple different instances to monitor.
-
- The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
- Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
- Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
- folding:
- title: "Config options"
- enabled: true
- list:
- - name: update_every
- description: Sets the default data collection frequency.
- default_value: 5
- required: false
- - name: priority
- description: Controls the order of charts at the netdata dashboard.
- default_value: 60000
- required: false
- - name: autodetection_retry
- description: Sets the job re-check interval in seconds.
- default_value: 0
- required: false
- - name: penalty
- description: Indicates whether to apply penalty to update_every in case of failures.
- default_value: yes
- required: false
- examples:
- folding:
- enabled: true
- title: "Config"
- list:
- - name: Basic
- folding:
- enabled: false
- description: A basic example configuration per job
- config: |
- job_name:
- name: my_job_name
- update_every: 1 # the JOB's data collection frequency
- priority: 60000 # the JOB's order on the dashboard
- penalty: yes # the JOB's penalty
- autodetection_retry: 0 # the JOB's re-check interval in seconds
- troubleshooting:
- problems:
- list: []
- alerts:
- - name: adaptec_raid_ld_status
- link: https://github.com/netdata/netdata/blob/master/health/health.d/adaptec_raid.conf
- metric: adaptec_raid.ld_status
- info: logical device status is failed or degraded
- - name: adaptec_raid_pd_state
- link: https://github.com/netdata/netdata/blob/master/health/health.d/adaptec_raid.conf
- metric: adaptec_raid.pd_state
- info: physical device state is not online
- metrics:
- folding:
- title: Metrics
- enabled: false
- description: ""
- availability: []
- scopes:
- - name: global
- description: "These metrics refer to the entire monitored application."
- labels: []
- metrics:
- - name: adaptec_raid.ld_status
- description: "Status of logical devices (1: Failed or Degraded)"
- unit: "bool"
- chart_type: line
- dimensions:
- - name: a dimension per logical device
- - name: adaptec_raid.pd_state
- description: "State of physical devices (1: not Online)"
- unit: "bool"
- chart_type: line
- dimensions:
- - name: a dimension per physical device
- - name: adaptec_raid.smart_warnings
- description: S.M.A.R.T warnings
- unit: "count"
- chart_type: line
- dimensions:
- - name: a dimension per physical device
- - name: adaptec_raid.temperature
- description: Temperature
- unit: "celsius"
- chart_type: line
- dimensions:
- - name: a dimension per physical device
diff --git a/collectors/python.d.plugin/adaptec_raid/README.md b/src/collectors/python.d.plugin/adaptec_raid/README.md
index 97a103eb9..97a103eb9 120000
--- a/collectors/python.d.plugin/adaptec_raid/README.md
+++ b/src/collectors/python.d.plugin/adaptec_raid/README.md
diff --git a/collectors/python.d.plugin/adaptec_raid/adaptec_raid.chart.py b/src/collectors/python.d.plugin/adaptec_raid/adaptec_raid.chart.py
index 1995ad681..1995ad681 100644
--- a/collectors/python.d.plugin/adaptec_raid/adaptec_raid.chart.py
+++ b/src/collectors/python.d.plugin/adaptec_raid/adaptec_raid.chart.py
diff --git a/collectors/python.d.plugin/adaptec_raid/adaptec_raid.conf b/src/collectors/python.d.plugin/adaptec_raid/adaptec_raid.conf
index fa462ec83..fa462ec83 100644
--- a/collectors/python.d.plugin/adaptec_raid/adaptec_raid.conf
+++ b/src/collectors/python.d.plugin/adaptec_raid/adaptec_raid.conf
diff --git a/collectors/python.d.plugin/adaptec_raid/integrations/adaptecraid.md b/src/collectors/python.d.plugin/adaptec_raid/integrations/adaptecraid.md
index 13d22ba54..aa28451df 100644
--- a/collectors/python.d.plugin/adaptec_raid/integrations/adaptecraid.md
+++ b/src/collectors/python.d.plugin/adaptec_raid/integrations/adaptecraid.md
@@ -1,9 +1,9 @@
<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/adaptec_raid/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/adaptec_raid/metadata.yaml"
+custom_edit_url: "https://github.com/netdata/netdata/edit/master/src/collectors/python.d.plugin/adaptec_raid/README.md"
+meta_yaml: "https://github.com/netdata/netdata/edit/master/src/collectors/python.d.plugin/adaptec_raid/metadata.yaml"
sidebar_label: "AdaptecRAID"
learn_status: "Published"
-learn_rel_path: "Data Collection/Storage, Mount Points and Filesystems"
+learn_rel_path: "Collecting Metrics/Storage, Mount Points and Filesystems"
most_popular: False
message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE COLLECTOR'S metadata.yaml FILE"
endmeta-->
@@ -84,8 +84,8 @@ The following alerts are available:
| Alert name | On metric | Description |
|:------------|:----------|:------------|
-| [ adaptec_raid_ld_status ](https://github.com/netdata/netdata/blob/master/health/health.d/adaptec_raid.conf) | adaptec_raid.ld_status | logical device status is failed or degraded |
-| [ adaptec_raid_pd_state ](https://github.com/netdata/netdata/blob/master/health/health.d/adaptec_raid.conf) | adaptec_raid.pd_state | physical device state is not online |
+| [ adaptec_raid_ld_status ](https://github.com/netdata/netdata/blob/master/src/health/health.d/adaptec_raid.conf) | adaptec_raid.ld_status | logical device status is failed or degraded |
+| [ adaptec_raid_pd_state ](https://github.com/netdata/netdata/blob/master/src/health/health.d/adaptec_raid.conf) | adaptec_raid.pd_state | physical device state is not online |
## Setup
@@ -127,7 +127,7 @@ The configuration file name for this integration is `python.d/adaptec_raid.conf`
You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
+Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/netdata-agent/configuration.md#the-netdata-config-directory).
```bash
cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata