summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/sensors
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 11:19:16 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:07:37 +0000
commitb485aab7e71c1625cfc27e0f92c9509f42378458 (patch)
treeae9abe108601079d1679194de237c9a435ae5b55 /collectors/python.d.plugin/sensors
parentAdding upstream version 1.44.3. (diff)
downloadnetdata-upstream.tar.xz
netdata-upstream.zip
Adding upstream version 1.45.3+dfsg.upstream/1.45.3+dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--collectors/python.d.plugin/sensors/Makefile.inc13
-rw-r--r--collectors/python.d.plugin/sensors/metadata.yaml184
l---------src/collectors/python.d.plugin/sensors/README.md (renamed from collectors/python.d.plugin/sensors/README.md)0
-rw-r--r--src/collectors/python.d.plugin/sensors/integrations/linux_sensors_lm-sensors.md (renamed from collectors/python.d.plugin/sensors/integrations/linux_sensors_lm-sensors.md)8
-rw-r--r--src/collectors/python.d.plugin/sensors/sensors.chart.py (renamed from collectors/python.d.plugin/sensors/sensors.chart.py)0
-rw-r--r--src/collectors/python.d.plugin/sensors/sensors.conf (renamed from collectors/python.d.plugin/sensors/sensors.conf)0
6 files changed, 4 insertions, 201 deletions
diff --git a/collectors/python.d.plugin/sensors/Makefile.inc b/collectors/python.d.plugin/sensors/Makefile.inc
deleted file mode 100644
index 5fb26e1c8..000000000
--- a/collectors/python.d.plugin/sensors/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_python_DATA += sensors/sensors.chart.py
-dist_pythonconfig_DATA += sensors/sensors.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += sensors/README.md sensors/Makefile.inc
-
diff --git a/collectors/python.d.plugin/sensors/metadata.yaml b/collectors/python.d.plugin/sensors/metadata.yaml
deleted file mode 100644
index d7cb2206f..000000000
--- a/collectors/python.d.plugin/sensors/metadata.yaml
+++ /dev/null
@@ -1,184 +0,0 @@
-plugin_name: python.d.plugin
-modules:
- - meta:
- plugin_name: python.d.plugin
- module_name: sensors
- monitored_instance:
- name: Linux Sensors (lm-sensors)
- link: https://hwmon.wiki.kernel.org/lm_sensors
- categories:
- - data-collection.hardware-devices-and-sensors
- icon_filename: "microchip.svg"
- related_resources:
- integrations:
- list: []
- info_provided_to_referring_integrations:
- description: ""
- keywords:
- - sensors
- - temperature
- - voltage
- - current
- - power
- - fan
- - energy
- - humidity
- most_popular: false
- overview:
- data_collection:
- metrics_description: |
- Examine Linux Sensors metrics with Netdata for insights into hardware health and performance.
-
- Enhance your system's reliability with real-time hardware health insights.
- method_description: >
- Reads system sensors information (temperature, voltage, electric current, power, etc.) via [lm-sensors](https://hwmon.wiki.kernel.org/lm_sensors).
- supported_platforms:
- include: []
- exclude: []
- multi_instance: true
- additional_permissions:
- description: ""
- default_behavior:
- auto_detection:
- description: >
- The following type of sensors are auto-detected:
-
- - temperature
- - fan
- - voltage
- - current
- - power
- - energy
- - humidity
- limits:
- description: ""
- performance_impact:
- description: ""
- setup:
- prerequisites:
- list: []
- configuration:
- file:
- name: python.d/sensors.conf
- description: ""
- options:
- description: |
- There are 2 sections:
-
- * Global variables
- * One or more JOBS that can define multiple different instances to monitor.
-
- The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
- Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
- Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
- folding:
- title: Config options
- enabled: true
- list:
- - name: types
- description: The types of sensors to collect.
- default_value: "temperature, fan, voltage, current, power, energy, humidity"
- required: true
- - name: update_every
- description: Sets the default data collection frequency.
- default_value: 1
- required: false
- - name: priority
- description: Controls the order of charts at the netdata dashboard.
- default_value: 60000
- required: false
- - name: autodetection_retry
- description: Sets the job re-check interval in seconds.
- default_value: 0
- required: false
- - name: penalty
- description: Indicates whether to apply penalty to update_every in case of failures.
- default_value: yes
- required: false
- examples:
- folding:
- enabled: true
- title: Config
- list:
- - name: Default
- folding:
- enabled: false
- description: Default configuration.
- config: |
- types:
- - temperature
- - fan
- - voltage
- - current
- - power
- - energy
- - humidity
- troubleshooting:
- problems:
- list:
- - name: lm-sensors doesn't work on your device
- description: |
- When `lm-sensors` doesn't work on your device (e.g. for RPi temperatures),
- use [the legacy bash collector](https://github.com/netdata/netdata/blob/master/collectors/charts.d.plugin/sensors/README.md)
- - name: ACPI ring buffer errors are printed
- description: |
- There have been reports from users that on certain servers, ACPI ring buffer errors are printed by the kernel (`dmesg`)
- when ACPI sensors are being accessed. We are tracking such cases in issue [#827](https://github.com/netdata/netdata/issues/827).
- Please join this discussion for help.
- alerts: []
- metrics:
- folding:
- title: Metrics
- enabled: false
- description: ""
- availability: []
- scopes:
- - name: chip
- description: >
- Metrics related to chips. Each chip provides a set of the following metrics, each having the chip name in the metric name as reported by `sensors -u`.
- labels: []
- metrics:
- - name: sensors.temperature
- description: Temperature
- unit: "Celsius"
- chart_type: line
- dimensions:
- - name: a dimension per sensor
- - name: sensors.voltage
- description: Voltage
- unit: "Volts"
- chart_type: line
- dimensions:
- - name: a dimension per sensor
- - name: sensors.current
- description: Current
- unit: "Ampere"
- chart_type: line
- dimensions:
- - name: a dimension per sensor
- - name: sensors.power
- description: Power
- unit: "Watt"
- chart_type: line
- dimensions:
- - name: a dimension per sensor
- - name: sensors.fan
- description: Fans speed
- unit: "Rotations/min"
- chart_type: line
- dimensions:
- - name: a dimension per sensor
- - name: sensors.energy
- description: Energy
- unit: "Joule"
- chart_type: line
- dimensions:
- - name: a dimension per sensor
- - name: sensors.humidity
- description: Humidity
- unit: "Percent"
- chart_type: line
- dimensions:
- - name: a dimension per sensor
diff --git a/collectors/python.d.plugin/sensors/README.md b/src/collectors/python.d.plugin/sensors/README.md
index 4e92b0882..4e92b0882 120000
--- a/collectors/python.d.plugin/sensors/README.md
+++ b/src/collectors/python.d.plugin/sensors/README.md
diff --git a/collectors/python.d.plugin/sensors/integrations/linux_sensors_lm-sensors.md b/src/collectors/python.d.plugin/sensors/integrations/linux_sensors_lm-sensors.md
index e426c8c83..f743d410c 100644
--- a/collectors/python.d.plugin/sensors/integrations/linux_sensors_lm-sensors.md
+++ b/src/collectors/python.d.plugin/sensors/integrations/linux_sensors_lm-sensors.md
@@ -1,9 +1,9 @@
<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/sensors/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/sensors/metadata.yaml"
+custom_edit_url: "https://github.com/netdata/netdata/edit/master/src/collectors/python.d.plugin/sensors/README.md"
+meta_yaml: "https://github.com/netdata/netdata/edit/master/src/collectors/python.d.plugin/sensors/metadata.yaml"
sidebar_label: "Linux Sensors (lm-sensors)"
learn_status: "Published"
-learn_rel_path: "Data Collection/Hardware Devices and Sensors"
+learn_rel_path: "Collecting Metrics/Hardware Devices and Sensors"
most_popular: False
message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE COLLECTOR'S metadata.yaml FILE"
endmeta-->
@@ -99,7 +99,7 @@ The configuration file name for this integration is `python.d/sensors.conf`.
You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
+Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/netdata-agent/configuration.md#the-netdata-config-directory).
```bash
cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
diff --git a/collectors/python.d.plugin/sensors/sensors.chart.py b/src/collectors/python.d.plugin/sensors/sensors.chart.py
index 0d9de3750..0d9de3750 100644
--- a/collectors/python.d.plugin/sensors/sensors.chart.py
+++ b/src/collectors/python.d.plugin/sensors/sensors.chart.py
diff --git a/collectors/python.d.plugin/sensors/sensors.conf b/src/collectors/python.d.plugin/sensors/sensors.conf
index d3369ba66..d3369ba66 100644
--- a/collectors/python.d.plugin/sensors/sensors.conf
+++ b/src/collectors/python.d.plugin/sensors/sensors.conf