summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-11-28 04:53:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-11-28 04:53:08 +0000
commit315e0143f65da3485dcbcd2f6a3172a351618aec (patch)
treeb713ae472cffab249c95917c6fb6d242d54e0a87 /configure.ac
parentAdding upstream version 1.18.1. (diff)
downloadnetdata-315e0143f65da3485dcbcd2f6a3172a351618aec.tar.xz
netdata-315e0143f65da3485dcbcd2f6a3172a351618aec.zip
Adding upstream version 1.19.0.upstream/1.19.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ea91a7299..35147b0e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -748,6 +748,22 @@ fi
AC_MSG_RESULT([${enable_plugin_xenstat}])
AM_CONDITIONAL([ENABLE_PLUGIN_XENSTAT], [test "${enable_plugin_xenstat}" = "yes"])
+if test "${enable_plugin_xenstat}" == "yes"; then
+ AC_MSG_CHECKING([for xenstat_vbd_error in -lxenstat])
+ AC_TRY_LINK(
+ [ #include <xenstat.h> ],
+ [
+ xenstat_vbd * vbd;
+ int out = xenstat_vbd_error(vbd);
+ ],
+ [
+ have_xenstat_vbd_error=yes
+ AC_DEFINE([HAVE_XENSTAT_VBD_ERROR], [1], [xenstat_vbd_error usability])
+ ],
+ [ have_xenstat_vbd_error=no ]
+ )
+ AC_MSG_RESULT([${have_xenstat_vbd_error}])
+fi
# -----------------------------------------------------------------------------
# perf.plugin