summaryrefslogtreecommitdiffstats
path: root/contrib
diff options
context:
space:
mode:
authorLennart Weller <lhw@ring0.de>2016-09-05 08:27:21 +0000
committerLennart Weller <lhw@ring0.de>2016-09-05 08:27:21 +0000
commit1746898cefcb17f58b5cf27b4dad3d28236f1152 (patch)
tree9207f191cf39bbd077a1e1c73d6e82123e2fc710 /contrib
parentImported Upstream version 1.2.0+dfsg (diff)
downloadnetdata-1746898cefcb17f58b5cf27b4dad3d28236f1152.tar.xz
netdata-1746898cefcb17f58b5cf27b4dad3d28236f1152.zip
Imported Upstream version 1.3.0+dfsgupstream/1.3.0+dfsg
Diffstat (limited to 'contrib')
-rw-r--r--contrib/Makefile.am1
-rw-r--r--contrib/Makefile.in3
-rw-r--r--contrib/README.md13
-rw-r--r--contrib/debian/changelog4
-rw-r--r--contrib/debian/control3
-rw-r--r--contrib/debian/control.wheezy25
-rw-r--r--contrib/debian/netdata.default3
7 files changed, 45 insertions, 7 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 19e5df77f..b58b40e26 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -5,6 +5,7 @@ dist_noinst_DATA = \
debian/copyright \
debian/netdata.conf \
debian/source/format \
+ debian/control.wheezy \
debian/compat \
debian/netdata.install \
debian/netdata.lintian-overrides \
diff --git a/contrib/Makefile.in b/contrib/Makefile.in
index f2d5ffa25..7b14a18de 100644
--- a/contrib/Makefile.in
+++ b/contrib/Makefile.in
@@ -235,6 +235,8 @@ pluginsdir = @pluginsdir@
prefix = @prefix@
program_transform_name = @program_transform_name@
psdir = @psdir@
+pythondir = @pythondir@
+registrydir = @registrydir@
sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
srcdir = @srcdir@
@@ -251,6 +253,7 @@ dist_noinst_DATA = \
debian/copyright \
debian/netdata.conf \
debian/source/format \
+ debian/control.wheezy \
debian/compat \
debian/netdata.install \
debian/netdata.lintian-overrides \
diff --git a/contrib/README.md b/contrib/README.md
index 4578989a4..d3643d753 100644
--- a/contrib/README.md
+++ b/contrib/README.md
@@ -35,8 +35,16 @@ updates first.
* edit `contrib/debian/rules` and adjust the `dh` rule near the
top to remove systemd (see comments in that file).
-* edit `contrib/debian/control`: remove `dh-systemd` from the
- Build-Depends list, and add `pkg-config` to it.
+* rename `contrib/debian/control.wheezy` to `contrib/debian/control`.
+
+* uncomment `EXTRA_OPTS="-P /var/run/netdata.pid"` in
+ `contrib/debian/netdata.default`
+
+* edit `contrib/debian/netdata.init` and change `PIDFILE` to
+ `/var/run/netdata.pid`
+
+* uncomment `postrotate` in `system/netdata.logrotate.in` and change
+ `try-restart` to `restart`
Then proceed as the main instructions above.
@@ -46,4 +54,3 @@ The recommended way to upgrade netdata packages built from this
source is to remove the current package from your system, then
install the new package. Upgrading on wheezy is known to not
work cleanly; Jessie may behave as expected.
-
diff --git a/contrib/debian/changelog b/contrib/debian/changelog
index ed818d4df..f1dddc4ca 100644
--- a/contrib/debian/changelog
+++ b/contrib/debian/changelog
@@ -1,3 +1,3 @@
-netdata (1.2.0) UNRELEASED; urgency=medium
+netdata (1.3.0) UNRELEASED; urgency=medium
* Latest release
- -- Netdata Team <> Mon, 16 May 2016 22:12:32 +0200
+ -- Netdata Team <> Sat, 27 Aug 2016 23:38:15 +0200
diff --git a/contrib/debian/control b/contrib/debian/control
index c0312c6c6..24c5f4c4b 100644
--- a/contrib/debian/control
+++ b/contrib/debian/control
@@ -3,7 +3,8 @@ Build-Depends: debhelper (>= 9),
dh-autoreconf,
dh-systemd (>= 1.5),
dpkg-dev (>= 1.13.19),
- zlib1g-dev
+ zlib1g-dev,
+ uuid-dev
Section: net
Priority: optional
Maintainer: Costa Tsaousis <costa@tsaousis.gr>
diff --git a/contrib/debian/control.wheezy b/contrib/debian/control.wheezy
new file mode 100644
index 000000000..4103908a2
--- /dev/null
+++ b/contrib/debian/control.wheezy
@@ -0,0 +1,25 @@
+Source: netdata
+Build-Depends: debhelper (>= 9),
+ dh-autoreconf,
+ pkg-config,
+ dpkg-dev (>= 1.13.19),
+ zlib1g-dev,
+ uuid-dev
+Section: net
+Priority: optional
+Maintainer: Costa Tsaousis <costa@tsaousis.gr>
+Standards-Version: 3.9.6
+Homepage: https://github.com/firehol/netdata/wiki
+
+Package: netdata
+Architecture: any
+Depends: adduser,
+ libcap2-bin (>= 1:2.0),
+ lsb-base (>= 3.1-23.2),
+ ${misc:Depends},
+ ${shlibs:Depends}
+Description: real-time charts for system monitoring
+ Netdata is a daemon that collects data in realtime (per second)
+ and presents a web site to view and analyze them. The presentation
+ is also real-time and full of interactive charts that precisely
+ render all collected values.
diff --git a/contrib/debian/netdata.default b/contrib/debian/netdata.default
index eb1a69037..9e7f8ae6e 100644
--- a/contrib/debian/netdata.default
+++ b/contrib/debian/netdata.default
@@ -1,4 +1,5 @@
# Extra arguments to pass to netdata
#
#EXTRA_OPTS=""
-
+#uncomment following line if you are building a wheezy-package
+#EXTRA_OPTS="-P /var/run/netdata.pid"