summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorLennart Weller <lhw@ring0.de>2016-04-27 14:58:57 +0000
committerLennart Weller <lhw@ring0.de>2016-05-09 15:51:01 +0000
commitb5968a874ee8e42577a74d92e4825061dabb31d8 (patch)
treea96a92ba391fb416fc1b68729fc57ad63fdf5156 /debian
parentUpdate copyright syntax (diff)
downloadnetdata-b5968a874ee8e42577a74d92e4825061dabb31d8.tar.xz
netdata-b5968a874ee8e42577a74d92e4825061dabb31d8.zip
some bug fixes
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control46
-rw-r--r--debian/netdata-data.install1
-rw-r--r--debian/netdata-plugins-nodejs.install2
-rw-r--r--debian/netdata.install7
-rwxr-xr-xdebian/rules43
6 files changed, 66 insertions, 39 deletions
diff --git a/debian/changelog b/debian/changelog
index a1d697b65..442ae915a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,9 @@
netdata (1.1.0-1) UNRELEASED; urgency=low
+ [ Federico Ceratto ]
* Initial release (Closes: #819661)
- -- Federico Ceratto <federico@debian.org> Wed, 30 Mar 2016 22:41:35 +0100
+ [ Lennart Weller ]
+ * Split the main package into appropriate sub packages
+
+ -- Lennart Weller <lhw@ring0.de> Mon, 09 May 2016 17:01:31 +0200
diff --git a/debian/control b/debian/control
index 0d0159584..c36269696 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,15 @@ Source: netdata
Section: net
Priority: optional
Maintainer: Lennart Weller <lhw@ring0.de>
-Uploaders: James Cowgill <jcowgill@debian.org>, Federico Ceratto <federico@debian.org>
+Uploaders: James Cowgill <jcowgill@debian.org>,
+ Federico Ceratto <federico@debian.org>
Build-Depends: debhelper (>= 9),
- dh-autoreconf,
- dh-systemd (>= 1.5),
- dpkg-dev (>= 1.13.19),
- zlib1g-dev
-Standards-Version: 3.9.7
+ dh-autoreconf,
+ dh-systemd (>= 1.5),
+ dpkg-dev (>= 1.13.19),
+ pkg-config,
+ zlib1g-dev
+Standards-Version: 3.9.8
Homepage: https://github.com/firehol/netdata
Vcs-Git: https://anonscm.debian.org/collab-maint/netdata.git
Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/netdata.git
@@ -16,12 +18,36 @@ Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/netdata.git
Package: netdata
Architecture: any
Depends: adduser,
- libcap2-bin (>= 1:2.0),
- lsb-base (>= 3.1-23.2),
- ${misc:Depends},
- ${shlibs:Depends}
+ libcap2-bin (>= 1:2.0),
+ lsb-base (>= 3.1-23.2),
+ netdata-data,
+ ${misc:Depends},
+ ${shlibs:Depends}
+Recommends: netdata-plugins-nodejs
Description: real-time charts for system monitoring
Netdata is a daemon that collects data in realtime (per second)
and presents a web site to view and analyze them. The presentation
is also real-time and full of interactive charts that precisely
render all collected values.
+
+Package: netdata-data
+Architecture: all
+Depends: ${misc:Depends}, ${shlibs:Depends}
+Description: real-time charts for system monitoring
+ Netdata is a daemon that collects data in realtime (per second)
+ and presents a web site to view and analyze them. The presentation
+ is also real-time and full of interactive charts that precisely
+ render all collected values.
+ .
+ This package contains all the architecture independent data
+
+Package: netdata-plugins-nodejs
+Architecture: all
+Depends: nodejs, ${misc:Depends}, ${shlibs:Depends}
+Description: real-time charts for system monitoring
+ Netdata is a daemon that collects data in realtime (per second)
+ and presents a web site to view and analyze them. The presentation
+ is also real-time and full of interactive charts that precisely
+ render all collected values.
+ .
+ This package contains all the nodejs plugins
diff --git a/debian/netdata-data.install b/debian/netdata-data.install
new file mode 100644
index 000000000..32a3caaab
--- /dev/null
+++ b/debian/netdata-data.install
@@ -0,0 +1 @@
+/usr/share/netdata
diff --git a/debian/netdata-plugins-nodejs.install b/debian/netdata-plugins-nodejs.install
new file mode 100644
index 000000000..580442978
--- /dev/null
+++ b/debian/netdata-plugins-nodejs.install
@@ -0,0 +1,2 @@
+/usr/lib/*/netdata/node.d
+/usr/lib/*/netdata/plugins.d/node.d.plugin
diff --git a/debian/netdata.install b/debian/netdata.install
index 45d42b635..97091ff78 100644
--- a/debian/netdata.install
+++ b/debian/netdata.install
@@ -1 +1,8 @@
+/usr/sbin
debian/netdata.conf /etc/netdata/
+usr/lib/*/netdata/charts.d
+usr/lib/*/netdata/plugins.d/apps.plugin
+usr/lib/*/netdata/plugins.d/charts.d.dryrun-helper.sh
+usr/lib/*/netdata/plugins.d/charts.d.plugin
+usr/lib/*/netdata/plugins.d/loopsleepms.sh.inc
+usr/lib/*/netdata/plugins.d/tc-qos-helper.sh
diff --git a/debian/rules b/debian/rules
index dcc92dbbb..e853d24a8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,7 +23,7 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
#dh $@ --with autoreconf
override_dh_auto_configure:
- dh_auto_configure -- --with-math --with-webdir=/var/lib/netdata/www
+ dh_auto_configure -- --with-math
debian/%.postinst: debian/%.postinst.in
sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
@@ -34,42 +34,29 @@ override_dh_install: debian/netdata.postinst
# Remove unneeded .keep files
#
find "$(TOP)" -name .keep -exec rm '{}' ';'
+ rm -rf $(CURDIR)/debian/netdata-data/usr/share/netdata/web/old
# Move files that local user shouldn't be editing to /usr/share/netdata
#
- mkdir -p "$(TOP)/usr/share/netdata"
- for D in $$(find "$(TOP)/var/lib/netdata/www/" -maxdepth 1 -type d -printf '%f '); do \
- echo Relocating $$D; \
- mv "$(TOP)/var/lib/netdata/www/$$D" "$(TOP)/usr/share/netdata/$$D"; \
- ln -s "/usr/share/netdata/$$D" "$(TOP)/var/lib/netdata/www/$$D"; \
- done
+ #mkdir -p "$(TOP)/usr/share/netdata"
+ #for D in $$(find "$(TOP)/var/lib/netdata/www/" -maxdepth 1 -type d -printf '%f '); do \
+ # echo Relocating $$D; \
+ # mv "$(TOP)/var/lib/netdata/www/$$D" "$(TOP)/usr/share/netdata/$$D"; \
+ # ln -s "/usr/share/netdata/$$D" "$(TOP)/var/lib/netdata/www/$$D"; \
+ #done
# Update postinst to set correct group for www files on installation.
# Should probably be dpkg-statoverride really, but that gets *really*
# messy. We also set all web files in /var as conffiles so an upgrade
# doesn't splat them.
#
- for D in $$(find "$(TOP)/var/lib/netdata/www/" -maxdepth 1 -type f -printf '%f '); do \
- echo Updating postinst for $$D; \
- sed -i "s/^#PERMS#/chgrp netdata \/var\/lib\/netdata\/www\/$$D\n#PERMS#/g" \
- $(CURDIR)/debian/netdata.postinst; \
- echo "/var/lib/netdata/www/$$D" >> $(CURDIR)/debian/netdata.conffiles; \
- done
- sed -i "/^#PERMS#/d" $(CURDIR)/debian/netdata.postinst
-
-override_dh_installdocs:
- dh_installdocs
-
- # Docs should not be under /usr/lib
- #
- mv $(TOP)/usr/lib/$(DEB_HOST_MULTIARCH)/netdata/plugins.d/README.md \
- $(TOP)/usr/share/doc/netdata/README.plugins.md
- mv $(TOP)/usr/lib/$(DEB_HOST_MULTIARCH)/netdata/charts.d/README.md \
- $(TOP)/usr/share/doc/netdata/README.charts.md
-
- # This doc is currently empty, so no point installing it.
- #
- rm $(TOP)/usr/lib/$(DEB_HOST_MULTIARCH)/netdata/node.d/README.md
+ #for D in $$(find "$(TOP)/var/lib/netdata/www/" -maxdepth 1 -type f -printf '%f '); do \
+ # echo Updating postinst for $$D; \
+ # sed -i "s/^#PERMS#/chgrp netdata \/var\/lib\/netdata\/www\/$$D\n#PERMS#/g" \
+ # $(CURDIR)/debian/netdata.postinst; \
+ # echo "/var/lib/netdata/www/$$D" >> $(CURDIR)/debian/netdata.conffiles; \
+ #done
+ #sed -i "/^#PERMS#/d" $(CURDIR)/debian/netdata.postinst
override_dh_fixperms:
dh_fixperms