summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorLennart Weller <lhw@ring0.de>2016-05-18 11:12:57 +0000
committerLennart Weller <lhw@ring0.de>2016-05-18 11:54:08 +0000
commit2de6799cb1ddda358599d196caa71b5b2ec13239 (patch)
tree25190352114fe19df01b53fa0e949ae72fad25d2 /debian
parentUpdated completed tasks (diff)
downloadnetdata-2de6799cb1ddda358599d196caa71b5b2ec13239.tar.xz
netdata-2de6799cb1ddda358599d196caa71b5b2ec13239.zip
multi-arch dirs and links with javascript
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rw-r--r--debian/netdata-plugins-nodejs.install4
-rw-r--r--debian/netdata.links.in2
-rw-r--r--debian/netdata.lintian-overrides12
-rwxr-xr-xdebian/rules21
5 files changed, 10 insertions, 31 deletions
diff --git a/debian/control b/debian/control
index c00d4169e..e965ed38c 100644
--- a/debian/control
+++ b/debian/control
@@ -17,7 +17,7 @@ Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/netdata.git
Package: netdata
Architecture: any
-Multi-Arch: same
+Multi-Arch: no
Depends: adduser,
libcap2-bin (>= 1:2.0),
lsb-base (>= 3.1-23.2),
diff --git a/debian/netdata-plugins-nodejs.install b/debian/netdata-plugins-nodejs.install
index 580442978..0ace52d81 100644
--- a/debian/netdata-plugins-nodejs.install
+++ b/debian/netdata-plugins-nodejs.install
@@ -1,2 +1,2 @@
-/usr/lib/*/netdata/node.d
-/usr/lib/*/netdata/plugins.d/node.d.plugin
+/usr/lib/*/netdata/node.d /usr/share/javascript/netdata
+/usr/lib/*/netdata/plugins.d/node.d.plugin /usr/share/javascript/netdata
diff --git a/debian/netdata.links.in b/debian/netdata.links.in
new file mode 100644
index 000000000..727bc09dc
--- /dev/null
+++ b/debian/netdata.links.in
@@ -0,0 +1,2 @@
+#/usr/share/javascript/netdata/node.d /usr/lib/@DEB_HOST_MULTIARCH@/netdata/
+#/usr/share/javascript/netdata/plugins.d/node.d.plugin /usr/lib/@DEB_HOST_MULTIARCH@/netdata/plugins.d/
diff --git a/debian/netdata.lintian-overrides b/debian/netdata.lintian-overrides
index a50a17531..23c0880b4 100644
--- a/debian/netdata.lintian-overrides
+++ b/debian/netdata.lintian-overrides
@@ -1,15 +1,3 @@
# See Debian policy 10.9. apps.plugin has extra capabilities, so don't let
# normal users run it.
netdata: non-standard-executable-perm usr/lib/*/netdata/plugins.d/apps.plugin 0754 != 0755
-
-
-# FontAwesome is at least in the fonts-font-awesome package, but this is
-# not available in wheezy. glyphicons-halflings-regular isn't currently in
-# a Debian package. Therefore don't complain about shipping them with netdata
-# for the time being.
-netdata: duplicate-font-file usr/share/netdata/fonts/*
-netdata: font-in-non-font-package usr/share/netdata/fonts/*
-
-# Files here are marked as conffiles so that local updates to the html files
-# isn't clobbered on upgrade.
-netdata: non-etc-file-marked-as-conffile var/lib/netdata/www/*
diff --git a/debian/rules b/debian/rules
index e853d24a8..43f312add 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,6 +11,8 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_CFLAGS_MAINT_APPEND = -Wall -O3
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+MULTIARCH_INSTALL = debian/netdata.postinst \
+ debian/netdata.links
%:
# For jessie and beyond
#
@@ -25,16 +27,16 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
override_dh_auto_configure:
dh_auto_configure -- --with-math
-debian/%.postinst: debian/%.postinst.in
+$(MULTIARCH_INSTALL): % : %.in
sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
-override_dh_install: debian/netdata.postinst
+override_dh_install: $(MULTIARCH_INSTALL)
dh_install
# Remove unneeded .keep files
#
find "$(TOP)" -name .keep -exec rm '{}' ';'
- rm -rf $(CURDIR)/debian/netdata-data/usr/share/netdata/web/old
+ rm -rf $(TOP)-data/usr/share/netdata/web/old
# Move files that local user shouldn't be editing to /usr/share/netdata
#
@@ -65,16 +67,3 @@ override_dh_fixperms:
# given extra capabilities in the postinst script.
#
chmod 0754 $(TOP)/usr/lib/$(DEB_HOST_MULTIARCH)/netdata/plugins.d/apps.plugin
-
-override_dh_installlogrotate:
- dh_installlogrotate
-
-override_dh_clean:
- dh_clean
-
- # Tidy up copied/generated files
- rm -f $(CURDIR)/debian/netdata.postinst
- rm -f $(CURDIR)/debian/netdata.conffiles
-
-override_dh_installchangelogs:
- dh_installchangelogs ChangeLog