summaryrefslogtreecommitdiffstats
path: root/fluent-bit/CODEOWNERS
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:22 +0000
commitc21c3b0befeb46a51b6bf3758ffa30813bea0ff0 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /fluent-bit/CODEOWNERS
parentAdding upstream version 1.43.2. (diff)
downloadnetdata-upstream/1.44.3.tar.xz
netdata-upstream/1.44.3.zip
Adding upstream version 1.44.3.upstream/1.44.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fluent-bit/CODEOWNERS')
-rw-r--r--fluent-bit/CODEOWNERS95
1 files changed, 95 insertions, 0 deletions
diff --git a/fluent-bit/CODEOWNERS b/fluent-bit/CODEOWNERS
new file mode 100644
index 000000000..98504a4f7
--- /dev/null
+++ b/fluent-bit/CODEOWNERS
@@ -0,0 +1,95 @@
+# Fluent Bit Code Owners
+# ----------------------
+# The following file list the code owners or responsibles for code
+# review on different components or extensions of Fluent Bit, applicable for
+# any original code author (not only maintainers).
+#
+# NOTE: if you are a original code author and you are not listed here, please
+# open a PR with the proper modification :)
+
+# Global Owners
+# -------------
+* @edsiper @leonardo-albertovich @fujimotos @koleini
+
+# Build System & Portability
+# --------------------------
+/CMakeLists.txt @fujimotos @niedbalski @patrick-stephens @celalettin1286
+/cmake/ @fujimotos @niedbalski @patrick-stephens @celalettin1286
+
+# CI
+# -------------------------
+/.github/ @niedbalski @patrick-stephens @celalettin1286
+/appveyor.yml @niedbalski @patrick-stephens @celalettin1286
+/dockerfiles/ @niedbalski @patrick-stephens @celalettin1286
+/packaging/ @niedbalski @patrick-stephens @celalettin1286
+/codebase-structure.svg @niedbalski @patrick-stephens @celalettin1286
+/install.sh @niedbalski @patrick-stephens @celalettin1286
+
+# Core: Signv4
+# ------------
+/src/flb_signv4.c @pettitwesley
+/src/flb_lib.c @edsiper @niedbalski
+
+# Core: AWS Auth & Utils
+# ------------
+/src/aws @pettitwesley
+
+# AWS header files
+/include/aws @pettitwesley
+/include/flb_aws_credentials.h @pettitwesley
+/include/flb_aws_util.h @pettitwesley
+
+# Core: Stream Processor
+# ----------------
+/src/stream_processor/ @koleini
+
+# Input Plugins
+# -------------
+/plugins/in_collectd @fujimotos
+/plugins/in_docker @nokute78 @edsiper
+/plugins/in_dummy @nokute78
+/plugins/in_netif @nokute78
+/plugins/in_statsd @fujimotos
+/plugins/in_thermal @nokute78
+/plugins/in_winlog @fujimotos
+
+# Filter Plugins
+# --------------
+/plugins/filter_aws @pettitwesley
+/plugins/filter_ecs @pettitwesley
+
+# Output Plugins
+# --------------
+/plugins/out_datadog @nokute78 @edsiper
+/plugins/out_es @pettitwesley @edsiper
+/plugins/out_pgsql @sxd
+/plugins/out_stackdriver @braydonk @igorpeshansky @qingling128
+
+# AWS Plugins
+/plugins/out_s3 @pettitwesley
+/plugins/out_cloudwatch_logs @pettitwesley
+/plugins/out_kinesis_firehose @pettitwesley
+/plugins/out_kinesis_streams @pettitwesley
+/plugins/out_opensearch @pettitwesley @edsiper
+
+# AWS test code
+/tests/internal/aws @pettitwesley
+/tests/internal/aws_* @pettitwesley
+/tests/runtime/filter_ecs.c @pettitwesley
+/tests/runtime/filter_aws.c @pettitwesley
+/tests/runtime/out_cloudwatch.c @pettitwesley
+/tests/runtime/out_firehose.c @pettitwesley
+/tests/runtime/out_kinesis.c @pettitwesley
+/tests/runtime/out_opensearch.c @pettitwesley @edsiper
+/tests/runtime/out_s3.c @pettitwesley
+
+# Google test code
+# --------------
+/tests/runtime/out_stackdriver.c @braydonk @igorpeshansky @qingling128
+
+# Devcontainer
+/.devcontainer @patrick-stephens @niedbalski @edsiper
+
+# Calytia Fleet
+/plugins/custom_calyptia/ @pwhelan
+/plugins/in_calyptia_fleet/ @pwhelan