summaryrefslogtreecommitdiffstats
path: root/fluent-bit/examples/hello_world/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:20:02 +0000
commit58daab21cd043e1dc37024a7f99b396788372918 (patch)
tree96771e43bb69f7c1c2b0b4f7374cb74d7866d0cb /fluent-bit/examples/hello_world/CMakeLists.txt
parentReleasing debian version 1.43.2-1. (diff)
downloadnetdata-58daab21cd043e1dc37024a7f99b396788372918.tar.xz
netdata-58daab21cd043e1dc37024a7f99b396788372918.zip
Merging upstream version 1.44.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fluent-bit/examples/hello_world/CMakeLists.txt')
-rw-r--r--fluent-bit/examples/hello_world/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/fluent-bit/examples/hello_world/CMakeLists.txt b/fluent-bit/examples/hello_world/CMakeLists.txt
new file mode 100644
index 000000000..2e55b75f0
--- /dev/null
+++ b/fluent-bit/examples/hello_world/CMakeLists.txt
@@ -0,0 +1,9 @@
+set(src
+ ${src}
+ hello_world.c
+ )
+
+find_package (Threads)
+add_executable(hello_world ${src})
+target_link_libraries(hello_world fluent-bit-shared)
+target_link_libraries(hello_world ${CMAKE_THREAD_LIBS_INIT})