summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/decrease/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:22 +0000
commitc21c3b0befeb46a51b6bf3758ffa30813bea0ff0 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/decrease/Makefile
parentAdding upstream version 1.43.2. (diff)
downloadnetdata-c21c3b0befeb46a51b6bf3758ffa30813bea0ff0.tar.xz
netdata-c21c3b0befeb46a51b6bf3758ffa30813bea0ff0.zip
Adding upstream version 1.44.3.upstream/1.44.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/decrease/Makefile')
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/decrease/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/decrease/Makefile b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/decrease/Makefile
new file mode 100644
index 000000000..d99008beb
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/decrease/Makefile
@@ -0,0 +1,29 @@
+# Copyright (C) 2019 Intel Corporation. All rights reserved.
+# SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
+
+CC = /opt/wasi-sdk/bin/clang
+APP_DIR = ${shell pwd}
+IWASM_DIR = $(APP_DIR)/../../../../core/iwasm
+SDK_DIR = $(APP_DIR)/../../../../wamr-sdk/out/gui/app-sdk
+APP_FRAMEWORK_DIR = $(APP_DIR)/../../../../wamr-sdk/out/gui/app-sdk/wamr-app-framework
+DEPS_DIR = $(APP_DIR)/../../../../core/deps
+
+CFLAGS += -O3 \
+ -Wno-int-conversion \
+ -I$(APP_DIR)/src \
+ -I$(APP_FRAMEWORK_DIR)/include \
+ -I${DEPS_DIR}
+
+SRCS += $(APP_DIR)/src/main.c
+
+all:
+ @$(CC) $(CFLAGS) $(SRCS) \
+ --target=wasm32 -O3 -z stack-size=2048 -Wl,--initial-memory=65536 \
+ --sysroot=$(SDK_DIR)/libc-builtin-sysroot \
+ -L$(APP_FRAMEWORK_DIR)/lib -lapp_framework \
+ -Wl,--allow-undefined-file=$(SDK_DIR)/libc-builtin-sysroot/share/defined-symbols.txt \
+ -Wl,--strip-all,--no-entry -nostdlib \
+ -Wl,--export=on_init -Wl,--export=on_timer_callback \
+ -Wl,--export=on_widget_event \
+ -Wl,--export=__heap_base,--export=__data_end \
+ -o ui_decrease.wasm