summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-09 13:19:22 +0000
commitc21c3b0befeb46a51b6bf3758ffa30813bea0ff0 (patch)
tree9754ff1ca740f6346cf8483ec915d4054bc5da2d /fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase
parentAdding upstream version 1.43.2. (diff)
downloadnetdata-c21c3b0befeb46a51b6bf3758ffa30813bea0ff0.tar.xz
netdata-c21c3b0befeb46a51b6bf3758ffa30813bea0ff0.zip
Adding upstream version 1.44.3.upstream/1.44.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase')
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/CMakeLists.txt20
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/Makefile34
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/src/main.c84
3 files changed, 138 insertions, 0 deletions
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/CMakeLists.txt b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/CMakeLists.txt
new file mode 100644
index 000000000..ce55fb1e6
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/CMakeLists.txt
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(wgl)
+
+set (WAMR_ROOT_DIR ${CMAKE_CURRENT_LIST_DIR}/../../../../)
+
+include_directories(
+ ${WAMR_ROOT_DIR}/wamr-sdk/out/gui/app-sdk/wamr-app-framework/include
+ ${WAMR_ROOT_DIR}/core/deps
+)
+
+set (CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS},-L${WAMR_ROOT_DIR}/wamr-sdk/out/gui/app-sdk/wamr-app-framework/lib")
+set (CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS},--export=on_init,--export=on_timer_callback,--export=on_widget_event,--export=__heap_base,--export=__data_end")
+set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O3 -Wno-unused-command-line-argument")
+
+add_executable(ui_increase.wasm
+ ${CMAKE_CURRENT_LIST_DIR}/src/main.c
+)
+
+target_link_libraries(ui_increase.wasm app_framework)
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/Makefile b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/Makefile
new file mode 100644
index 000000000..5f250d6ef
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/Makefile
@@ -0,0 +1,34 @@
+# Copyright (C) 2019 Intel Corporation. All rights reserved.
+# SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
+
+CC = /opt/wasi-sdk/bin/clang
+APP_DIR = ${shell pwd}
+IWASM_DIR = ../../../../core/iwasm
+APP_FRAMEWORK_DIR = ../../../../core/app-framework
+DEPS_DIR = ../../../../core/deps
+
+CFLAGS += -O3 \
+ -Wno-int-conversion \
+ -I$(APP_DIR)/src \
+ -I$(APP_FRAMEWORK_DIR)/base/app \
+ -I$(APP_FRAMEWORK_DIR)/app-native-shared \
+ -I$(APP_FRAMEWORK_DIR)/sensor/app \
+ -I$(APP_FRAMEWORK_DIR)/wgl/app \
+ -I$(APP_FRAMEWORK_DIR)/connection/app \
+ -I${DEPS_DIR}
+
+SRCS += $(APP_DIR)/src/main.c
+
+# For app size consideration, not all but necessary app libs are included
+SRCS += $(APP_FRAMEWORK_DIR)/base/app/timer.c
+SRCS += $(APP_FRAMEWORK_DIR)/wgl/app/src/*.c
+
+all:
+ @$(CC) $(CFLAGS) $(SRCS) \
+ --target=wasm32-wasi -O3 -z stack-size=2048 -Wl,--initial-memory=65536 \
+ -nostdlib -Wl,--allow-undefined \
+ -Wl,--strip-all,--no-entry \
+ -Wl,--export=on_init -Wl,--export=on_timer_callback \
+ -Wl,--export=on_widget_event \
+ -Wl,--export=__heap_base,--export=__data_end \
+ -o ui_app.wasm
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/src/main.c b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/src/main.c
new file mode 100644
index 000000000..b5271830a
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/gui/wasm-apps/increase/src/main.c
@@ -0,0 +1,84 @@
+/*
+ * Copyright (C) 2019 Intel Corporation. All rights reserved.
+ * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
+ */
+
+#include <stdlib.h>
+#include "wasm_app.h"
+#include "wa-inc/lvgl/lvgl.h"
+#include "wa-inc/timer_wasm_app.h"
+
+extern char g_widget_text[];
+
+static void
+btn_event_cb(lv_obj_t *btn, lv_event_t event);
+
+uint32_t count = 0;
+char count_str[11] = { 0 };
+lv_obj_t *hello_world_label;
+lv_obj_t *count_label;
+lv_obj_t *btn1;
+lv_obj_t *label_count1;
+int label_count1_value = 1;
+char label_count1_str[11] = { 0 };
+
+void
+timer1_update(user_timer_t timer1)
+{
+ if ((count % 100) == 0) {
+ snprintf(count_str, sizeof(count_str), "%d", count / 100);
+ lv_label_set_text(count_label, count_str);
+ }
+ ++count;
+}
+
+void
+on_init()
+{
+ char *text;
+
+ hello_world_label = lv_label_create(NULL, NULL);
+ lv_label_set_text(hello_world_label, "Hello world!");
+ text = lv_label_get_text(hello_world_label);
+ printf("Label text %lu %s \n", strlen(text), text);
+ lv_obj_align(hello_world_label, NULL, LV_ALIGN_IN_TOP_LEFT, 0, 0);
+
+ count_label = lv_label_create(NULL, NULL);
+ lv_obj_align(count_label, NULL, LV_ALIGN_IN_TOP_MID, 0, 0);
+
+ btn1 = lv_btn_create(
+ NULL, NULL); /*Create a button on the currently loaded screen*/
+ lv_obj_set_event_cb(
+ btn1,
+ btn_event_cb); /*Set function to be called when the button is released*/
+ lv_obj_align(btn1, NULL, LV_ALIGN_CENTER, 0, 0); /*Align below the label*/
+
+ /*Create a label on the button*/
+ lv_obj_t *btn_label = lv_label_create(btn1, NULL);
+ lv_label_set_text(btn_label, "Click ++");
+
+ label_count1 = lv_label_create(NULL, NULL);
+ lv_label_set_text(label_count1, "1");
+ lv_obj_align(label_count1, NULL, LV_ALIGN_IN_BOTTOM_MID, 0, 0);
+
+ /* set up a timer */
+ user_timer_t timer;
+ timer = api_timer_create(10, true, false, timer1_update);
+ if (timer)
+ api_timer_restart(timer, 10);
+ else
+ printf("Fail to create timer.\n");
+}
+
+static void
+btn_event_cb(lv_obj_t *btn, lv_event_t event)
+{
+ if (event == LV_EVENT_RELEASED) {
+ label_count1_value++;
+ snprintf(label_count1_str, sizeof(label_count1_str), "%d",
+ label_count1_value);
+ lv_label_set_text(label_count1, label_count1_str);
+ if (label_count1_value == 100)
+ label_count1_value = 0;
+ }
+}