summaryrefslogtreecommitdiffstats
path: root/ml/dlib/tools/imglab/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 11:19:16 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:07:37 +0000
commitb485aab7e71c1625cfc27e0f92c9509f42378458 (patch)
treeae9abe108601079d1679194de237c9a435ae5b55 /ml/dlib/tools/imglab/CMakeLists.txt
parentAdding upstream version 1.44.3. (diff)
downloadnetdata-b485aab7e71c1625cfc27e0f92c9509f42378458.tar.xz
netdata-b485aab7e71c1625cfc27e0f92c9509f42378458.zip
Adding upstream version 1.45.3+dfsg.upstream/1.45.3+dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ml/dlib/tools/imglab/CMakeLists.txt')
-rw-r--r--ml/dlib/tools/imglab/CMakeLists.txt41
1 files changed, 0 insertions, 41 deletions
diff --git a/ml/dlib/tools/imglab/CMakeLists.txt b/ml/dlib/tools/imglab/CMakeLists.txt
deleted file mode 100644
index 46c64fb3e..000000000
--- a/ml/dlib/tools/imglab/CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# This is a CMake makefile. You can find the cmake utility and
-# information about it at http://www.cmake.org
-#
-
-cmake_minimum_required(VERSION 2.8.12)
-
-# create a variable called target_name and set it to the string "imglab"
-set (target_name imglab)
-
-PROJECT(${target_name})
-add_subdirectory(../../dlib dlib_build)
-
-# add all the cpp files we want to compile to this list. This tells
-# cmake that they are part of our target (which is the executable named imglab)
-add_executable(${target_name}
- src/main.cpp
- src/metadata_editor.h
- src/metadata_editor.cpp
- src/convert_pascal_xml.h
- src/convert_pascal_xml.cpp
- src/convert_pascal_v1.h
- src/convert_pascal_v1.cpp
- src/convert_idl.h
- src/convert_idl.cpp
- src/common.h
- src/common.cpp
- src/cluster.cpp
- src/flip_dataset.cpp
-)
-
-
-# Tell cmake to link our target executable to dlib.
-target_link_libraries(${target_name} dlib::dlib )
-
-
-install(TARGETS ${target_name}
- RUNTIME DESTINATION bin
- )
-install(PROGRAMS convert_imglab_paths_to_relative copy_imglab_dataset DESTINATION bin )
-