summaryrefslogtreecommitdiffstats
path: root/netdata-9999.ebuild
diff options
context:
space:
mode:
authorFederico Ceratto <federico.ceratto@gmail.com>2016-03-30 21:40:42 +0000
committerFederico Ceratto <federico.ceratto@gmail.com>2016-03-30 21:40:42 +0000
commit9ce153ce7167c11adba8ac225edc7a707e97c6eb (patch)
tree9f6e849cce2dcc7e5b4e9e6252c843dc2d0787a2 /netdata-9999.ebuild
downloadnetdata-9ce153ce7167c11adba8ac225edc7a707e97c6eb.tar.xz
netdata-9ce153ce7167c11adba8ac225edc7a707e97c6eb.zip
Imported Upstream version 1.0.0upstream/1.0.0
Diffstat (limited to 'netdata-9999.ebuild')
-rw-r--r--netdata-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/netdata-9999.ebuild b/netdata-9999.ebuild
new file mode 100644
index 000000000..768b9ec1d
--- /dev/null
+++ b/netdata-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools git-2 user
+
+DESCRIPTION="Linux real time system monitoring, over the web!"
+HOMEPAGE="https://github.com/firehol/netdata"
+EGIT_REPO_URI="https://github.com/firehol/netdata"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE="nfacct +zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ nfacct? (
+ net-firewall/nfacct
+ net-libs/libmnl
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ enewgroup netdata
+ enewuser netdata -1 -1 / netdata
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EROOT}var" \
+ $(use_enable nfacct plugin-nfacct) \
+ $(use_with zlib) \
+ --with-user=netdata
+}
+
+src_install() {
+ default
+ fowners netdata /var/log/netdata
+ rm -fr "${ED}/var/cache/netdata"
+}