summaryrefslogtreecommitdiffstats
path: root/node.d
diff options
context:
space:
mode:
authorFederico Ceratto <federico.ceratto@gmail.com>2016-11-23 15:49:10 +0000
committerFederico Ceratto <federico.ceratto@gmail.com>2016-11-23 15:49:10 +0000
commit87649cf32bd0e14d5a903fb85b01e9f41a253540 (patch)
treebbefda6dac074aeb87529592e8e5064f69cbe024 /node.d
parentImported Upstream version 1.3.0+dfsg (diff)
downloadnetdata-87649cf32bd0e14d5a903fb85b01e9f41a253540.tar.xz
netdata-87649cf32bd0e14d5a903fb85b01e9f41a253540.zip
New upstream version 1.4.0+dfsgupstream/1.4.0+dfsg
Diffstat (limited to 'node.d')
-rw-r--r--node.d/Makefile.in12
-rw-r--r--node.d/sma_webbox.node.js12
2 files changed, 16 insertions, 8 deletions
diff --git a/node.d/Makefile.in b/node.d/Makefile.in
index 12a870f59..b338c0bdc 100644
--- a/node.d/Makefile.in
+++ b/node.d/Makefile.in
@@ -83,8 +83,13 @@ DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
$(dist_node_DATA) $(dist_nodemodules_DATA) \
$(dist_nodemodulesber_DATA)
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-am__aclocal_m4_deps = $(top_srcdir)/m4/ax_pthread.m4 \
- $(top_srcdir)/configure.ac
+am__aclocal_m4_deps = $(top_srcdir)/m4/ax_c___atomic.m4 \
+ $(top_srcdir)/m4/ax_c__generic.m4 \
+ $(top_srcdir)/m4/ax_c_mallinfo.m4 \
+ $(top_srcdir)/m4/ax_c_mallopt.m4 \
+ $(top_srcdir)/m4/ax_check_compile_flag.m4 \
+ $(top_srcdir)/m4/ax_pthread.m4 $(top_srcdir)/m4/jemalloc.m4 \
+ $(top_srcdir)/m4/tcmalloc.m4 $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
mkinstalldirs = $(install_sh) -d
@@ -209,6 +214,7 @@ PTHREAD_CFLAGS = @PTHREAD_CFLAGS@
PTHREAD_LIBS = @PTHREAD_LIBS@
SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
+SSE_CANDIDATE = @SSE_CANDIDATE@
STRIP = @STRIP@
UUID_CFLAGS = @UUID_CFLAGS@
UUID_LIBS = @UUID_LIBS@
@@ -241,6 +247,8 @@ datarootdir = @datarootdir@
docdir = @docdir@
dvidir = @dvidir@
exec_prefix = @exec_prefix@
+has_jemalloc = @has_jemalloc@
+has_tcmalloc = @has_tcmalloc@
host = @host@
host_alias = @host_alias@
host_cpu = @host_cpu@
diff --git a/node.d/sma_webbox.node.js b/node.d/sma_webbox.node.js
index a6ce12052..3dd17a5c1 100644
--- a/node.d/sma_webbox.node.js
+++ b/node.d/sma_webbox.node.js
@@ -74,7 +74,7 @@ var webbox = {
// Grid Current Power Chart
if(d['GriPwr'].value !== null) {
- var id = 'sma_webbox_' + service.name + '.current';
+ var id = 'smawebbox_' + service.name + '.current';
var chart = webbox.charts[id];
if(typeof chart === 'undefined') {
@@ -84,7 +84,7 @@ var webbox = {
title: service.name + ' Current Grid Power', // the title of the chart
units: d['GriPwr'].unit, // the units of the chart dimensions
family: 'now', // the family of the chart
- context: 'sma_webbox.grid.power', // the context of the chart
+ context: 'smawebbox.grid_power', // the context of the chart
type: netdata.chartTypes.area, // the type of the chart
priority: webbox.base_priority + 1, // the priority relative to others in the same family
update_every: service.update_every, // the expected update frequency of the chart
@@ -110,7 +110,7 @@ var webbox = {
}
if(d['GriEgyTdy'].value !== null) {
- var id = 'sma_webbox_' + service.name + '.today';
+ var id = 'smawebbox_' + service.name + '.today';
var chart = webbox.charts[id];
if(typeof chart === 'undefined') {
@@ -120,7 +120,7 @@ var webbox = {
title: service.name + ' Today Grid Power', // the title of the chart
units: d['GriEgyTdy'].unit, // the units of the chart dimensions
family: 'today', // the family of the chart
- context: 'sma_webbox.grid.power.today', // the context of the chart
+ context: 'smawebbox.grid_power_today', // the context of the chart
type: netdata.chartTypes.area, // the type of the chart
priority: webbox.base_priority + 2, // the priority relative to others in the same family
update_every: service.update_every, // the expected update frequency of the chart
@@ -146,7 +146,7 @@ var webbox = {
}
if(d['GriEgyTot'].value !== null) {
- var id = 'sma_webbox_' + service.name + '.total';
+ var id = 'smawebbox_' + service.name + '.total';
var chart = webbox.charts[id];
if(typeof chart === 'undefined') {
@@ -156,7 +156,7 @@ var webbox = {
title: service.name + ' Total Grid Power', // the title of the chart
units: d['GriEgyTot'].unit, // the units of the chart dimensions
family: 'total', // the family of the chart
- context: 'sma_webbox.grid.power.total', // the context of the chart
+ context: 'smawebbox.grid_power_total', // the context of the chart
type: netdata.chartTypes.area, // the type of the chart
priority: webbox.base_priority + 3, // the priority relative to others in the same family
update_every: service.update_every, // the expected update frequency of the chart