summaryrefslogtreecommitdiffstats
path: root/packaging/makeself/jobs/50-bash-5.1.8.install.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-04-14 18:12:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-04-14 18:12:10 +0000
commitb5321aff06d6ea8d730d62aec2ffd8e9271c1ffc (patch)
tree36c41e35994786456154f9d3bf88c324763aeea4 /packaging/makeself/jobs/50-bash-5.1.8.install.sh
parentAdding upstream version 1.33.1. (diff)
downloadnetdata-b5321aff06d6ea8d730d62aec2ffd8e9271c1ffc.tar.xz
netdata-b5321aff06d6ea8d730d62aec2ffd8e9271c1ffc.zip
Adding upstream version 1.34.0.upstream/1.34.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'packaging/makeself/jobs/50-bash-5.1.8.install.sh')
-rwxr-xr-xpackaging/makeself/jobs/50-bash-5.1.8.install.sh41
1 files changed, 0 insertions, 41 deletions
diff --git a/packaging/makeself/jobs/50-bash-5.1.8.install.sh b/packaging/makeself/jobs/50-bash-5.1.8.install.sh
deleted file mode 100755
index 22c9286af..000000000
--- a/packaging/makeself/jobs/50-bash-5.1.8.install.sh
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/usr/bin/env bash
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# shellcheck source=packaging/makeself/functions.sh
-. "$(dirname "${0}")/../functions.sh" "${@}" || exit 1
-
-# shellcheck disable=SC2015
-[ "${GITHUB_ACTIONS}" = "true" ] && echo "::group::building bash" || true
-
-fetch "bash-5.1.8" "http://ftp.gnu.org/gnu/bash/bash-5.1.8.tar.gz" \
- 0cfb5c9bb1a29f800a97bd242d19511c997a1013815b805e0fdd32214113d6be
-
-export PKG_CONFIG_PATH="/openssl-static/lib/pkgconfig"
-
-run ./configure \
- --prefix="${NETDATA_INSTALL_PATH}" \
- --without-bash-malloc \
- --enable-static-link \
- --enable-net-redirections \
- --enable-array-variables \
- --disable-progcomp \
- --disable-profiling \
- --disable-nls
-
-run make clean
-run make -j "$(nproc)"
-
-cat > examples/loadables/Makefile << EOF
-all:
-clean:
-install:
-EOF
-
-run make install
-
-if [ "${NETDATA_BUILD_WITH_DEBUG}" -eq 0 ]; then
- run strip "${NETDATA_INSTALL_PATH}"/bin/bash
-fi
-
-# shellcheck disable=SC2015
-[ "${GITHUB_ACTIONS}" = "true" ] && echo "::endgroup::" || true