summaryrefslogtreecommitdiffstats
path: root/packaging/makeself/jobs/50-curl-7.73.0.install.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-01 06:15:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-01 06:15:04 +0000
commite970e0b37b8bd7f246feb3f70c4136418225e434 (patch)
tree0b67c0ca45f56f2f9d9c5c2e725279ecdf52d2eb /packaging/makeself/jobs/50-curl-7.73.0.install.sh
parentAdding upstream version 1.31.0. (diff)
downloadnetdata-e970e0b37b8bd7f246feb3f70c4136418225e434.tar.xz
netdata-e970e0b37b8bd7f246feb3f70c4136418225e434.zip
Adding upstream version 1.32.0.upstream/1.32.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'packaging/makeself/jobs/50-curl-7.73.0.install.sh')
-rwxr-xr-xpackaging/makeself/jobs/50-curl-7.73.0.install.sh36
1 files changed, 0 insertions, 36 deletions
diff --git a/packaging/makeself/jobs/50-curl-7.73.0.install.sh b/packaging/makeself/jobs/50-curl-7.73.0.install.sh
deleted file mode 100755
index 4a9505e58..000000000
--- a/packaging/makeself/jobs/50-curl-7.73.0.install.sh
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/usr/bin/env bash
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# shellcheck source=packaging/makeself/functions.sh
-. "$(dirname "${0}")/../functions.sh" "${@}" || exit 1
-
-fetch "curl-7.73.0" "https://curl.haxx.se/download/curl-7.73.0.tar.gz"
-
-export CFLAGS="-I/openssl-static/include"
-export LDFLAGS="-static -L/openssl-static/lib"
-export PKG_CONFIG="pkg-config --static"
-export PKG_CONFIG_PATH="/openssl-static/lib/pkgconfig"
-
-run autoreconf -fi
-
-run ./configure \
- --prefix="${NETDATA_INSTALL_PATH}" \
- --enable-optimize \
- --disable-shared \
- --enable-static \
- --enable-http \
- --enable-proxy \
- --enable-ipv6 \
- --enable-cookies \
- --with-ca-fallback
-
-# Curl autoconf does not honour the curl_LDFLAGS environment variable
-run sed -i -e "s/curl_LDFLAGS =/curl_LDFLAGS = -all-static/" src/Makefile
-
-run make clean
-run make -j "$(nproc)"
-run make install
-
-if [ ${NETDATA_BUILD_WITH_DEBUG} -eq 0 ]; then
- run strip "${NETDATA_INSTALL_PATH}"/bin/curl
-fi