summaryrefslogtreecommitdiffstats
path: root/web/api/queries/trimmed_mean
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 11:19:16 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 12:07:37 +0000
commitb485aab7e71c1625cfc27e0f92c9509f42378458 (patch)
treeae9abe108601079d1679194de237c9a435ae5b55 /web/api/queries/trimmed_mean
parentAdding upstream version 1.44.3. (diff)
downloadnetdata-b485aab7e71c1625cfc27e0f92c9509f42378458.tar.xz
netdata-b485aab7e71c1625cfc27e0f92c9509f42378458.zip
Adding upstream version 1.45.3+dfsg.upstream/1.45.3+dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'web/api/queries/trimmed_mean')
-rw-r--r--web/api/queries/trimmed_mean/Makefile.am8
-rw-r--r--web/api/queries/trimmed_mean/README.md60
-rw-r--r--web/api/queries/trimmed_mean/trimmed_mean.c7
-rw-r--r--web/api/queries/trimmed_mean/trimmed_mean.h169
4 files changed, 0 insertions, 244 deletions
diff --git a/web/api/queries/trimmed_mean/Makefile.am b/web/api/queries/trimmed_mean/Makefile.am
deleted file mode 100644
index 161784b8f..000000000
--- a/web/api/queries/trimmed_mean/Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-AUTOMAKE_OPTIONS = subdir-objects
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
-
-dist_noinst_DATA = \
- README.md \
- $(NULL)
diff --git a/web/api/queries/trimmed_mean/README.md b/web/api/queries/trimmed_mean/README.md
deleted file mode 100644
index 328c44942..000000000
--- a/web/api/queries/trimmed_mean/README.md
+++ /dev/null
@@ -1,60 +0,0 @@
-<!--
-title: "Trimmed Mean"
-sidebar_label: "Trimmed Mean"
-description: "Use trimmed-mean in API queries and health entities to find the average value from a sample, eliminating any unwanted spikes in the returned metrics."
-custom_edit_url: https://github.com/netdata/netdata/edit/master/web/api/queries/trimmed_mean/README.md
-learn_status: "Published"
-learn_topic_type: "References"
-learn_rel_path: "Developers/Web/Api/Queries"
--->
-
-# Trimmed Mean
-
-The trimmed mean is the average value of a series excluding the smallest and biggest points.
-
-Netdata applies linear interpolation on the last point, if the percentage requested to be excluded does not give a
-round number of points.
-
-The following percentile aliases are defined:
-
-- `trimmed-mean1`
-- `trimmed-mean2`
-- `trimmed-mean3`
-- `trimmed-mean5`
-- `trimmed-mean10`
-- `trimmed-mean15`
-- `trimmed-mean20`
-- `trimmed-mean25`
-
-The default `trimmed-mean` is an alias for `trimmed-mean5`.
-Any percentage may be requested using the `group_options` query parameter.
-
-## how to use
-
-Use it in alerts like this:
-
-```
- alarm: my_alert
- on: my_chart
-lookup: trimmed-mean5 -1m unaligned of my_dimension
- warn: $this > 1000
-```
-
-`trimmed-mean` does not change the units. For example, if the chart units is `requests/sec`, the result
-will be again expressed in the same units.
-
-It can also be used in APIs and badges as `&group=trimmed-mean` in the URL and the additional parameter `group_options`
-may be used to request any percentage (e.g. `&group=trimmed-mean&group_options=29`).
-
-## Examples
-
-Examining last 1 minute `successful` web server responses:
-
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=min&after=-60&label=min)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=average&after=-60&label=average)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=trimmed-mean5&after=-60&label=trimmed-mean5&value_color=orange)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=max&after=-60&label=max)
-
-## References
-
-- <https://en.wikipedia.org/wiki/Truncated_mean>.
diff --git a/web/api/queries/trimmed_mean/trimmed_mean.c b/web/api/queries/trimmed_mean/trimmed_mean.c
deleted file mode 100644
index c50db7ed6..000000000
--- a/web/api/queries/trimmed_mean/trimmed_mean.c
+++ /dev/null
@@ -1,7 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#include "trimmed_mean.h"
-
-// ----------------------------------------------------------------------------
-// median
-
diff --git a/web/api/queries/trimmed_mean/trimmed_mean.h b/web/api/queries/trimmed_mean/trimmed_mean.h
deleted file mode 100644
index 3c09015bf..000000000
--- a/web/api/queries/trimmed_mean/trimmed_mean.h
+++ /dev/null
@@ -1,169 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#ifndef NETDATA_API_QUERIES_TRIMMED_MEAN_H
-#define NETDATA_API_QUERIES_TRIMMED_MEAN_H
-
-#include "../query.h"
-#include "../rrdr.h"
-
-struct tg_trimmed_mean {
- size_t series_size;
- size_t next_pos;
- NETDATA_DOUBLE percent;
-
- NETDATA_DOUBLE *series;
-};
-
-static inline void tg_trimmed_mean_create_internal(RRDR *r, const char *options, NETDATA_DOUBLE def) {
- long entries = r->view.group;
- if(entries < 10) entries = 10;
-
- struct tg_trimmed_mean *g = (struct tg_trimmed_mean *)onewayalloc_callocz(r->internal.owa, 1, sizeof(struct tg_trimmed_mean));
- g->series = onewayalloc_mallocz(r->internal.owa, entries * sizeof(NETDATA_DOUBLE));
- g->series_size = (size_t)entries;
-
- g->percent = def;
- if(options && *options) {
- g->percent = str2ndd(options, NULL);
- if(!netdata_double_isnumber(g->percent)) g->percent = 0.0;
- if(g->percent < 0.0) g->percent = 0.0;
- if(g->percent > 50.0) g->percent = 50.0;
- }
-
- g->percent = 1.0 - ((g->percent / 100.0) * 2.0);
- r->time_grouping.data = g;
-}
-
-static inline void tg_trimmed_mean_create_1(RRDR *r, const char *options) {
- tg_trimmed_mean_create_internal(r, options, 1.0);
-}
-static inline void tg_trimmed_mean_create_2(RRDR *r, const char *options) {
- tg_trimmed_mean_create_internal(r, options, 2.0);
-}
-static inline void tg_trimmed_mean_create_3(RRDR *r, const char *options) {
- tg_trimmed_mean_create_internal(r, options, 3.0);
-}
-static inline void tg_trimmed_mean_create_5(RRDR *r, const char *options) {
- tg_trimmed_mean_create_internal(r, options, 5.0);
-}
-static inline void tg_trimmed_mean_create_10(RRDR *r, const char *options) {
- tg_trimmed_mean_create_internal(r, options, 10.0);
-}
-static inline void tg_trimmed_mean_create_15(RRDR *r, const char *options) {
- tg_trimmed_mean_create_internal(r, options, 15.0);
-}
-static inline void tg_trimmed_mean_create_20(RRDR *r, const char *options) {
- tg_trimmed_mean_create_internal(r, options, 20.0);
-}
-static inline void tg_trimmed_mean_create_25(RRDR *r, const char *options) {
- tg_trimmed_mean_create_internal(r, options, 25.0);
-}
-
-// resets when switches dimensions
-// so, clear everything to restart
-static inline void tg_trimmed_mean_reset(RRDR *r) {
- struct tg_trimmed_mean *g = (struct tg_trimmed_mean *)r->time_grouping.data;
- g->next_pos = 0;
-}
-
-static inline void tg_trimmed_mean_free(RRDR *r) {
- struct tg_trimmed_mean *g = (struct tg_trimmed_mean *)r->time_grouping.data;
- if(g) onewayalloc_freez(r->internal.owa, g->series);
-
- onewayalloc_freez(r->internal.owa, r->time_grouping.data);
- r->time_grouping.data = NULL;
-}
-
-static inline void tg_trimmed_mean_add(RRDR *r, NETDATA_DOUBLE value) {
- struct tg_trimmed_mean *g = (struct tg_trimmed_mean *)r->time_grouping.data;
-
- if(unlikely(g->next_pos >= g->series_size)) {
- g->series = onewayalloc_doublesize( r->internal.owa, g->series, g->series_size * sizeof(NETDATA_DOUBLE));
- g->series_size *= 2;
- }
-
- g->series[g->next_pos++] = value;
-}
-
-static inline NETDATA_DOUBLE tg_trimmed_mean_flush(RRDR *r, RRDR_VALUE_FLAGS *rrdr_value_options_ptr) {
- struct tg_trimmed_mean *g = (struct tg_trimmed_mean *)r->time_grouping.data;
-
- NETDATA_DOUBLE value;
- size_t available_slots = g->next_pos;
-
- if(unlikely(!available_slots)) {
- value = 0.0;
- *rrdr_value_options_ptr |= RRDR_VALUE_EMPTY;
- }
- else if(available_slots == 1) {
- value = g->series[0];
- }
- else {
- sort_series(g->series, available_slots);
-
- NETDATA_DOUBLE min = g->series[0];
- NETDATA_DOUBLE max = g->series[available_slots - 1];
-
- if (min != max) {
- size_t slots_to_use = (size_t)((NETDATA_DOUBLE)available_slots * g->percent);
- if(!slots_to_use) slots_to_use = 1;
-
- NETDATA_DOUBLE percent_to_use = (NETDATA_DOUBLE)slots_to_use / (NETDATA_DOUBLE)available_slots;
- NETDATA_DOUBLE percent_delta = g->percent - percent_to_use;
-
- NETDATA_DOUBLE percent_interpolation_slot = 0.0;
- NETDATA_DOUBLE percent_last_slot = 0.0;
- if(percent_delta > 0.0) {
- NETDATA_DOUBLE percent_to_use_plus_1_slot = (NETDATA_DOUBLE)(slots_to_use + 1) / (NETDATA_DOUBLE)available_slots;
- NETDATA_DOUBLE percent_1slot = percent_to_use_plus_1_slot - percent_to_use;
-
- percent_interpolation_slot = percent_delta / percent_1slot;
- percent_last_slot = 1 - percent_interpolation_slot;
- }
-
- int start_slot, stop_slot, step, last_slot, interpolation_slot;
- if(min >= 0.0 && max >= 0.0) {
- start_slot = (int)((available_slots - slots_to_use) / 2);
- stop_slot = start_slot + (int)slots_to_use;
- last_slot = stop_slot - 1;
- interpolation_slot = stop_slot;
- step = 1;
- }
- else {
- start_slot = (int)available_slots - 1 - (int)((available_slots - slots_to_use) / 2);
- stop_slot = start_slot - (int)slots_to_use;
- last_slot = stop_slot + 1;
- interpolation_slot = stop_slot;
- step = -1;
- }
-
- value = 0.0;
- for(int slot = start_slot; slot != stop_slot ; slot += step)
- value += g->series[slot];
-
- size_t counted = slots_to_use;
- if(percent_interpolation_slot > 0.0 && interpolation_slot >= 0 && interpolation_slot < (int)available_slots) {
- value += g->series[interpolation_slot] * percent_interpolation_slot;
- value += g->series[last_slot] * percent_last_slot;
- counted++;
- }
-
- value = value / (NETDATA_DOUBLE)counted;
- }
- else
- value = min;
- }
-
- if(unlikely(!netdata_double_isnumber(value))) {
- value = 0.0;
- *rrdr_value_options_ptr |= RRDR_VALUE_EMPTY;
- }
-
- //log_series_to_stderr(g->series, g->next_pos, value, "trimmed_mean");
-
- g->next_pos = 0;
-
- return value;
-}
-
-#endif //NETDATA_API_QUERIES_TRIMMED_MEAN_H