summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c70d1eac7..dcc55353e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,7 +26,7 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
dh ${@} --with apache2
execute_before_dh_autoreconf:
- mkdir -p mqtt_websockets
+ mkdir -p httpd mqtt_websockets
rm -f debian/configure.ac.orig
cp configure.ac debian/configure.ac.orig
@@ -59,6 +59,7 @@ override_dh_auto_configure:
--enable-plugin-cups \
--enable-plugin-nfacct \
--with-math
+ cp -a httpd/h2o build-core/httpd
cp -a mqtt_websockets system tests build-core
cp -a web/gui/src build-core/web/gui
@@ -73,6 +74,7 @@ ifeq (netdata-core-no-sse,$(findstring netdata-core-no-sse,$(PACKAGES)))
--enable-plugin-cups \
--enable-plugin-nfacct \
--with-math
+ cp -a httpd/h2o build-core-no-sse/httpd
cp -a mqtt_websockets system tests build-core-no-sse
cp -a web/gui/src build-core-no-sse/web/gui
endif