summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/control21
-rw-r--r--debian/netdata-plugins-go.install4
-rwxr-xr-xdebian/rules1
3 files changed, 25 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index dbe1e1f58..ec668dcfa 100644
--- a/debian/control
+++ b/debian/control
@@ -9,6 +9,9 @@ Build-Depends:
cmake,
curl,
debhelper-compat (= 13),
+ golang-any,
+ golang-github-imdario-mergo-dev,
+ golang-filippo-edwards25519-dev,
libbpf-dev,
libcap-dev,
libcups2-dev,
@@ -127,3 +130,21 @@ Description: real-time performance monitoring (python plugins)
systems it runs using interactive web dashboards.
.
This package contains the plugins using python.
+
+Package: netdata-plugins-go
+Section: net
+Architecture: all
+Multi-Arch: foreign
+Depends:
+ netdata (>= ${source:Version}),
+ ${misc:Depends},
+Provides:
+ netdata-plugins,
+Enhances:
+ netdata,
+Description: real-time performance monitoring (Go plugins)
+ Netdata is distributed, real-time, performance and health monitoring for
+ systems and applications. It provides insights of everything happening on the
+ systems it runs using interactive web dashboards.
+ .
+ This package contains the plugins written in Go.
diff --git a/debian/netdata-plugins-go.install b/debian/netdata-plugins-go.install
new file mode 100644
index 000000000..ef45bbb61
--- /dev/null
+++ b/debian/netdata-plugins-go.install
@@ -0,0 +1,4 @@
+etc/netdata/go.d
+usr/lib/netdata/conf.d/go.d
+usr/lib/netdata/conf.d/go.d.conf
+usr/libexec/netdata/plugins.d/go.d.plugin
diff --git a/debian/rules b/debian/rules
index 45164d635..e53562b0c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,7 +25,6 @@ override_dh_auto_configure:
# Linux eBPF metric collection
# Xen domain monitoring
dh_auto_configure -- \
- -DENABLE_PLUGIN_GO:BOOL=OFF \
-DENABLE_H2O:BOOL=OFF \
-DENABLE_LEGACY_EBPF_PROGRAMS:BOOL=OFF \
-DENABLE_ML:BOOL=OFF \