summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/patches/debian/0006-use-dlib.patch37
-rw-r--r--debian/patches/series1
2 files changed, 38 insertions, 0 deletions
diff --git a/debian/patches/debian/0006-use-dlib.patch b/debian/patches/debian/0006-use-dlib.patch
new file mode 100644
index 000000000..83206e208
--- /dev/null
+++ b/debian/patches/debian/0006-use-dlib.patch
@@ -0,0 +1,37 @@
+Author: Daniel Baumann <daniel@debian.org>
+Description: Use system dlib.
+
+diff -Naurp netdata.orig/CMakeLists.txt netdata/CMakeLists.txt
+--- netdata.orig/CMakeLists.txt
++++ netdata/CMakeLists.txt
+@@ -1194,7 +1194,6 @@ if(ENABLE_ML)
+ src/ml/ad_charts.h
+ src/ml/ad_charts.cc
+ src/ml/Config.cc
+- src/ml/dlib/dlib/all/source.cpp
+ src/ml/ml.h
+ src/ml/ml.cc
+ src/ml/ml-private.h
+diff -Naurp netdata.orig/src/ml/ml-private.h netdata/src/ml/ml-private.h
+--- netdata.orig/src/ml/ml-private.h
++++ netdata/src/ml/ml-private.h
+@@ -3,7 +3,7 @@
+ #ifndef NETDATA_ML_PRIVATE_H
+ #define NETDATA_ML_PRIVATE_H
+
+-#include "dlib/dlib/matrix.h"
++#include <dlib/matrix.h>
+
+ // CentOS 7 shenanigans
+ #include <cmath>
+diff -Naurp netdata.orig/src/ml/ml.cc netdata/src/ml/ml.cc
+--- netdata.orig/src/ml/ml.cc
++++ netdata/src/ml/ml.cc
+@@ -1,6 +1,6 @@
+ // SPDX-License-Identifier: GPL-3.0-or-later
+
+-#include "dlib/dlib/clustering.h"
++#include <dlib/clustering.h>
+
+ #include "ml-private.h"
+
diff --git a/debian/patches/series b/debian/patches/series
index 17a2f5a33..d4916a779 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
debian/0003-use-python3.patch
debian/0004-use-bash.patch
debian/0005-send-email.patch
+debian/0006-use-dlib.patch