summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index e13c9a2c7..8cf104e0f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+VERSION := $(shell dpkg-parsechangelog | awk '/^Version: / { print $$2 }' | cut -d- -f1)
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
include /usr/share/dpkg/architecture.mk
@@ -110,3 +112,18 @@ override_dh_fixperms-indep:
chmod 0644 debian/netdata-plugins-bash/usr/libexec/netdata/charts.d/*.sh
chmod 0644 debian/netdata-plugins-bash/usr/libexec/netdata/plugins.d/*.sh.inc
chmod 0644 debian/netdata-plugins-python/usr/libexec/netdata/python.d/*.py
+
+upstream:
+ git clone --recursive https://github.com/netdata/netdata netdata-$(VERSION)+dfsg
+ cd netdata-$(VERSION)+dfsg && git checkout -f v$(VERSION)+dfsg
+
+ # removing embedded python modules
+ rm -rf netdata-$(VERSION)+dfsg/src/collectors/python.d.plugin/python_modules/pyyaml3
+ rm -rf netdata-$(VERSION)+dfsg/src/collectors/python.d.plugin/python_modules/urllib3
+
+ # removing embedded shared libraries
+ rm -rf netdata-$(VERSION)+dfsg/src/ml/dlib
+ rm -rf netdata-$(VERSION)+dfsg/src/web/server/h2o/libh2o
+
+ # removing git metadata
+ rm -rf netdata-$(VERSION)+dfsg/.git