summaryrefslogtreecommitdiffstats
path: root/collectors/charts.d.plugin/cpu_apps
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/charts.d.plugin/cpu_apps')
-rw-r--r--collectors/charts.d.plugin/cpu_apps/Makefile.inc13
-rw-r--r--collectors/charts.d.plugin/cpu_apps/README.md6
-rw-r--r--collectors/charts.d.plugin/cpu_apps/cpu_apps.chart.sh70
-rw-r--r--collectors/charts.d.plugin/cpu_apps/cpu_apps.conf19
4 files changed, 0 insertions, 108 deletions
diff --git a/collectors/charts.d.plugin/cpu_apps/Makefile.inc b/collectors/charts.d.plugin/cpu_apps/Makefile.inc
deleted file mode 100644
index a35f82837..000000000
--- a/collectors/charts.d.plugin/cpu_apps/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_charts_DATA += cpu_apps/cpu_apps.chart.sh
-dist_chartsconfig_DATA += cpu_apps/cpu_apps.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += cpu_apps/README.md cpu_apps/Makefile.inc
-
diff --git a/collectors/charts.d.plugin/cpu_apps/README.md b/collectors/charts.d.plugin/cpu_apps/README.md
deleted file mode 100644
index c8230aa4f..000000000
--- a/collectors/charts.d.plugin/cpu_apps/README.md
+++ /dev/null
@@ -1,6 +0,0 @@
-# cpu_apps
-
-> THIS MODULE IS OBSOLETE.
-> USE [APPS.PLUGIN](../../apps.plugin).
-
-[![analytics](https://www.google-analytics.com/collect?v=1&aip=1&t=pageview&_s=1&ds=github&dr=https%3A%2F%2Fgithub.com%2Fnetdata%2Fnetdata&dl=https%3A%2F%2Fmy-netdata.io%2Fgithub%2Fcollectors%2Fcharts.d.plugin%2Fcpu_apps%2FREADME&_u=MAC~&cid=5792dfd7-8dc4-476b-af31-da2fdb9f93d2&tid=UA-64295674-3)](<>)
diff --git a/collectors/charts.d.plugin/cpu_apps/cpu_apps.chart.sh b/collectors/charts.d.plugin/cpu_apps/cpu_apps.chart.sh
deleted file mode 100644
index e91c46d54..000000000
--- a/collectors/charts.d.plugin/cpu_apps/cpu_apps.chart.sh
+++ /dev/null
@@ -1,70 +0,0 @@
-# shellcheck shell=bash disable=SC2154,SC1072,SC1073,SC2009,SC2162,SC2006,SC2002,SC2086,SC1117
-# no need for shebang - this file is loaded from charts.d.plugin
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# netdata
-# real-time performance and health monitoring, done right!
-# (C) 2016 Costa Tsaousis <costa@tsaousis.gr>
-#
-# THIS PLUGIN IS OBSOLETE
-# USE apps.plugin INSTEAD
-
-# a space separated list of command to monitor
-cpu_apps_apps=
-
-# these are required for computing memory in bytes and cpu in seconds
-#cpu_apps_pagesize="`getconf PAGESIZE`"
-cpu_apps_clockticks="$(getconf CLK_TCK)"
-
-cpu_apps_update_every=60
-
-cpu_apps_check() {
- # this should return:
- # - 0 to enable the chart
- # - 1 to disable the chart
-
- if [ -z "$cpu_apps_apps" ]; then
- error "manual configuration required: please set cpu_apps_apps='command1 command2 ...' in $confd/cpu_apps_apps.conf"
- return 1
- fi
- return 0
-}
-
-cpu_apps_bc_finalze=
-
-cpu_apps_create() {
-
- echo "CHART chartsd_apps.cpu '' 'Apps CPU' 'milliseconds / $cpu_apps_update_every sec' apps apps stacked 20001 $cpu_apps_update_every"
-
- local x=
- for x in $cpu_apps_apps; do
- echo "DIMENSION $x $x incremental 1000 $cpu_apps_clockticks"
-
- # this string is needed later in the update() function
- # to finalize the instructions for the bc command
- cpu_apps_bc_finalze="$cpu_apps_bc_finalze \"SET $x = \"; $x;"
- done
- return 0
-}
-
-cpu_apps_update() {
- # do all the work to collect / calculate the values
- # for each dimension
- # remember: KEEP IT SIMPLE AND SHORT
-
- echo "BEGIN chartsd_apps.cpu"
- ps -o pid,comm -C "$cpu_apps_apps" |
- grep -v "COMMAND" |
- (
- while read pid name; do
- echo "$name+=$(cat /proc/$pid/stat | cut -d ' ' -f 14-15)"
- done
- ) |
- (
- sed -e "s/ \+/ /g" -e "s/ /+/g"
- echo "$cpu_apps_bc_finalze"
- ) | bc
- echo "END"
-
- return 0
-}
diff --git a/collectors/charts.d.plugin/cpu_apps/cpu_apps.conf b/collectors/charts.d.plugin/cpu_apps/cpu_apps.conf
deleted file mode 100644
index 850cd0c6f..000000000
--- a/collectors/charts.d.plugin/cpu_apps/cpu_apps.conf
+++ /dev/null
@@ -1,19 +0,0 @@
-# no need for shebang - this file is loaded from charts.d.plugin
-
-# netdata
-# real-time performance and health monitoring, done right!
-# (C) 2018 Costa Tsaousis <costa@tsaousis.gr>
-# GPL v3+
-
-# THIS PLUGIN IS DEPRECATED
-# app.plugin can do better
-
-#cpu_apps_apps=
-
-# the data collection frequency
-# if unset, will inherit the netdata update frequency
-#cpu_apps_update_every=2
-
-# the number of retries to do in case of failure
-# before disabling the module
-#cpu_apps_retries=10