summaryrefslogtreecommitdiffstats
path: root/collectors/charts.d.plugin/exim
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/charts.d.plugin/exim')
-rw-r--r--collectors/charts.d.plugin/exim/Makefile.inc13
-rw-r--r--collectors/charts.d.plugin/exim/README.md6
-rw-r--r--collectors/charts.d.plugin/exim/exim.chart.sh46
-rw-r--r--collectors/charts.d.plugin/exim/exim.conf24
4 files changed, 0 insertions, 89 deletions
diff --git a/collectors/charts.d.plugin/exim/Makefile.inc b/collectors/charts.d.plugin/exim/Makefile.inc
deleted file mode 100644
index ca2112a80..000000000
--- a/collectors/charts.d.plugin/exim/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_charts_DATA += exim/exim.chart.sh
-dist_chartsconfig_DATA += exim/exim.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += exim/README.md exim/Makefile.inc
-
diff --git a/collectors/charts.d.plugin/exim/README.md b/collectors/charts.d.plugin/exim/README.md
deleted file mode 100644
index 5c73c002e..000000000
--- a/collectors/charts.d.plugin/exim/README.md
+++ /dev/null
@@ -1,6 +0,0 @@
-# exim
-
-> THIS MODULE IS OBSOLETE.
-> USE [THE PYTHON ONE](../../python.d.plugin/exim) - IT SUPPORTS MULTIPLE JOBS AND IT IS MORE EFFICIENT
-
-[![analytics](https://www.google-analytics.com/collect?v=1&aip=1&t=pageview&_s=1&ds=github&dr=https%3A%2F%2Fgithub.com%2Fnetdata%2Fnetdata&dl=https%3A%2F%2Fmy-netdata.io%2Fgithub%2Fcollectors%2Fcharts.d.plugin%2Fexim%2FREADME&_u=MAC~&cid=5792dfd7-8dc4-476b-af31-da2fdb9f93d2&tid=UA-64295674-3)](<>)
diff --git a/collectors/charts.d.plugin/exim/exim.chart.sh b/collectors/charts.d.plugin/exim/exim.chart.sh
deleted file mode 100644
index 7b0ef70d2..000000000
--- a/collectors/charts.d.plugin/exim/exim.chart.sh
+++ /dev/null
@@ -1,46 +0,0 @@
-# shellcheck shell=bash
-# no need for shebang - this file is loaded from charts.d.plugin
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# netdata
-# real-time performance and health monitoring, done right!
-# (C) 2016 Costa Tsaousis <costa@tsaousis.gr>
-#
-# Contributed by @jsveiga with PR #480
-
-# the exim command to run
-exim_command=
-
-# how frequently to collect queue size
-exim_update_every=5
-
-exim_priority=60000
-
-exim_check() {
- if [ -z "${exim_command}" ]; then
- require_cmd exim || return 1
- exim_command="${EXIM_CMD}"
- fi
-
- if [ "$(${exim_command} -bpc 2>&1 | grep -c denied)" -ne 0 ]; then
- error "permission denied - please set 'queue_list_requires_admin = false' in your exim options file"
- return 1
- fi
-
- return 0
-}
-
-exim_create() {
- cat <<EOF
-CHART exim_local.qemails '' "Exim Queue Emails" "emails" queue exim.queued.emails line $((exim_priority + 1)) $exim_update_every
-DIMENSION emails '' absolute 1 1
-EOF
- return 0
-}
-
-exim_update() {
- echo "BEGIN exim_local.qemails $1"
- echo "SET emails = $(run "${exim_command}" -bpc)"
- echo "END"
- return 0
-}
diff --git a/collectors/charts.d.plugin/exim/exim.conf b/collectors/charts.d.plugin/exim/exim.conf
deleted file mode 100644
index f96ac4dbb..000000000
--- a/collectors/charts.d.plugin/exim/exim.conf
+++ /dev/null
@@ -1,24 +0,0 @@
-# no need for shebang - this file is loaded from charts.d.plugin
-
-# netdata
-# real-time performance and health monitoring, done right!
-# (C) 2018 Costa Tsaousis <costa@tsaousis.gr>
-# GPL v3+
-
-# THIS PLUGIN IS DEPRECATED
-# USE THE PYTHON.D ONE
-
-# the exim command to run
-# if empty, it will use the one found in the system path
-#exim_command=
-
-# the data collection frequency
-# if unset, will inherit the netdata update frequency
-#exim_update_every=5
-
-# the charts priority on the dashboard
-#exim_priority=60000
-
-# the number of retries to do in case of failure
-# before disabling the module
-#exim_retries=10