summaryrefslogtreecommitdiffstats
path: root/collectors/charts.d.plugin/hddtemp
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/charts.d.plugin/hddtemp')
-rw-r--r--collectors/charts.d.plugin/hddtemp/Makefile.inc13
-rw-r--r--collectors/charts.d.plugin/hddtemp/README.md30
-rw-r--r--collectors/charts.d.plugin/hddtemp/hddtemp.chart.sh77
-rw-r--r--collectors/charts.d.plugin/hddtemp/hddtemp.conf23
4 files changed, 0 insertions, 143 deletions
diff --git a/collectors/charts.d.plugin/hddtemp/Makefile.inc b/collectors/charts.d.plugin/hddtemp/Makefile.inc
deleted file mode 100644
index 2bd29e5b1..000000000
--- a/collectors/charts.d.plugin/hddtemp/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_charts_DATA += hddtemp/hddtemp.chart.sh
-dist_chartsconfig_DATA += hddtemp/hddtemp.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += hddtemp/README.md hddtemp/Makefile.inc
-
diff --git a/collectors/charts.d.plugin/hddtemp/README.md b/collectors/charts.d.plugin/hddtemp/README.md
deleted file mode 100644
index 77f48956a..000000000
--- a/collectors/charts.d.plugin/hddtemp/README.md
+++ /dev/null
@@ -1,30 +0,0 @@
-# hddtemp
-
-> THIS MODULE IS OBSOLETE.
-> USE [THE PYTHON ONE](../../python.d.plugin/hddtemp) - IT SUPPORTS MULTIPLE JOBS AND IT IS MORE EFFICIENT
-
-The plugin will collect temperatures from disks
-
-It will create one chart with all active disks
-
-1. **temperature in Celsius**
-
-## configuration
-
-hddtemp needs to be running in daemonized mode
-
-```sh
-# host with daemonized hddtemp
-hddtemp_host="localhost"
-
-# port on which hddtemp is showing data
-hddtemp_port="7634"
-
-# array of included disks
-# the default is to include all
-hddtemp_disks=()
-```
-
----
-
-[![analytics](https://www.google-analytics.com/collect?v=1&aip=1&t=pageview&_s=1&ds=github&dr=https%3A%2F%2Fgithub.com%2Fnetdata%2Fnetdata&dl=https%3A%2F%2Fmy-netdata.io%2Fgithub%2Fcollectors%2Fcharts.d.plugin%2Fhddtemp%2FREADME&_u=MAC~&cid=5792dfd7-8dc4-476b-af31-da2fdb9f93d2&tid=UA-64295674-3)](<>)
diff --git a/collectors/charts.d.plugin/hddtemp/hddtemp.chart.sh b/collectors/charts.d.plugin/hddtemp/hddtemp.chart.sh
deleted file mode 100644
index a4cef3c3b..000000000
--- a/collectors/charts.d.plugin/hddtemp/hddtemp.chart.sh
+++ /dev/null
@@ -1,77 +0,0 @@
-# shellcheck shell=bash
-# no need for shebang - this file is loaded from charts.d.plugin
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# netdata
-# real-time performance and health monitoring, done right!
-# (C) 2016 Costa Tsaousis <costa@tsaousis.gr>
-#
-# contributed by @paulfantom with PR #511
-
-# if this chart is called X.chart.sh, then all functions and global variables
-# must start with X_
-hddtemp_host="localhost"
-hddtemp_port="7634"
-declare -A hddtemp_disks=()
-
-# _update_every is a special variable - it holds the number of seconds
-# between the calls of the _update() function
-hddtemp_update_every=3
-hddtemp_priority=90000
-
-# _check is called once, to find out if this chart should be enabled or not
-hddtemp_check() {
- require_cmd nc || return 1
- run nc $hddtemp_host $hddtemp_port && return 0 || return 1
-}
-
-# _create is called once, to create the charts
-hddtemp_create() {
- if [ ${#hddtemp_disks[@]} -eq 0 ]; then
- local all
- all=$(nc $hddtemp_host $hddtemp_port)
- unset hddtemp_disks
- # shellcheck disable=SC2190,SC2207
- hddtemp_disks=($(grep -Po '/dev/[^|]+' <<<"$all" | cut -c 6-))
- fi
- # local disk_names
- # disk_names=(`sed -e 's/||/\n/g;s/^|//' <<< "$all" | cut -d '|' -f2 | tr ' ' '_'`)
-
- echo "CHART hddtemp.temperature 'disks_temp' 'temperature' 'Celsius' 'Disks temperature' 'hddtemp.temp' line $((hddtemp_priority)) $hddtemp_update_every"
- for i in $(seq 0 $((${#hddtemp_disks[@]} - 1))); do
- # echo "DIMENSION ${hddtemp_disks[i]} ${disk_names[i]} absolute 1 1"
- echo "DIMENSION ${hddtemp_disks[$i]} '' absolute 1 1"
- done
- return 0
-}
-
-# _update is called continuously, to collect the values
-#hddtemp_last=0
-#hddtemp_count=0
-hddtemp_update() {
- # local all=( `nc $hddtemp_host $hddtemp_port | sed -e 's/||/\n/g;s/^|//' | cut -d '|' -f3` )
- # local all=( `nc $hddtemp_host $hddtemp_port | awk 'BEGIN { FS="|" };{i=4; while (i <= NF) {print $i+0;i+=5;};}'` )
- OLD_IFS=$IFS
- set -f
- # shellcheck disable=SC2207
- IFS="|" all=($(nc $hddtemp_host $hddtemp_port 2>/dev/null))
- set +f
- IFS=$OLD_IFS
-
- # check if there is some data
- if [ -z "${all[3]}" ]; then
- return 1
- fi
-
- # write the result of the work.
- echo "BEGIN hddtemp.temperature $1"
- end=${#hddtemp_disks[@]}
- for ((i = 0; i < end; i++)); do
- # temperature - this will turn SLP to zero
- t=$((all[$((i * 5 + 3))]))
- echo "SET ${hddtemp_disks[$i]} = $t"
- done
- echo "END"
-
- return 0
-}
diff --git a/collectors/charts.d.plugin/hddtemp/hddtemp.conf b/collectors/charts.d.plugin/hddtemp/hddtemp.conf
deleted file mode 100644
index b6037b40e..000000000
--- a/collectors/charts.d.plugin/hddtemp/hddtemp.conf
+++ /dev/null
@@ -1,23 +0,0 @@
-# no need for shebang - this file is loaded from charts.d.plugin
-
-# netdata
-# real-time performance and health monitoring, done right!
-# (C) 2018 Costa Tsaousis <costa@tsaousis.gr>
-# GPL v3+
-
-# THIS PLUGIN IS DEPRECATED
-# USE THE PYTHON.D ONE
-
-#hddtemp_host="localhost"
-#hddtemp_port="7634"
-
-# the data collection frequency
-# if unset, will inherit the netdata update frequency
-#hddtemp_update_every=3
-
-# the charts priority on the dashboard
-#hddtemp_priority=90000
-
-# the number of retries to do in case of failure
-# before disabling the module
-#hddtemp_retries=10