summaryrefslogtreecommitdiffstats
path: root/collectors/charts.d.plugin/load_average
diff options
context:
space:
mode:
Diffstat (limited to 'collectors/charts.d.plugin/load_average')
-rw-r--r--collectors/charts.d.plugin/load_average/Makefile.inc13
-rw-r--r--collectors/charts.d.plugin/load_average/README.md6
-rw-r--r--collectors/charts.d.plugin/load_average/load_average.chart.sh69
-rw-r--r--collectors/charts.d.plugin/load_average/load_average.conf22
4 files changed, 0 insertions, 110 deletions
diff --git a/collectors/charts.d.plugin/load_average/Makefile.inc b/collectors/charts.d.plugin/load_average/Makefile.inc
deleted file mode 100644
index e5a481bf4..000000000
--- a/collectors/charts.d.plugin/load_average/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_charts_DATA += load_average/load_average.chart.sh
-dist_chartsconfig_DATA += load_average/load_average.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += load_average/README.md load_average/Makefile.inc
-
diff --git a/collectors/charts.d.plugin/load_average/README.md b/collectors/charts.d.plugin/load_average/README.md
deleted file mode 100644
index 40b860cc5..000000000
--- a/collectors/charts.d.plugin/load_average/README.md
+++ /dev/null
@@ -1,6 +0,0 @@
-# load_average
-
-> THIS MODULE IS OBSOLETE.
-> THE NETDATA DAEMON COLLECTS LOAD AVERAGE BY ITSELF
-
-[![analytics](https://www.google-analytics.com/collect?v=1&aip=1&t=pageview&_s=1&ds=github&dr=https%3A%2F%2Fgithub.com%2Fnetdata%2Fnetdata&dl=https%3A%2F%2Fmy-netdata.io%2Fgithub%2Fcollectors%2Fcharts.d.plugin%2Fload_average%2FREADME&_u=MAC~&cid=5792dfd7-8dc4-476b-af31-da2fdb9f93d2&tid=UA-64295674-3)](<>)
diff --git a/collectors/charts.d.plugin/load_average/load_average.chart.sh b/collectors/charts.d.plugin/load_average/load_average.chart.sh
deleted file mode 100644
index 841e3d9f6..000000000
--- a/collectors/charts.d.plugin/load_average/load_average.chart.sh
+++ /dev/null
@@ -1,69 +0,0 @@
-# shellcheck shell=bash disable=SC2154,SC1072,SC1073,SC2009,SC2162,SC2006,SC2002,SC2086,SC1117
-# no need for shebang - this file is loaded from charts.d.plugin
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# netdata
-# real-time performance and health monitoring, done right!
-# (C) 2016 Costa Tsaousis <costa@tsaousis.gr>
-#
-
-load_average_update_every=5
-load_priority=100
-
-# this is an example charts.d collector
-# it is disabled by default.
-# there is no point to enable it, since netdata already
-# collects this information using its internal plugins.
-load_average_enabled=0
-
-load_average_check() {
- # this should return:
- # - 0 to enable the chart
- # - 1 to disable the chart
-
- if [ ${load_average_update_every} -lt 5 ]; then
- # there is no meaning for shorter than 5 seconds
- # the kernel changes this value every 5 seconds
- load_average_update_every=5
- fi
-
- [ ${load_average_enabled} -eq 0 ] && return 1
- return 0
-}
-
-load_average_create() {
- # create a chart with 3 dimensions
- cat <<EOF
-CHART system.load '' "System Load Average" "load" load system.load line $((load_priority + 1)) $load_average_update_every
-DIMENSION load1 '1 min' absolute 1 100
-DIMENSION load5 '5 mins' absolute 1 100
-DIMENSION load15 '15 mins' absolute 1 100
-EOF
-
- return 0
-}
-
-load_average_update() {
- # do all the work to collect / calculate the values
- # for each dimension
- # remember: KEEP IT SIMPLE AND SHORT
-
- # here we parse the system average load
- # it is decimal (with 2 decimal digits), so we remove the dot and
- # at the definition we have divisor = 100, to have the graph show the right value
- loadavg="$(cat /proc/loadavg | sed -e "s/\.//g")"
- load1=$(echo $loadavg | cut -d ' ' -f 1)
- load5=$(echo $loadavg | cut -d ' ' -f 2)
- load15=$(echo $loadavg | cut -d ' ' -f 3)
-
- # write the result of the work.
- cat <<VALUESEOF
-BEGIN system.load
-SET load1 = $load1
-SET load5 = $load5
-SET load15 = $load15
-END
-VALUESEOF
-
- return 0
-}
diff --git a/collectors/charts.d.plugin/load_average/load_average.conf b/collectors/charts.d.plugin/load_average/load_average.conf
deleted file mode 100644
index 68979275f..000000000
--- a/collectors/charts.d.plugin/load_average/load_average.conf
+++ /dev/null
@@ -1,22 +0,0 @@
-# no need for shebang - this file is loaded from charts.d.plugin
-
-# netdata
-# real-time performance and health monitoring, done right!
-# (C) 2018 Costa Tsaousis <costa@tsaousis.gr>
-# GPL v3+
-
-# THIS PLUGIN IS DEPRECATED
-# netdata can collect this metric already
-
-#load_average_enabled=0
-
-# the data collection frequency
-# if unset, will inherit the netdata update frequency
-#load_average_update_every=5
-
-# the charts priority on the dashboard
-#load_average_priority=100
-
-# the number of retries to do in case of failure
-# before disabling the module
-#load_average_retries=10