summaryrefslogtreecommitdiffstats
path: root/collectors/node.d.plugin/named
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--collectors/node.d.plugin/named/Makefile.inc13
-rw-r--r--collectors/node.d.plugin/named/README.md (renamed from conf.d/node.d/named.conf.md)2
-rw-r--r--collectors/node.d.plugin/named/named.node.js (renamed from node.d/named.node.js)9
3 files changed, 18 insertions, 6 deletions
diff --git a/collectors/node.d.plugin/named/Makefile.inc b/collectors/node.d.plugin/named/Makefile.inc
new file mode 100644
index 000000000..95f423012
--- /dev/null
+++ b/collectors/node.d.plugin/named/Makefile.inc
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+# THIS IS NOT A COMPLETE Makefile
+# IT IS INCLUDED BY ITS PARENT'S Makefile.am
+# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
+
+# install these files
+dist_node_DATA += named/named.node.js
+# dist_nodeconfig_DATA += named/named.conf
+
+# do not install these files, but include them in the distribution
+dist_noinst_DATA += named/README.md named/Makefile.inc
+
diff --git a/conf.d/node.d/named.conf.md b/collectors/node.d.plugin/named/README.md
index fa843dd58..977a5015f 100644
--- a/conf.d/node.d/named.conf.md
+++ b/collectors/node.d.plugin/named/README.md
@@ -2,8 +2,6 @@
Using this netdata collector, you can monitor one or more ISC Bind servers.
-The source code for this plugin in [here](https://github.com/firehol/netdata/blob/master/node.d/named.node.js).
-
## Example netdata charts
Depending on the number of views your bind has, you may get a large number of charts.
diff --git a/node.d/named.node.js b/collectors/node.d.plugin/named/named.node.js
index 02c890c60..d13c608cb 100644
--- a/node.d/named.node.js
+++ b/collectors/node.d.plugin/named/named.node.js
@@ -1,4 +1,5 @@
'use strict';
+// SPDX-License-Identifier: GPL-3.0-or-later
// collect statistics from bind (named) v9.10+
//
@@ -36,8 +37,8 @@ statistics-channels {
};
*/
-var url = require('url');
-var http = require('http');
+require('url');
+require('http');
var XML = require('pixl-xml');
var netdata = require('netdata');
@@ -79,11 +80,11 @@ var named = {
multiplier: multiplier, // the multiplier
divisor: divisor, // the divisor
hidden: false // is hidden (boolean)
- }
+ };
}
}
- if(found === false)
+ if(!found)
return null;
chart = service.chart(id, chart);