summaryrefslogtreecommitdiffstats
path: root/collectors/node.d.plugin/sma_webbox
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--collectors/node.d.plugin/sma_webbox/Makefile.inc13
-rw-r--r--collectors/node.d.plugin/sma_webbox/README.md (renamed from conf.d/node.d/sma_webbox.conf.md)2
-rw-r--r--collectors/node.d.plugin/sma_webbox/sma_webbox.node.js (renamed from node.d/sma_webbox.node.js)5
3 files changed, 17 insertions, 3 deletions
diff --git a/collectors/node.d.plugin/sma_webbox/Makefile.inc b/collectors/node.d.plugin/sma_webbox/Makefile.inc
new file mode 100644
index 000000000..38f2fe97a
--- /dev/null
+++ b/collectors/node.d.plugin/sma_webbox/Makefile.inc
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+# THIS IS NOT A COMPLETE Makefile
+# IT IS INCLUDED BY ITS PARENT'S Makefile.am
+# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
+
+# install these files
+dist_node_DATA += sma_webbox/sma_webbox.node.js
+# dist_nodeconfig_DATA += sma_webbox/sma_webbox.conf
+
+# do not install these files, but include them in the distribution
+dist_noinst_DATA += sma_webbox/README.md sma_webbox/Makefile.inc
+
diff --git a/conf.d/node.d/sma_webbox.conf.md b/collectors/node.d.plugin/sma_webbox/README.md
index 19fdc9dd3..1512c7008 100644
--- a/conf.d/node.d/sma_webbox.conf.md
+++ b/collectors/node.d.plugin/sma_webbox/README.md
@@ -1,5 +1,5 @@
-[SMA Sunny Webbox](http://www.solar-is-future.com/sma-technology-for-our-future/products/sunny-webbox/index.html)
+[SMA Sunny Webbox](http://files.sma.de/dl/4253/WEBBOX-DUS131916W.pdf)
Example netdata configuration for node.d/sma_webbox.conf
diff --git a/node.d/sma_webbox.node.js b/collectors/node.d.plugin/sma_webbox/sma_webbox.node.js
index 3d99943d4..b9a168adc 100644
--- a/node.d/sma_webbox.node.js
+++ b/collectors/node.d.plugin/sma_webbox/sma_webbox.node.js
@@ -1,4 +1,5 @@
'use strict';
+// SPDX-License-Identifier: GPL-3.0-or-later
// This program will connect to one or more SMA Sunny Webboxes
// to get the Solar Power Generated (current, today, total).
@@ -23,8 +24,8 @@
}
*/
-var url = require('url');
-var http = require('http');
+require('url');
+require('http');
var netdata = require('netdata');
if(netdata.options.DEBUG === true) netdata.debug('loaded ' + __filename + ' plugin');