summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/example
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--collectors/python.d.plugin/example/Makefile.inc13
-rw-r--r--collectors/python.d.plugin/example/README.md1
-rw-r--r--collectors/python.d.plugin/example/example.chart.py (renamed from python.d/example.chart.py)3
-rw-r--r--collectors/python.d.plugin/example/example.conf (renamed from conf.d/python.d/example.conf)0
4 files changed, 16 insertions, 1 deletions
diff --git a/collectors/python.d.plugin/example/Makefile.inc b/collectors/python.d.plugin/example/Makefile.inc
new file mode 100644
index 000000000..1b027d5a7
--- /dev/null
+++ b/collectors/python.d.plugin/example/Makefile.inc
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+# THIS IS NOT A COMPLETE Makefile
+# IT IS INCLUDED BY ITS PARENT'S Makefile.am
+# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
+
+# install these files
+dist_python_DATA += example/example.chart.py
+dist_pythonconfig_DATA += example/example.conf
+
+# do not install these files, but include them in the distribution
+dist_noinst_DATA += example/README.md example/Makefile.inc
+
diff --git a/collectors/python.d.plugin/example/README.md b/collectors/python.d.plugin/example/README.md
new file mode 100644
index 000000000..f9f314ac4
--- /dev/null
+++ b/collectors/python.d.plugin/example/README.md
@@ -0,0 +1 @@
+An example python data collection module. \ No newline at end of file
diff --git a/python.d/example.chart.py b/collectors/python.d.plugin/example/example.chart.py
index ee7ff62fc..85defa4d1 100644
--- a/python.d/example.chart.py
+++ b/collectors/python.d.plugin/example/example.chart.py
@@ -1,6 +1,7 @@
# -*- coding: utf-8 -*-
# Description: example netdata python.d module
-# Author: Pawel Krupa (paulfantom)
+# Author: Put your name here (your github login)
+# SPDX-License-Identifier: GPL-3.0-or-later
from random import SystemRandom
diff --git a/conf.d/python.d/example.conf b/collectors/python.d.plugin/example/example.conf
index e7fed9b50..e7fed9b50 100644
--- a/conf.d/python.d/example.conf
+++ b/collectors/python.d.plugin/example/example.conf