summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/example
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--collectors/python.d.plugin/example/Makefile.inc13
-rw-r--r--collectors/python.d.plugin/example/metadata.yaml138
l---------src/collectors/python.d.plugin/example/README.md (renamed from collectors/python.d.plugin/example/README.md)0
-rw-r--r--src/collectors/python.d.plugin/example/example.chart.py (renamed from collectors/python.d.plugin/example/example.chart.py)0
-rw-r--r--src/collectors/python.d.plugin/example/example.conf (renamed from collectors/python.d.plugin/example/example.conf)0
-rw-r--r--src/collectors/python.d.plugin/example/integrations/example_collector.md (renamed from collectors/python.d.plugin/example/integrations/example_collector.md)10
6 files changed, 5 insertions, 156 deletions
diff --git a/collectors/python.d.plugin/example/Makefile.inc b/collectors/python.d.plugin/example/Makefile.inc
deleted file mode 100644
index 1b027d5a7..000000000
--- a/collectors/python.d.plugin/example/Makefile.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_python_DATA += example/example.chart.py
-dist_pythonconfig_DATA += example/example.conf
-
-# do not install these files, but include them in the distribution
-dist_noinst_DATA += example/README.md example/Makefile.inc
-
diff --git a/collectors/python.d.plugin/example/metadata.yaml b/collectors/python.d.plugin/example/metadata.yaml
deleted file mode 100644
index eae84d9e1..000000000
--- a/collectors/python.d.plugin/example/metadata.yaml
+++ /dev/null
@@ -1,138 +0,0 @@
-plugin_name: python.d.plugin
-modules:
- - meta:
- plugin_name: python.d.plugin
- module_name: example
- monitored_instance:
- name: Example collector
- link: https://github.com/netdata/netdata/blob/master/collectors/python.d.plugin/example/README.md
- categories:
- - data-collection.other
- icon_filename: ""
- related_resources:
- integrations:
- list: []
- info_provided_to_referring_integrations:
- description: ""
- keywords:
- - example
- - netdata
- - python
- most_popular: false
- overview:
- data_collection:
- metrics_description: |
- Example collector that generates some random numbers as metrics.
-
- If you want to write your own collector, read our [writing a new Python module](https://github.com/netdata/netdata/blob/master/collectors/python.d.plugin/README.md#how-to-write-a-new-module) tutorial.
- method_description: |
- The `get_data()` function uses `random.randint()` to generate a random number which will be collected as a metric.
- supported_platforms:
- include: []
- exclude: []
- multi_instance: true
- additional_permissions:
- description: ""
- default_behavior:
- auto_detection:
- description: ""
- limits:
- description: ""
- performance_impact:
- description: ""
- setup:
- prerequisites:
- list: []
- configuration:
- file:
- name: python.d/example.conf
- description: ""
- options:
- description: |
- There are 2 sections:
-
- * Global variables
- * One or more JOBS that can define multiple different instances to monitor.
-
- The following options can be defined globally: priority, penalty, autodetection_retry, update_every, but can also be defined per JOB to override the global values.
-
- Additionally, the following collapsed table contains all the options that can be configured inside a JOB definition.
-
- Every configuration JOB starts with a `job_name` value which will appear in the dashboard, unless a `name` parameter is specified.
- folding:
- title: Config options
- enabled: true
- list:
- - name: num_lines
- description: The number of lines to create.
- default_value: 4
- required: false
- - name: lower
- description: The lower bound of numbers to randomly sample from.
- default_value: 0
- required: false
- - name: upper
- description: The upper bound of numbers to randomly sample from.
- default_value: 100
- required: false
- - name: update_every
- description: Sets the default data collection frequency.
- default_value: 1
- required: false
- - name: priority
- description: Controls the order of charts at the netdata dashboard.
- default_value: 60000
- required: false
- - name: autodetection_retry
- description: Sets the job re-check interval in seconds.
- default_value: 0
- required: false
- - name: penalty
- description: Indicates whether to apply penalty to update_every in case of failures.
- default_value: yes
- required: false
- - name: name
- description: Job name. This value will overwrite the `job_name` value. JOBS with the same name are mutually exclusive. Only one of them will be allowed running at any time. This allows autodetection to try several alternatives and pick the one that works.
- default_value: ""
- required: false
- examples:
- folding:
- enabled: true
- title: Config
- list:
- - name: Basic
- folding:
- enabled: false
- description: A basic example configuration.
- config: |
- four_lines:
- name: "Four Lines"
- update_every: 1
- priority: 60000
- penalty: yes
- autodetection_retry: 0
- num_lines: 4
- lower: 0
- upper: 100
- troubleshooting:
- problems:
- list: []
- alerts: []
- metrics:
- folding:
- title: Metrics
- enabled: false
- description: ""
- availability: []
- scopes:
- - name: global
- description: |
- These metrics refer to the entire monitored application.
- labels: []
- metrics:
- - name: example.random
- description: A random number
- unit: number
- chart_type: line
- dimensions:
- - name: random
diff --git a/collectors/python.d.plugin/example/README.md b/src/collectors/python.d.plugin/example/README.md
index 55877a99a..55877a99a 120000
--- a/collectors/python.d.plugin/example/README.md
+++ b/src/collectors/python.d.plugin/example/README.md
diff --git a/collectors/python.d.plugin/example/example.chart.py b/src/collectors/python.d.plugin/example/example.chart.py
index d6c0b6658..d6c0b6658 100644
--- a/collectors/python.d.plugin/example/example.chart.py
+++ b/src/collectors/python.d.plugin/example/example.chart.py
diff --git a/collectors/python.d.plugin/example/example.conf b/src/collectors/python.d.plugin/example/example.conf
index 31261b840..31261b840 100644
--- a/collectors/python.d.plugin/example/example.conf
+++ b/src/collectors/python.d.plugin/example/example.conf
diff --git a/collectors/python.d.plugin/example/integrations/example_collector.md b/src/collectors/python.d.plugin/example/integrations/example_collector.md
index 7dded67ba..3d031a1a4 100644
--- a/collectors/python.d.plugin/example/integrations/example_collector.md
+++ b/src/collectors/python.d.plugin/example/integrations/example_collector.md
@@ -1,9 +1,9 @@
<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/example/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/collectors/python.d.plugin/example/metadata.yaml"
+custom_edit_url: "https://github.com/netdata/netdata/edit/master/src/collectors/python.d.plugin/example/README.md"
+meta_yaml: "https://github.com/netdata/netdata/edit/master/src/collectors/python.d.plugin/example/metadata.yaml"
sidebar_label: "Example collector"
learn_status: "Published"
-learn_rel_path: "Data Collection/Other"
+learn_rel_path: "Collecting Metrics/Other"
most_popular: False
message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE COLLECTOR'S metadata.yaml FILE"
endmeta-->
@@ -19,7 +19,7 @@ Module: example
Example collector that generates some random numbers as metrics.
-If you want to write your own collector, read our [writing a new Python module](https://github.com/netdata/netdata/blob/master/collectors/python.d.plugin/README.md#how-to-write-a-new-module) tutorial.
+If you want to write your own collector, read our [writing a new Python module](https://github.com/netdata/netdata/blob/master/src/collectors/python.d.plugin/README.md#how-to-write-a-new-module) tutorial.
The `get_data()` function uses `random.randint()` to generate a random number which will be collected as a metric.
@@ -87,7 +87,7 @@ The configuration file name for this integration is `python.d/example.conf`.
You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
+Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/netdata-agent/configuration.md#the-netdata-config-directory).
```bash
cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata