summaryrefslogtreecommitdiffstats
path: root/conf.d
diff options
context:
space:
mode:
Diffstat (limited to 'conf.d')
-rw-r--r--conf.d/Makefile.am9
-rw-r--r--conf.d/apps_groups.conf65
-rw-r--r--conf.d/charts.d.conf44
3 files changed, 118 insertions, 0 deletions
diff --git a/conf.d/Makefile.am b/conf.d/Makefile.am
new file mode 100644
index 000000000..381b546e3
--- /dev/null
+++ b/conf.d/Makefile.am
@@ -0,0 +1,9 @@
+#
+# Copyright (C) 2015 Alon Bar-Lev <alon.barlev@gmail.com>
+#
+MAINTAINERCLEANFILES= $(srcdir)/Makefile.in
+
+dist_config_DATA = \
+ apps_groups.conf \
+ charts.d.conf \
+ $(NULL)
diff --git a/conf.d/apps_groups.conf b/conf.d/apps_groups.conf
new file mode 100644
index 000000000..195118f46
--- /dev/null
+++ b/conf.d/apps_groups.conf
@@ -0,0 +1,65 @@
+#
+# apps.plugin process grouping
+#
+# The apps.plugin displays charts with information about the processes running.
+# This config allows grouping processes together, so that several processes
+# will be reported together.
+#
+# Only groups in this file are reported. All other processes will be reported
+# as 'other'.
+#
+# For each process given, its whole process tree will be grouped, not just
+# the process matched. The plugin will include both parents and childs.
+#
+# The format is:
+#
+# group_name: process1 process2 process3 ...
+#
+# The process names are the same to the ones returned by: ps -e
+#
+# If a group_name starts with a -, the dimension will be hidden (cpu chart only)
+#
+
+compile: cc1 cc1plus as gcc ld make automake autoconf git
+rsync: rsync
+media: mplayer vlc xine mediatomb omxplayer omxplayer.bin kodi kodi.bin xbmc xbmc.bin mediacenter eventlircd
+squid: squid squid2 squid3
+apache: apache apache2
+mysql: mysqld mysql
+asterisk: asterisk
+opensips: opensips opensips-mi-pro stund
+radius: radiusd radiusclient
+fail2ban: fail2ban-server
+mail: dovecot imapd pop3d
+postfix: master
+nginx: nginx
+splunk: splunkd
+mongo: mongod
+lighttpd: lighttpd
+ftpd: proftpd in.tftpd
+samba: smbd nmbd winbindd
+nfs: rpcbind rpc.statd rpc.idmapd rpc.mountd nfsd4 nfsd4_callbacks nfsd nfsiod
+ssh: ssh sshd scp
+X: X lightdm xdm pulseaudio gkrellm
+xfce: xfwm4 xfdesktop xfce4-appfinder Thunar xfsettingsd xfce4-panel
+gnome: gnome-session gdm gconfd-2 gnome-terminal gnome-screensaver gnome-settings-daemon
+named: named rncd
+clam: clamd freshclam
+cups: cupsd cups-browsed
+ntp: ntpq ntpd
+deluge: deluge deluged
+vbox: vboxwebsrv VBoxXPCOMIPCD VBoxSVC
+log: ulogd syslogd syslog-ng rsyslogd logrotate
+nms: snmpd vnstatd smokeping zabbix_agentd monit munin-node mon openhpid
+ppp: ppp pppd pptpd pptpctrl
+inetd: inetd xinetd
+openvpn: openvpn
+cron: cron atd
+ha: corosync hs_logd ha_logd stonithd
+ipvs: ipvs_syncmaster ipvs_syncbackup
+kernel: kthreadd kauditd lockd khelper kdevtmpfs khungtaskd rpciod fsnotify_mark kthrotld iscsi_eh deferwq
+netdata: netdata apps.plugin charts.d.plugin
+crsproxy: crsproxy
+wifi: hostapd wpa_supplicant
+system: systemd-journal systemd-udevd systemd-logind udisks-glue udisks-daemon udevd udevd connmand ipv6_addrconf dbus-daemon
+ksmd: ksmd
diff --git a/conf.d/charts.d.conf b/conf.d/charts.d.conf
new file mode 100644
index 000000000..f284c3b77
--- /dev/null
+++ b/conf.d/charts.d.conf
@@ -0,0 +1,44 @@
+#!/bin/sh
+
+# This is the configuration for charts.d.plugin
+
+# Each of its collectors can read configuration eiher from this file
+# or a NAME.conf file (where NAME is the collector name).
+# The collector specific file has higher precedence.
+
+# This file is a shell script too.
+
+# -----------------------------------------------------------------------------
+
+# number of seconds to run without restart
+# after this time, charts.d.plugin will exit
+# netdata will restart it, but a small gap
+# will appear in the charts.d.plugin charts.
+#restart_timeout=$[3600 * 4]
+
+# when making iterations, charts.d can loop more frequently
+# to prevent plugins missing iterations.
+# this is a percentage relative to update_every to align its
+# iterations.
+# The minimum is 10%, the maximum 100%.
+# So, if update_every is 1 second and time_divisor is 50,
+# charts.d will iterate every 500ms.
+# Charts will be called to collect data only if the time
+# passed since the last time the collected data is equal or
+# above their update_every.
+#time_divisor=50
+
+# -----------------------------------------------------------------------------
+
+# the default enable/disable for all charts.d collectors
+#enable_all_charts="yes"
+
+# per charts.d collector enable/disable
+#nut=yes
+#squid=yes
+#postfix=yes
+#sensors=yes
+#cpufreq=yes
+#mysql=yes
+#example=yes
+#load_average=yes