summaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure217
1 files changed, 183 insertions, 34 deletions
diff --git a/configure b/configure
index 054590f7f..cbcc0a1ee 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for netdata 1.10.0.
+# Generated by GNU Autoconf 2.69 for netdata 1.11.0_rolling.
#
#
# Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
@@ -577,12 +577,12 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='netdata'
PACKAGE_TARNAME='netdata'
-PACKAGE_VERSION='1.10.0'
-PACKAGE_STRING='netdata 1.10.0'
+PACKAGE_VERSION='1.11.0_rolling'
+PACKAGE_STRING='netdata 1.11.0_rolling'
PACKAGE_BUGREPORT=''
PACKAGE_URL=''
-ac_unique_file="src/main.c"
+ac_unique_file="daemon/main.c"
# Factoring default headers for most tests.
ac_includes_default="\
#include <stdio.h>
@@ -640,6 +640,7 @@ OPTIONAL_MATH_CLFAGS
webdir
pluginsdir
logdir
+libconfigdir
configdir
pythondir
nodedir
@@ -647,6 +648,7 @@ chartsdir
cachedir
registrydir
varlibdir
+build_target
ENABLE_PLUGIN_CGROUP_NETWORK_FALSE
ENABLE_PLUGIN_CGROUP_NETWORK_TRUE
ENABLE_PLUGIN_NFACCT_FALSE
@@ -1374,7 +1376,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures netdata 1.10.0 to adapt to many kinds of systems.
+\`configure' configures netdata 1.11.0_rolling to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1444,7 +1446,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of netdata 1.10.0:";;
+ short | recursive ) echo "Configuration of netdata 1.11.0_rolling:";;
esac
cat <<\_ACEOF
@@ -1587,7 +1589,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-netdata configure 1.10.0
+netdata configure 1.11.0_rolling
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2365,7 +2367,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by netdata $as_me 1.10.0, which was
+It was created by netdata $as_me 1.11.0_rolling, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2646,6 +2648,10 @@ $as_echo "$as_me: creating cache $cache_file" >&6;}
fi
as_fn_append ac_header_list " sys/prctl.h"
+as_fn_append ac_header_list " sys/vfs.h"
+as_fn_append ac_header_list " sys/statfs.h"
+as_fn_append ac_header_list " sys/statvfs.h"
+as_fn_append ac_header_list " sys/mount.h"
as_fn_append ac_func_list " accept4"
as_fn_append ac_header_list " linux/netfilter/nfnetlink_conntrack.h"
# Check that the precious variables saved in the cache have kept the same
@@ -2746,7 +2752,7 @@ $as_echo "$as_me: ***************** MAINTAINER MODE *****************" >&6;}
PACKAGE_BUILT_DATE=$(date '+%d %b %Y')
fi
-PACKAGE_RPM_VERSION="1.10.0"
+PACKAGE_RPM_VERSION="1.10.1"
@@ -2787,6 +2793,10 @@ ac_config_headers="$ac_config_headers config.h"
+
+
+
+
am__api_version='1.14'
# Find a good install program. We prefer a C program (faster),
@@ -3273,7 +3283,7 @@ fi
# Define the identity of the package.
PACKAGE='netdata'
- VERSION='1.10.0'
+ VERSION='1.11.0_rolling'
cat >>confdefs.h <<_ACEOF
@@ -3450,6 +3460,47 @@ END
as_fn_error $? "Your 'rm' program is bad, sorry." "$LINENO" 5
fi
fi
+
+ # Check whether --enable-silent-rules was given.
+if test "${enable_silent_rules+set}" = set; then :
+ enableval=$enable_silent_rules;
+fi
+
+case $enable_silent_rules in # (((
+ yes) AM_DEFAULT_VERBOSITY=0;;
+ no) AM_DEFAULT_VERBOSITY=1;;
+ *) AM_DEFAULT_VERBOSITY=0;;
+esac
+am_make=${MAKE-make}
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $am_make supports nested variables" >&5
+$as_echo_n "checking whether $am_make supports nested variables... " >&6; }
+if ${am_cv_make_support_nested_variables+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ if $as_echo 'TRUE=$(BAR$(V))
+BAR0=false
+BAR1=true
+V=1
+am__doit:
+ @$(TRUE)
+.PHONY: am__doit' | $am_make -f - >/dev/null 2>&1; then
+ am_cv_make_support_nested_variables=yes
+else
+ am_cv_make_support_nested_variables=no
+fi
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_make_support_nested_variables" >&5
+$as_echo "$am_cv_make_support_nested_variables" >&6; }
+if test $am_cv_make_support_nested_variables = yes; then
+ AM_V='$(V)'
+ AM_DEFAULT_V='$(AM_DEFAULT_VERBOSITY)'
+else
+ AM_V=$AM_DEFAULT_VERBOSITY
+ AM_DEFAULT_V=$AM_DEFAULT_VERBOSITY
+fi
+AM_BACKSLASH='\'
+
+
# Make sure we can run config.sub.
$SHELL "$ac_aux_dir/config.sub" sun4 >/dev/null 2>&1 ||
as_fn_error $? "cannot run $SHELL $ac_aux_dir/config.sub" "$LINENO" 5
@@ -4568,6 +4619,7 @@ fi
+
if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
@@ -5635,7 +5687,7 @@ _ACEOF
fi
done
-for ac_func in sched_setscheduler sched_get_priority_min sched_get_priority_max nice
+for ac_func in sched_setscheduler sched_getscheduler sched_getparam sched_get_priority_min sched_get_priority_max getpriority setpriority nice
do :
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
@@ -6102,6 +6154,18 @@ done
+
+
+
+
+
+
+
+
+
+
+
+
if test "${enable_accept4}" != "no"; then
@@ -6131,14 +6195,17 @@ $as_echo_n "checking operating system... " >&6; }
case "$host_os" in
freebsd*)
build_target=freebsd
+ build_target_id=2
CFLAGS="${CFLAGS} -I/usr/local/include"
;;
darwin*)
build_target=macos
+ build_target_id=3
LDFLAGS="${LDFLAGS} -framework CoreFoundation -framework IOKit"
;;
*)
build_target=linux
+ build_target_id=1
;;
esac
@@ -6166,8 +6233,8 @@ else
LINUX_FALSE=
fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ${build_target}" >&5
-$as_echo "${build_target}" >&6; }
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ${build_target} with id ${build_target_id}" >&5
+$as_echo "${build_target} with id ${build_target_id}" >&6; }
# -----------------------------------------------------------------------------
@@ -7974,26 +8041,42 @@ cat >>confdefs.h <<_ACEOF
_ACEOF
-varlibdir="\$(localstatedir)/lib/netdata"
+varlibdir="${localstatedir}/lib/netdata"
+registrydir="${localstatedir}/lib/netdata/registry"
+cachedir="${localstatedir}/cache/netdata"
+chartsdir="${libexecdir}/netdata/charts.d"
+nodedir="${libexecdir}/netdata/node.d"
+pythondir="${libexecdir}/netdata/python.d"
+configdir="${sysconfdir}/netdata"
+libconfigdir="${libdir}/netdata/conf.d"
+logdir="${localstatedir}/log/netdata"
+pluginsdir="${libexecdir}/netdata/plugins.d"
+
+
+
-registrydir="\$(localstatedir)/lib/netdata/registry"
-cachedir="\$(localstatedir)/cache/netdata"
-chartsdir="\$(libexecdir)/netdata/charts.d"
-nodedir="\$(libexecdir)/netdata/node.d"
-pythondir="\$(libexecdir)/netdata/python.d"
-configdir="\$(sysconfdir)/netdata"
-logdir="\$(localstatedir)/log/netdata"
-pluginsdir="\$(libexecdir)/netdata/plugins.d"
+CPPFLAGS="\
+ -DTARGET_OS=${build_target_id} \
+ -DVARLIB_DIR=\"\\\"${varlibdir}\\\"\" \
+ -DCACHE_DIR=\"\\\"${cachedir}\\\"\" \
+ -DCONFIG_DIR=\"\\\"${configdir}\\\"\" \
+ -DLIBCONFIG_DIR=\"\\\"${libconfigdir}\\\"\" \
+ -DLOG_DIR=\"\\\"${logdir}\\\"\" \
+ -DPLUGINS_DIR=\"\\\"${pluginsdir}\\\"\" \
+ -DRUN_DIR=\"\\\"${localstatedir}/run/netdata\\\"\" \
+ -DWEB_DIR=\"\\\"${webdir}\\\"\" \
+"
+
@@ -8007,7 +8090,7 @@ pluginsdir="\$(libexecdir)/netdata/plugins.d"
-ac_config_files="$ac_config_files Makefile charts.d/Makefile conf.d/Makefile netdata.spec python.d/Makefile node.d/Makefile plugins.d/Makefile src/Makefile system/Makefile web/Makefile diagrams/Makefile makeself/Makefile contrib/Makefile tests/Makefile"
+ac_config_files="$ac_config_files Makefile netdata.spec backends/graphite/Makefile backends/json/Makefile backends/Makefile backends/opentsdb/Makefile backends/prometheus/Makefile collectors/Makefile collectors/apps.plugin/Makefile collectors/cgroups.plugin/Makefile collectors/charts.d.plugin/Makefile collectors/checks.plugin/Makefile collectors/diskspace.plugin/Makefile collectors/fping.plugin/Makefile collectors/freebsd.plugin/Makefile collectors/freeipmi.plugin/Makefile collectors/idlejitter.plugin/Makefile collectors/macos.plugin/Makefile collectors/nfacct.plugin/Makefile collectors/node.d.plugin/Makefile collectors/plugins.d/Makefile collectors/proc.plugin/Makefile collectors/python.d.plugin/Makefile collectors/statsd.plugin/Makefile collectors/tc.plugin/Makefile contrib/Makefile daemon/Makefile database/Makefile diagrams/Makefile health/Makefile health/notifications/Makefile libnetdata/Makefile libnetdata/adaptive_resortable_list/Makefile libnetdata/avl/Makefile libnetdata/buffer/Makefile libnetdata/clocks/Makefile libnetdata/config/Makefile libnetdata/dictionary/Makefile libnetdata/eval/Makefile libnetdata/locks/Makefile libnetdata/log/Makefile libnetdata/popen/Makefile libnetdata/procfile/Makefile libnetdata/simple_pattern/Makefile libnetdata/socket/Makefile libnetdata/statistical/Makefile libnetdata/storage_number/Makefile libnetdata/threads/Makefile libnetdata/url/Makefile makeself/Makefile registry/Makefile streaming/Makefile system/Makefile tests/Makefile web/Makefile web/api/Makefile web/api/badges/Makefile web/api/exporters/Makefile web/api/exporters/shell/Makefile web/api/exporters/prometheus/Makefile web/api/formatters/Makefile web/api/formatters/csv/Makefile web/api/formatters/json/Makefile web/api/formatters/ssv/Makefile web/api/formatters/value/Makefile web/api/queries/Makefile web/api/queries/average/Makefile web/api/queries/des/Makefile web/api/queries/incremental_sum/Makefile web/api/queries/max/Makefile web/api/queries/median/Makefile web/api/queries/min/Makefile web/api/queries/ses/Makefile web/api/queries/stddev/Makefile web/api/queries/sum/Makefile web/gui/Makefile web/server/Makefile web/server/single/Makefile web/server/multi/Makefile web/server/static/Makefile"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -8575,7 +8658,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by netdata $as_me 1.10.0, which was
+This file was extended by netdata $as_me 1.11.0_rolling, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -8641,7 +8724,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-netdata config.status 1.10.0
+netdata config.status 1.11.0_rolling
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
@@ -8773,19 +8856,85 @@ do
"config.h") CONFIG_HEADERS="$CONFIG_HEADERS config.h" ;;
"depfiles") CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
- "charts.d/Makefile") CONFIG_FILES="$CONFIG_FILES charts.d/Makefile" ;;
- "conf.d/Makefile") CONFIG_FILES="$CONFIG_FILES conf.d/Makefile" ;;
"netdata.spec") CONFIG_FILES="$CONFIG_FILES netdata.spec" ;;
- "python.d/Makefile") CONFIG_FILES="$CONFIG_FILES python.d/Makefile" ;;
- "node.d/Makefile") CONFIG_FILES="$CONFIG_FILES node.d/Makefile" ;;
- "plugins.d/Makefile") CONFIG_FILES="$CONFIG_FILES plugins.d/Makefile" ;;
- "src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
- "system/Makefile") CONFIG_FILES="$CONFIG_FILES system/Makefile" ;;
- "web/Makefile") CONFIG_FILES="$CONFIG_FILES web/Makefile" ;;
+ "backends/graphite/Makefile") CONFIG_FILES="$CONFIG_FILES backends/graphite/Makefile" ;;
+ "backends/json/Makefile") CONFIG_FILES="$CONFIG_FILES backends/json/Makefile" ;;
+ "backends/Makefile") CONFIG_FILES="$CONFIG_FILES backends/Makefile" ;;
+ "backends/opentsdb/Makefile") CONFIG_FILES="$CONFIG_FILES backends/opentsdb/Makefile" ;;
+ "backends/prometheus/Makefile") CONFIG_FILES="$CONFIG_FILES backends/prometheus/Makefile" ;;
+ "collectors/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/Makefile" ;;
+ "collectors/apps.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/apps.plugin/Makefile" ;;
+ "collectors/cgroups.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/cgroups.plugin/Makefile" ;;
+ "collectors/charts.d.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/charts.d.plugin/Makefile" ;;
+ "collectors/checks.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/checks.plugin/Makefile" ;;
+ "collectors/diskspace.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/diskspace.plugin/Makefile" ;;
+ "collectors/fping.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/fping.plugin/Makefile" ;;
+ "collectors/freebsd.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/freebsd.plugin/Makefile" ;;
+ "collectors/freeipmi.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/freeipmi.plugin/Makefile" ;;
+ "collectors/idlejitter.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/idlejitter.plugin/Makefile" ;;
+ "collectors/macos.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/macos.plugin/Makefile" ;;
+ "collectors/nfacct.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/nfacct.plugin/Makefile" ;;
+ "collectors/node.d.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/node.d.plugin/Makefile" ;;
+ "collectors/plugins.d/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/plugins.d/Makefile" ;;
+ "collectors/proc.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/proc.plugin/Makefile" ;;
+ "collectors/python.d.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/python.d.plugin/Makefile" ;;
+ "collectors/statsd.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/statsd.plugin/Makefile" ;;
+ "collectors/tc.plugin/Makefile") CONFIG_FILES="$CONFIG_FILES collectors/tc.plugin/Makefile" ;;
+ "contrib/Makefile") CONFIG_FILES="$CONFIG_FILES contrib/Makefile" ;;
+ "daemon/Makefile") CONFIG_FILES="$CONFIG_FILES daemon/Makefile" ;;
+ "database/Makefile") CONFIG_FILES="$CONFIG_FILES database/Makefile" ;;
"diagrams/Makefile") CONFIG_FILES="$CONFIG_FILES diagrams/Makefile" ;;
+ "health/Makefile") CONFIG_FILES="$CONFIG_FILES health/Makefile" ;;
+ "health/notifications/Makefile") CONFIG_FILES="$CONFIG_FILES health/notifications/Makefile" ;;
+ "libnetdata/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/Makefile" ;;
+ "libnetdata/adaptive_resortable_list/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/adaptive_resortable_list/Makefile" ;;
+ "libnetdata/avl/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/avl/Makefile" ;;
+ "libnetdata/buffer/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/buffer/Makefile" ;;
+ "libnetdata/clocks/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/clocks/Makefile" ;;
+ "libnetdata/config/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/config/Makefile" ;;
+ "libnetdata/dictionary/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/dictionary/Makefile" ;;
+ "libnetdata/eval/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/eval/Makefile" ;;
+ "libnetdata/locks/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/locks/Makefile" ;;
+ "libnetdata/log/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/log/Makefile" ;;
+ "libnetdata/popen/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/popen/Makefile" ;;
+ "libnetdata/procfile/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/procfile/Makefile" ;;
+ "libnetdata/simple_pattern/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/simple_pattern/Makefile" ;;
+ "libnetdata/socket/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/socket/Makefile" ;;
+ "libnetdata/statistical/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/statistical/Makefile" ;;
+ "libnetdata/storage_number/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/storage_number/Makefile" ;;
+ "libnetdata/threads/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/threads/Makefile" ;;
+ "libnetdata/url/Makefile") CONFIG_FILES="$CONFIG_FILES libnetdata/url/Makefile" ;;
"makeself/Makefile") CONFIG_FILES="$CONFIG_FILES makeself/Makefile" ;;
- "contrib/Makefile") CONFIG_FILES="$CONFIG_FILES contrib/Makefile" ;;
+ "registry/Makefile") CONFIG_FILES="$CONFIG_FILES registry/Makefile" ;;
+ "streaming/Makefile") CONFIG_FILES="$CONFIG_FILES streaming/Makefile" ;;
+ "system/Makefile") CONFIG_FILES="$CONFIG_FILES system/Makefile" ;;
"tests/Makefile") CONFIG_FILES="$CONFIG_FILES tests/Makefile" ;;
+ "web/Makefile") CONFIG_FILES="$CONFIG_FILES web/Makefile" ;;
+ "web/api/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/Makefile" ;;
+ "web/api/badges/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/badges/Makefile" ;;
+ "web/api/exporters/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/exporters/Makefile" ;;
+ "web/api/exporters/shell/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/exporters/shell/Makefile" ;;
+ "web/api/exporters/prometheus/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/exporters/prometheus/Makefile" ;;
+ "web/api/formatters/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/formatters/Makefile" ;;
+ "web/api/formatters/csv/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/formatters/csv/Makefile" ;;
+ "web/api/formatters/json/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/formatters/json/Makefile" ;;
+ "web/api/formatters/ssv/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/formatters/ssv/Makefile" ;;
+ "web/api/formatters/value/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/formatters/value/Makefile" ;;
+ "web/api/queries/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/queries/Makefile" ;;
+ "web/api/queries/average/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/queries/average/Makefile" ;;
+ "web/api/queries/des/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/queries/des/Makefile" ;;
+ "web/api/queries/incremental_sum/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/queries/incremental_sum/Makefile" ;;
+ "web/api/queries/max/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/queries/max/Makefile" ;;
+ "web/api/queries/median/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/queries/median/Makefile" ;;
+ "web/api/queries/min/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/queries/min/Makefile" ;;
+ "web/api/queries/ses/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/queries/ses/Makefile" ;;
+ "web/api/queries/stddev/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/queries/stddev/Makefile" ;;
+ "web/api/queries/sum/Makefile") CONFIG_FILES="$CONFIG_FILES web/api/queries/sum/Makefile" ;;
+ "web/gui/Makefile") CONFIG_FILES="$CONFIG_FILES web/gui/Makefile" ;;
+ "web/server/Makefile") CONFIG_FILES="$CONFIG_FILES web/server/Makefile" ;;
+ "web/server/single/Makefile") CONFIG_FILES="$CONFIG_FILES web/server/single/Makefile" ;;
+ "web/server/multi/Makefile") CONFIG_FILES="$CONFIG_FILES web/server/multi/Makefile" ;;
+ "web/server/static/Makefile") CONFIG_FILES="$CONFIG_FILES web/server/static/Makefile" ;;
*) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
esac