summaryrefslogtreecommitdiffstats
path: root/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-linked-js-css-fonts-removed-from-make.patch')
-rw-r--r--debian/patches/0001-linked-js-css-fonts-removed-from-make.patch99
1 files changed, 93 insertions, 6 deletions
diff --git a/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch b/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch
index f50dc3f16..eb3e93cd8 100644
--- a/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch
+++ b/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch
@@ -1,16 +1,86 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Tue, 24 Jan 2017 16:48:02 +0100
+Date: Thu, 26 Jan 2017 14:03:06 +0100
Subject: linked js/css/fonts removed from make
---
- web/Makefile.am | 21 ---------------------
- 1 file changed, 21 deletions(-)
+ python.d/Makefile.am | 50 --------------------------------------------------
+ web/Makefile.am | 35 -----------------------------------
+ 2 files changed, 85 deletions(-)
+diff --git a/python.d/Makefile.am b/python.d/Makefile.am
+index 883f06c..f8b14da 100644
+--- a/python.d/Makefile.am
++++ b/python.d/Makefile.am
+@@ -45,53 +45,3 @@ dist_python_SCRIPTS = \
+ dist_python_DATA = \
+ README.md \
+ $(NULL)
+-
+-pythonmodulesdir=$(pythondir)/python_modules
+-dist_pythonmodules_DATA = \
+- python_modules/__init__.py \
+- python_modules/base.py \
+- python_modules/msg.py \
+- python_modules/lm_sensors.py \
+- $(NULL)
+-
+-pythonyaml2dir=$(pythonmodulesdir)/pyyaml2
+-dist_pythonyaml2_DATA = \
+- python_modules/pyyaml2/__init__.py \
+- python_modules/pyyaml2/composer.py \
+- python_modules/pyyaml2/constructor.py \
+- python_modules/pyyaml2/cyaml.py \
+- python_modules/pyyaml2/dumper.py \
+- python_modules/pyyaml2/emitter.py \
+- python_modules/pyyaml2/error.py \
+- python_modules/pyyaml2/events.py \
+- python_modules/pyyaml2/loader.py \
+- python_modules/pyyaml2/nodes.py \
+- python_modules/pyyaml2/parser.py \
+- python_modules/pyyaml2/reader.py \
+- python_modules/pyyaml2/representer.py \
+- python_modules/pyyaml2/resolver.py \
+- python_modules/pyyaml2/scanner.py \
+- python_modules/pyyaml2/serializer.py \
+- python_modules/pyyaml2/tokens.py \
+- $(NULL)
+-
+-pythonyaml3dir=$(pythonmodulesdir)/pyyaml3
+-dist_pythonyaml3_DATA = \
+- python_modules/pyyaml3/__init__.py \
+- python_modules/pyyaml3/composer.py \
+- python_modules/pyyaml3/constructor.py \
+- python_modules/pyyaml3/cyaml.py \
+- python_modules/pyyaml3/dumper.py \
+- python_modules/pyyaml3/emitter.py \
+- python_modules/pyyaml3/error.py \
+- python_modules/pyyaml3/events.py \
+- python_modules/pyyaml3/loader.py \
+- python_modules/pyyaml3/nodes.py \
+- python_modules/pyyaml3/parser.py \
+- python_modules/pyyaml3/reader.py \
+- python_modules/pyyaml3/representer.py \
+- python_modules/pyyaml3/resolver.py \
+- python_modules/pyyaml3/scanner.py \
+- python_modules/pyyaml3/serializer.py \
+- python_modules/pyyaml3/tokens.py \
+- $(NULL)
diff --git a/web/Makefile.am b/web/Makefile.am
-index 396cf0b..d94d87e 100644
+index 396cf0b..e14cc57 100644
--- a/web/Makefile.am
+++ b/web/Makefile.am
-@@ -25,15 +25,6 @@ dist_web_DATA = \
+@@ -4,10 +4,6 @@
+ MAINTAINERCLEANFILES= $(srcdir)/Makefile.in
+
+ dist_web_DATA = \
+- demo.html \
+- demo2.html \
+- demosites.html \
+- demosites2.html \
+ dashboard.html \
+ dashboard.js \
+ dashboard_info.js \
+@@ -25,15 +21,6 @@ dist_web_DATA = \
version.txt \
$(NULL)
@@ -26,7 +96,7 @@ index 396cf0b..d94d87e 100644
weblibdir=$(webdir)/lib
dist_weblib_DATA = \
lib/bootstrap-3.3.7.min.js \
-@@ -62,23 +53,11 @@ dist_webcss_DATA = \
+@@ -62,23 +49,11 @@ dist_webcss_DATA = \
css/bootstrap-theme-3.3.7.min.css \
css/bootstrap-slate-flat-3.3.7.css \
css/bootstrap-toggle-2.2.2.min.css \
@@ -50,3 +120,20 @@ index 396cf0b..d94d87e 100644
$(NULL)
webimagesdir=$(webdir)/images
+@@ -105,16 +80,6 @@ dist_webimages_DATA = \
+ images/seo-performance-multi-size.icns \
+ $(NULL)
+
+-
+-webwellknowndir=$(webdir)/.well-known
+-dist_webwellknown_DATA = \
+- $(NULL)
+-
+-webdntdir=$(webdir)/.well-known/dnt
+-dist_webdnt_DATA = \
+- .well-known/dnt/cookies \
+- $(NULL)
+-
+ version.txt:
+ if test -d "$(top_srcdir)/.git"; then \
+ git --git-dir="$(top_srcdir)/.git" log -n 1 --format=%H; \