summaryrefslogtreecommitdiffstats
path: root/debian/patches/0001-python-libraries-removed-from-make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-python-libraries-removed-from-make.patch')
-rw-r--r--debian/patches/0001-python-libraries-removed-from-make.patch196
1 files changed, 196 insertions, 0 deletions
diff --git a/debian/patches/0001-python-libraries-removed-from-make.patch b/debian/patches/0001-python-libraries-removed-from-make.patch
new file mode 100644
index 000000000..cb13ac23a
--- /dev/null
+++ b/debian/patches/0001-python-libraries-removed-from-make.patch
@@ -0,0 +1,196 @@
+From: Lennart Weller <lhw@ring0.de>
+Date: Mon, 18 Sep 2017 13:05:36 +0200
+Subject: python libraries removed from make
+
+---
+ python.d/Makefile.am | 107 ---------------------------------------------------
+ web/Makefile.am | 35 -----------------
+ 2 files changed, 142 deletions(-)
+
+diff --git a/python.d/Makefile.am b/python.d/Makefile.am
+index 84c2aea..2996a53 100644
+--- a/python.d/Makefile.am
++++ b/python.d/Makefile.am
+@@ -60,110 +60,3 @@ dist_pythonmodules_DATA = \
+ python_modules/msg.py \
+ python_modules/lm_sensors.py \
+ $(NULL)
+-
+-pythonyaml2dir=$(pythonmodulesdir)/pyyaml2
+-dist_pythonyaml2_DATA = \
+- python_modules/pyyaml2/__init__.py \
+- python_modules/pyyaml2/composer.py \
+- python_modules/pyyaml2/constructor.py \
+- python_modules/pyyaml2/cyaml.py \
+- python_modules/pyyaml2/dumper.py \
+- python_modules/pyyaml2/emitter.py \
+- python_modules/pyyaml2/error.py \
+- python_modules/pyyaml2/events.py \
+- python_modules/pyyaml2/loader.py \
+- python_modules/pyyaml2/nodes.py \
+- python_modules/pyyaml2/parser.py \
+- python_modules/pyyaml2/reader.py \
+- python_modules/pyyaml2/representer.py \
+- python_modules/pyyaml2/resolver.py \
+- python_modules/pyyaml2/scanner.py \
+- python_modules/pyyaml2/serializer.py \
+- python_modules/pyyaml2/tokens.py \
+- $(NULL)
+-
+-pythonyaml3dir=$(pythonmodulesdir)/pyyaml3
+-dist_pythonyaml3_DATA = \
+- python_modules/pyyaml3/__init__.py \
+- python_modules/pyyaml3/composer.py \
+- python_modules/pyyaml3/constructor.py \
+- python_modules/pyyaml3/cyaml.py \
+- python_modules/pyyaml3/dumper.py \
+- python_modules/pyyaml3/emitter.py \
+- python_modules/pyyaml3/error.py \
+- python_modules/pyyaml3/events.py \
+- python_modules/pyyaml3/loader.py \
+- python_modules/pyyaml3/nodes.py \
+- python_modules/pyyaml3/parser.py \
+- python_modules/pyyaml3/reader.py \
+- python_modules/pyyaml3/representer.py \
+- python_modules/pyyaml3/resolver.py \
+- python_modules/pyyaml3/scanner.py \
+- python_modules/pyyaml3/serializer.py \
+- python_modules/pyyaml3/tokens.py \
+- $(NULL)
+-
+-python_urllib3dir=$(pythonmodulesdir)/urllib3
+-dist_python_urllib3_DATA = \
+- python_modules/urllib3/__init__.py \
+- python_modules/urllib3/_collections.py \
+- python_modules/urllib3/connection.py \
+- python_modules/urllib3/connectionpool.py \
+- python_modules/urllib3/exceptions.py \
+- python_modules/urllib3/fields.py \
+- python_modules/urllib3/filepost.py \
+- python_modules/urllib3/response.py \
+- python_modules/urllib3/poolmanager.py \
+- python_modules/urllib3/request.py \
+- $(NULL)
+-
+-python_urllib3_utildir=$(python_urllib3dir)/util
+-dist_python_urllib3_util_DATA = \
+- python_modules/urllib3/util/__init__.py \
+- python_modules/urllib3/util/connection.py \
+- python_modules/urllib3/util/request.py \
+- python_modules/urllib3/util/response.py \
+- python_modules/urllib3/util/retry.py \
+- python_modules/urllib3/util/selectors.py \
+- python_modules/urllib3/util/ssl_.py \
+- python_modules/urllib3/util/timeout.py \
+- python_modules/urllib3/util/url.py \
+- python_modules/urllib3/util/wait.py \
+- $(NULL)
+-
+-python_urllib3_packagesdir=$(python_urllib3dir)/packages
+-dist_python_urllib3_packages_DATA = \
+- python_modules/urllib3/packages/__init__.py \
+- python_modules/urllib3/packages/ordered_dict.py \
+- python_modules/urllib3/packages/six.py \
+- $(NULL)
+-
+-python_urllib3_backportsdir=$(python_urllib3_packagesdir)/backports
+-dist_python_urllib3_backports_DATA = \
+- python_modules/urllib3/packages/backports/__init__.py \
+- python_modules/urllib3/packages/backports/makefile.py \
+- $(NULL)
+-
+-python_urllib3_ssl_match_hostnamedir=$(python_urllib3_packagesdir)/ssl_match_hostname
+-dist_python_urllib3_ssl_match_hostname_DATA = \
+- python_modules/urllib3/packages/ssl_match_hostname/__init__.py \
+- python_modules/urllib3/packages/ssl_match_hostname/_implementation.py \
+- $(NULL)
+-
+-python_urllib3_contribdir=$(python_urllib3dir)/contrib
+-dist_python_urllib3_contrib_DATA = \
+- python_modules/urllib3/contrib/__init__.py \
+- python_modules/urllib3/contrib/appengine.py \
+- python_modules/urllib3/contrib/ntlmpool.py \
+- python_modules/urllib3/contrib/pyopenssl.py \
+- python_modules/urllib3/contrib/securetransport.py \
+- python_modules/urllib3/contrib/socks.py \
+- $(NULL)
+-
+-python_urllib3_securetransportdir=$(python_urllib3_contribdir)/_securetransport
+-dist_python_urllib3_securetransport_DATA = \
+- python_modules/urllib3/contrib/_securetransport/__init__.py \
+- python_modules/urllib3/contrib/_securetransport/bindings.py \
+- python_modules/urllib3/contrib/_securetransport/low_level.py \
+- $(NULL)
+-
+diff --git a/web/Makefile.am b/web/Makefile.am
+index b587f5a..9f33500 100644
+--- a/web/Makefile.am
++++ b/web/Makefile.am
+@@ -4,10 +4,6 @@
+ MAINTAINERCLEANFILES= $(srcdir)/Makefile.in
+
+ dist_web_DATA = \
+- demo.html \
+- demo2.html \
+- demosites.html \
+- demosites2.html \
+ dashboard.html \
+ dashboard.js \
+ dashboard_info.js \
+@@ -27,15 +23,6 @@ dist_web_DATA = \
+ version.txt \
+ $(NULL)
+
+-webolddir=$(webdir)/old
+-dist_webold_DATA = \
+- old/datasource.html \
+- old/index.html \
+- old/index.js \
+- old/netdata.js \
+- old/theme.css \
+- $(NULL)
+-
+ weblibdir=$(webdir)/lib
+ dist_weblib_DATA = \
+ lib/bootstrap-3.3.7.min.js \
+@@ -64,23 +51,11 @@ dist_webcss_DATA = \
+ css/bootstrap-theme-3.3.7.min.css \
+ css/bootstrap-slate-flat-3.3.7.css \
+ css/bootstrap-toggle-2.2.2.min.css \
+- css/font-awesome.min.css \
+ css/c3-0.4.11.min.css \
+ $(NULL)
+
+ webfontsdir=$(webdir)/fonts
+ dist_webfonts_DATA = \
+- fonts/glyphicons-halflings-regular.eot \
+- fonts/glyphicons-halflings-regular.svg \
+- fonts/glyphicons-halflings-regular.ttf \
+- fonts/glyphicons-halflings-regular.woff \
+- fonts/glyphicons-halflings-regular.woff2 \
+- fonts/FontAwesome.otf \
+- fonts/fontawesome-webfont.eot \
+- fonts/fontawesome-webfont.svg \
+- fonts/fontawesome-webfont.ttf \
+- fonts/fontawesome-webfont.woff \
+- fonts/fontawesome-webfont.woff2 \
+ $(NULL)
+
+ webimagesdir=$(webdir)/images
+@@ -107,16 +82,6 @@ dist_webimages_DATA = \
+ images/seo-performance-multi-size.icns \
+ $(NULL)
+
+-
+-webwellknowndir=$(webdir)/.well-known
+-dist_webwellknown_DATA = \
+- $(NULL)
+-
+-webdntdir=$(webdir)/.well-known/dnt
+-dist_webdnt_DATA = \
+- .well-known/dnt/cookies \
+- $(NULL)
+-
+ version.txt:
+ if test -d "$(top_srcdir)/.git"; then \
+ git --git-dir="$(top_srcdir)/.git" log -n 1 --format=%H; \