summaryrefslogtreecommitdiffstats
path: root/debian/patches/0001-python-libraries-removed-from-make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-python-libraries-removed-from-make.patch')
-rw-r--r--debian/patches/0001-python-libraries-removed-from-make.patch86
1 files changed, 34 insertions, 52 deletions
diff --git a/debian/patches/0001-python-libraries-removed-from-make.patch b/debian/patches/0001-python-libraries-removed-from-make.patch
index ed5b314f8..d49036c8a 100644
--- a/debian/patches/0001-python-libraries-removed-from-make.patch
+++ b/debian/patches/0001-python-libraries-removed-from-make.patch
@@ -1,20 +1,20 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Wed, 4 Apr 2018 14:22:34 +0200
+Date: Wed, 14 Nov 2018 14:21:40 +0100
Subject: python libraries removed from make. remove unused contrib files
---
- python.d/Makefile.am | 106 -------------------------------
- python.d/python_modules/bases/loaders.py | 4 +-
- web/Makefile.am | 32 ----------
- 3 files changed, 2 insertions(+), 140 deletions(-)
+ collectors/python.d.plugin/Makefile.am | 106 ---------------------
+ .../python_modules/bases/loaders.py | 4 +-
+ web/gui/Makefile.am | 23 -----
+ 3 files changed, 2 insertions(+), 131 deletions(-)
-diff --git a/python.d/Makefile.am b/python.d/Makefile.am
-index a5fcc73..3349ccf 100644
---- a/python.d/Makefile.am
-+++ b/python.d/Makefile.am
-@@ -96,109 +96,3 @@ dist_third_party_DATA = \
- python_modules/third_party/ordereddict.py \
- python_modules/third_party/lm_sensors.py \
+diff --git a/collectors/python.d.plugin/Makefile.am b/collectors/python.d.plugin/Makefile.am
+index 5f214e4..79c9dc3 100644
+--- a/collectors/python.d.plugin/Makefile.am
++++ b/collectors/python.d.plugin/Makefile.am
+@@ -136,109 +136,3 @@ dist_third_party_DATA = \
+ python_modules/third_party/boinc_client.py \
+ python_modules/third_party/monotonic.py \
$(NULL)
-
-pythonyaml2dir=$(pythonmodulesdir)/pyyaml2
@@ -122,30 +122,28 @@ index a5fcc73..3349ccf 100644
- python_modules/urllib3/contrib/_securetransport/bindings.py \
- python_modules/urllib3/contrib/_securetransport/low_level.py \
- $(NULL)
-diff --git a/python.d/python_modules/bases/loaders.py b/python.d/python_modules/bases/loaders.py
-index d18b9dc..71ba221 100644
---- a/python.d/python_modules/bases/loaders.py
-+++ b/python.d/python_modules/bases/loaders.py
-@@ -8,11 +8,11 @@ from sys import version_info
- PY_VERSION = version_info[:2]
+diff --git a/collectors/python.d.plugin/python_modules/bases/loaders.py b/collectors/python.d.plugin/python_modules/bases/loaders.py
+index 9eb268c..28c67d7 100644
+--- a/collectors/python.d.plugin/python_modules/bases/loaders.py
++++ b/collectors/python.d.plugin/python_modules/bases/loaders.py
+@@ -11,9 +11,9 @@ PY_VERSION = version_info[:2]
- if PY_VERSION > (3, 1):
-- from pyyaml3 import SafeLoader as YamlSafeLoader
-+ from yaml import SafeLoader as YamlSafeLoader
- from importlib.machinery import SourceFileLoader
- DEFAULT_MAPPING_TAG = 'tag:yaml.org,2002:map'
- else:
-- from pyyaml2 import SafeLoader as YamlSafeLoader
-+ from yaml import SafeLoader as YamlSafeLoader
- from imp import load_source as SourceFileLoader
- DEFAULT_MAPPING_TAG = u'tag:yaml.org,2002:map'
+ try:
+ if PY_VERSION > (3, 1):
+- from pyyaml3 import SafeLoader as YamlSafeLoader
++ from yaml import SafeLoader as YamlSafeLoader
+ else:
+- from pyyaml2 import SafeLoader as YamlSafeLoader
++ from yaml import SafeLoader as YamlSafeLoader
+ except ImportError:
+ from yaml import SafeLoader as YamlSafeLoader
-diff --git a/web/Makefile.am b/web/Makefile.am
-index ac92287..57595fc 100644
---- a/web/Makefile.am
-+++ b/web/Makefile.am
-@@ -4,10 +4,6 @@
- MAINTAINERCLEANFILES= $(srcdir)/Makefile.in
+diff --git a/web/gui/Makefile.am b/web/gui/Makefile.am
+index 314ca37..2b6f124 100644
+--- a/web/gui/Makefile.am
++++ b/web/gui/Makefile.am
+@@ -9,10 +9,6 @@ dist_noinst_DATA = \
+ $(NULL)
dist_web_DATA = \
- demo.html \
@@ -155,23 +153,7 @@ index ac92287..57595fc 100644
dashboard.html \
dashboard.js \
dashboard_info.js \
-@@ -28,15 +24,6 @@ dist_web_DATA = \
- version.txt \
- $(NULL)
-
--webolddir=$(webdir)/old
--dist_webold_DATA = \
-- old/datasource.html \
-- old/index.html \
-- old/index.js \
-- old/netdata.js \
-- old/theme.css \
-- $(NULL)
--
- weblibdir=$(webdir)/lib
- dist_weblib_DATA = \
- lib/bootstrap-3.3.7.min.js \
-@@ -75,15 +62,6 @@ dist_webcss_DATA = \
+@@ -69,15 +65,6 @@ dist_webcss_DATA = \
css/c3-0.4.18.min.css \
$(NULL)
@@ -187,7 +169,7 @@ index ac92287..57595fc 100644
webimagesdir=$(webdir)/images
dist_webimages_DATA = \
images/alert-128-orange.png \
-@@ -108,16 +86,6 @@ dist_webimages_DATA = \
+@@ -103,16 +90,6 @@ dist_webimages_DATA = \
images/seo-performance-multi-size.icns \
$(NULL)