summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian/0001-use-system-python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian/0001-use-system-python.patch')
-rw-r--r--debian/patches/debian/0001-use-system-python.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/patches/debian/0001-use-system-python.patch b/debian/patches/debian/0001-use-system-python.patch
index 6f649cf12..5a14159d5 100644
--- a/debian/patches/debian/0001-use-system-python.patch
+++ b/debian/patches/debian/0001-use-system-python.patch
@@ -117,15 +117,15 @@ diff -Naurp netdata.orig/collectors/python.d.plugin/Makefile.am netdata/collecto
diff -Naurp netdata.orig/collectors/python.d.plugin/python_modules/bases/loaders.py netdata/collectors/python.d.plugin/python_modules/bases/loaders.py
--- netdata.orig/collectors/python.d.plugin/python_modules/bases/loaders.py
+++ netdata/collectors/python.d.plugin/python_modules/bases/loaders.py
-@@ -10,9 +10,9 @@ PY_VERSION = version_info[:2]
+@@ -9,10 +9,7 @@ from sys import version_info
+ PY_VERSION = version_info[:2]
try:
- if PY_VERSION > (3, 1):
+- if PY_VERSION > (3, 1):
- from pyyaml3 import SafeLoader as YamlSafeLoader
-+ from yaml import SafeLoader as YamlSafeLoader
- else:
+- else:
- from pyyaml2 import SafeLoader as YamlSafeLoader
-+ from yaml import SafeLoader as YamlSafeLoader
++ from yaml import SafeLoader as YamlSafeLoader
except ImportError:
from yaml import SafeLoader as YamlSafeLoader