summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 5c321d1fc..e2456ae7b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,6 +23,9 @@ MULTIARCH_INSTALL = debian/netdata.postinst
dh $@
override_dh_autoreconf:
+ rm -f debian/configure.ac.orig
+ cp configure.ac debian/configure.ac.orig
+
sed -i -e 's/^\(define(\[VERSION_MAJOR]\).*/\1, [$(VERSION_MAJOR)])/' \
-e 's/^\(define(\[VERSION_MINOR]\).*/\1, [$(VERSION_MINOR)])/' \
-e 's/^\(define(\[VERSION_FIX]\).*/\1, [$(VERSION_FIX)])/' \
@@ -31,6 +34,15 @@ override_dh_autoreconf:
dh_autoreconf
+override_dh_autoreconf_clean:
+ if [ -e debian/configure.ac.orig ]; \
+ then \
+ rm -f configure.ac; \
+ mv debian/configure.ac.orig configure.ac; \
+ fi
+
+ dh_autoreconf_clean
+
override_dh_auto_configure:
dh_auto_configure -- --libexecdir=/usr/lib/$(DEB_HOST_MULTIARCH) --with-math