summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 56e9db248..02f2b2858 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,8 @@
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
TOP = $(CURDIR)/debian/netdata
+VERSION := $(shell dpkg-parsechangelog -SVersion)
+
export DH_VERBOSE = 1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
@@ -32,8 +34,8 @@ override_dh_install-arch: $(MULTIARCH_INSTALL)
override_dh_install-indep:
dh_install
- # Deactivate automatic update check
- echo 0 > $(TOP)-data/usr/share/netdata/web/version.txt
+ # Setting package version (update check)
+ echo $(VERSION) > $(TOP)-data/usr/share/netdata/web/version.txt
override_dh_fixperms-arch:
dh_fixperms