summaryrefslogtreecommitdiffstats
path: root/docs/guides/python-collector.md
diff options
context:
space:
mode:
Diffstat (limited to 'docs/guides/python-collector.md')
-rw-r--r--docs/guides/python-collector.md4
1 files changed, 2 insertions, 2 deletions
diff --git a/docs/guides/python-collector.md b/docs/guides/python-collector.md
index f77699495..d89eb25e1 100644
--- a/docs/guides/python-collector.md
+++ b/docs/guides/python-collector.md
@@ -16,7 +16,7 @@ Golang is more performant, easier to maintain, and simpler for users since it do
execute. Python plugins require Python on the machine to be executed. Netdata uses Go as the platform of choice for
production-grade collectors.
-We generally do not accept contributions of Python modules to the Github project netdata/netdata. If you write a Python collector and
+We generally do not accept contributions of Python modules to the GitHub project netdata/netdata. If you write a Python collector and
want to make it available for other users, you should create the pull request in https://github.com/netdata/community.
## What you need to get started
@@ -540,7 +540,7 @@ At minimum, to be buildable and testable, the PR needs to include:
- A makefile for the plugin at `collectors/python.d.plugin/<module_dir>/Makefile.inc`. Check an existing plugin for what this should look like.
- A line in `collectors/python.d.plugin/Makefile.am` including the above-mentioned makefile. Place it with the other plugin includes (please keep the includes sorted alphabetically).
- Optionally, chart information in `web/gui/dashboard_info.js`. This generally involves specifying a name and icon for the section, and may include descriptions for the section or individual charts.
-- Optionally, some default alarm configurations for your collector in `health/health.d/<module_name>.conf` and a line adding `<module_name>.conf` in `health/Makefile.am`.
+- Optionally, some default alert configurations for your collector in `health/health.d/<module_name>.conf` and a line adding `<module_name>.conf` in `health/Makefile.am`.
## Framework class reference