summaryrefslogtreecommitdiffstats
path: root/fluent-bit/cmake/sanitizers-cmake/tests
diff options
context:
space:
mode:
Diffstat (limited to 'fluent-bit/cmake/sanitizers-cmake/tests')
-rw-r--r--fluent-bit/cmake/sanitizers-cmake/tests/CMakeLists.txt67
-rw-r--r--fluent-bit/cmake/sanitizers-cmake/tests/asan_test.cpp40
-rw-r--r--fluent-bit/cmake/sanitizers-cmake/tests/shortest.ext.test.cpp40
3 files changed, 0 insertions, 147 deletions
diff --git a/fluent-bit/cmake/sanitizers-cmake/tests/CMakeLists.txt b/fluent-bit/cmake/sanitizers-cmake/tests/CMakeLists.txt
deleted file mode 100644
index 8553e6326..000000000
--- a/fluent-bit/cmake/sanitizers-cmake/tests/CMakeLists.txt
+++ /dev/null
@@ -1,67 +0,0 @@
-# This file is part of CMake-sanitizers.
-#
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and associated documentation files (the "Software"), to deal
-# in the Software without restriction, including without limitation the rights
-# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-# copies of the Software, and to permit persons to whom the Software is
-# furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice shall be included in all
-# copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-# SOFTWARE.
-#
-#
-# Copyright (c)
-# 2013-2015 Matt Arsenault
-# 2015 RWTH Aachen University, Federal Republic of Germany
-#
-
-# Function to add testcases.
-function(add_testcase TESTNAME SOURCEFILES)
- # remove ${TESTNAME} from ${ARGV} to use ${ARGV} as ${SOURCEFILES}
- list(REMOVE_AT ARGV 0)
-
- # add a new executable
- add_executable(${TESTNAME} ${ARGV})
-
- # add a testcase for executable
- add_test(${TESTNAME} ${TESTNAME})
-endfunction(add_testcase)
-
-# Function to add testcases with asan enabled.
-function(add_sanitized_testcase TESTNAME SOURCEFILES)
- add_testcase(${TESTNAME} ${SOURCEFILES})
- add_sanitizers(${TESTNAME})
-endfunction(add_sanitized_testcase)
-
-
-
-set(SANITIZE_ADDRESS TRUE)
-
-#
-# search for sanitizers
-#
-find_package(Sanitizers)
-
-
-#
-# add testcases
-#
-add_sanitized_testcase("asan_test_cpp" asan_test.cpp)
-add_sanitized_testcase("shortest_ext_test_cpp" shortest.ext.test.cpp)
-
-set_tests_properties(
- "asan_test_cpp"
- "shortest_ext_test_cpp"
-PROPERTIES
- WILL_FAIL TRUE
-)
-
diff --git a/fluent-bit/cmake/sanitizers-cmake/tests/asan_test.cpp b/fluent-bit/cmake/sanitizers-cmake/tests/asan_test.cpp
deleted file mode 100644
index 6c0a370c3..000000000
--- a/fluent-bit/cmake/sanitizers-cmake/tests/asan_test.cpp
+++ /dev/null
@@ -1,40 +0,0 @@
-/* This file is part of CMake-sanitizers.
- *
- * Permission is hereby granted, free of charge, to any person obtaining a copy
- * of this software and associated documentation files (the "Software"), to deal
- * in the Software without restriction, including without limitation the rights
- * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
- * copies of the Software, and to permit persons to whom the Software is
- * furnished to do so, subject to the following conditions:
- *
- * The above copyright notice and this permission notice shall be included in
- * all copies or substantial portions of the Software.
- *
- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
- * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
- * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
- * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
- * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
- * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
- * SOFTWARE.
- *
- *
- * Copyright (c)
- * 2013-2015 Matt Arsenault
- * 2015 RWTH Aachen University, Federal Republic of Germany
- */
-
-
-int
-main(int argc, char **argv)
-{
- // Allocate a new array and delete it.
- int *array = new int[argc + 1];
- array[argc] = 0;
- delete[] array;
-
- /* Access element of the deleted array. This will cause an memory error with
- * address sanitizer.
- */
- return array[argc];
-}
diff --git a/fluent-bit/cmake/sanitizers-cmake/tests/shortest.ext.test.cpp b/fluent-bit/cmake/sanitizers-cmake/tests/shortest.ext.test.cpp
deleted file mode 100644
index 6c0a370c3..000000000
--- a/fluent-bit/cmake/sanitizers-cmake/tests/shortest.ext.test.cpp
+++ /dev/null
@@ -1,40 +0,0 @@
-/* This file is part of CMake-sanitizers.
- *
- * Permission is hereby granted, free of charge, to any person obtaining a copy
- * of this software and associated documentation files (the "Software"), to deal
- * in the Software without restriction, including without limitation the rights
- * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
- * copies of the Software, and to permit persons to whom the Software is
- * furnished to do so, subject to the following conditions:
- *
- * The above copyright notice and this permission notice shall be included in
- * all copies or substantial portions of the Software.
- *
- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
- * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
- * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
- * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
- * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
- * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
- * SOFTWARE.
- *
- *
- * Copyright (c)
- * 2013-2015 Matt Arsenault
- * 2015 RWTH Aachen University, Federal Republic of Germany
- */
-
-
-int
-main(int argc, char **argv)
-{
- // Allocate a new array and delete it.
- int *array = new int[argc + 1];
- array[argc] = 0;
- delete[] array;
-
- /* Access element of the deleted array. This will cause an memory error with
- * address sanitizer.
- */
- return array[argc];
-}