summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/monkey/conf
diff options
context:
space:
mode:
Diffstat (limited to 'fluent-bit/lib/monkey/conf')
-rw-r--r--fluent-bit/lib/monkey/conf/CMakeLists.txt17
-rw-r--r--fluent-bit/lib/monkey/conf/monkey.conf.in166
-rw-r--r--fluent-bit/lib/monkey/conf/monkey.mime.in145
-rw-r--r--fluent-bit/lib/monkey/conf/plugins.load.in10
-rw-r--r--fluent-bit/lib/monkey/conf/sites/default.in57
5 files changed, 0 insertions, 395 deletions
diff --git a/fluent-bit/lib/monkey/conf/CMakeLists.txt b/fluent-bit/lib/monkey/conf/CMakeLists.txt
deleted file mode 100644
index 1a5b9e6ea..000000000
--- a/fluent-bit/lib/monkey/conf/CMakeLists.txt
+++ /dev/null
@@ -1,17 +0,0 @@
-# Generate conf/monkey.conf
-configure_file(
- "${PROJECT_SOURCE_DIR}/conf/monkey.conf.in"
- "${PROJECT_BINARY_DIR}/conf/monkey.conf"
- )
-
-# Generate (copy) conf/monkey.mime
-configure_file(
- "${PROJECT_SOURCE_DIR}/conf/monkey.mime.in"
- "${PROJECT_BINARY_DIR}/conf/monkey.mime"
- )
-
-# Generate conf/sites/default
-configure_file(
- "${PROJECT_SOURCE_DIR}/conf/sites/default.in"
- "${PROJECT_BINARY_DIR}/conf/sites/default"
- )
diff --git a/fluent-bit/lib/monkey/conf/monkey.conf.in b/fluent-bit/lib/monkey/conf/monkey.conf.in
deleted file mode 100644
index 32e626320..000000000
--- a/fluent-bit/lib/monkey/conf/monkey.conf.in
+++ /dev/null
@@ -1,166 +0,0 @@
-# Monkey HTTP Server - Configuration
-# ==================================
-# These are the main variables and their descriptions, defined in respect
-# to the configuration of the different types of directives.
-
-[SERVER]
- # Listen:
- # -------
- # The Listen directive maps the port and optionally restricts the
- # network interface from where Monkey will be listens for incoming
- # connections. Multiple Listen directives are allowed.
- #
- # The Listen directive requires a port number, preceded by an
- # optional IPv4 or IPv6 address separated by a colon (:).
- # IPv6 addresses must be enclosed in brackets ([]), e.g:
- #
- # Listen 127.0.0.1:2001
- # Listen [::1]:2001
-
- Listen @MK_CONF_LISTEN@
-
- # Workers:
- # --------
- # Monkey launches threads to attend clients; each worker thread is capable
- # of attending more than one client request at one time. The amount of
- # clients that can be handled by each thread is calculated using the
- # number of file descriptors allowed by the system. If this variable
- # is set to 0 monkey will launch one thread per processor.
-
- Workers @MK_CONF_WORKERS@
-
- # Timeout:
- # --------
- # The largest span of time, expressed in seconds, during which you should
- # wait to receive the information or waiting time for the remote host to
- # accept an answer. (Timeout > 0)
-
- Timeout @MK_CONF_TIMEOUT@
-
- # PidFile:
- # --------
- # File where the server guards the process number when starting.
-
- PidFile @MK_PATH_PIDPATH@/@MK_PIDFILE@
-
- # UserDir:
- # --------
- # Directory name for users home (~/user).
-
- UserDir @MK_CONF_USERDIR@
-
- # Indexfile:
- # ----------
- # Number of the initial file of aperture when calling a directory.
-
- Indexfile @MK_CONF_INDEXFILE@
-
- # HideVersion:
- # ------------
- # For security reasons, sometimes people want to hide the version of his
- # own webserver to clients (values on/off).
-
- HideVersion @MK_CONF_HIDEVERSION@
-
- # Resume:
- # -------
- # Allow clients to request files by ranges (values on/off).
-
- Resume @MK_CONF_RESUME@
-
- # User:
- # -----
- # If you want the webserver to run as a process of a defined user, you can
- # define it in this variable. For the change of user to work, it's necessary
- # to execute Monkey with root privileges. If it's started by a user that
- # that doesn't have root privileges, this variable will be omitted.
-
- User @MK_CONF_USER@
-
- # -----------------
- # ADVANCED CONFIG
- # -----------------
- # Just change the next variables if you know what are you doing.
-
- # KeepAlive:
- # ----------
- # Allow persistent connections. (on/off)
-
- KeepAlive @MK_CONF_KA@
-
- # KeepAliveTimeout
- # ----------------
- # Number of seconds to wait for the next request in a persistent
- # connection (value > 0).
-
- KeepAliveTimeout @MK_CONF_KA_TIMEOUT@
-
- # MaxKeepAliveRequest:
- # --------------------
- # Maximum number of requests per connection. (value > 0)
-
- MaxKeepAliveRequest @MK_CONF_KA_MAXREQ@
-
- # MaxRequestSize:
- # ---------------
- # When a request arrives, Monkey allocs a 'chunk' of memory space
- # to receive the incoming data. As many times the incoming data
- # size is undeterminated, Monkey increases the buffer as required. This
- # variable defines the maximum size that the buffer can grow in terms
- # of KB. Example: defining 'MaxRequestSize 32' means 32 Kilobytes.
- # The value defined must be greater than zero. Default value defined
- # is 32.
-
- MaxRequestSize @MK_CONF_REQ_SIZE@
-
- # SymLink:
- # --------
- # Allow request to symbolic link files.
-
- SymLink @MK_CONF_SYMLINK@
-
- # DefaultMimeType:
- # ----------------
- # If a static content is requested and it does not contain a known extension,
- # Monkey will send the mime type specified on this directive.
-
- DefaultMimeType @MK_CONF_DEFAULT_MIME@
-
- # FDT:
- # ----
- # The File Descriptor Table (FDT) it's an internal mechanism to share open
- # file descriptors under specific threads and virtual host context. When
- # enabled, it helps to reduce the number of opened file descriptors for the
- # same resource and the number of required system calls to open and close
- # files.
- #
- # The overhead in memory of this feature is around ~5KB per worker.
-
- FDT @MK_CONF_FDT@
-
- # OverCapacity:
- # -------------
- # When the server is over capacity at networking level, is required to
- # prepare a contingency plan. The OverCapacity feature allows to define
- # the behavior under this situation. Monkey defines three options:
- #
- # Drop : just drop any new incoming connection.
- # Resist : try to serve all request, even some of them may delay.
- # TooBusy: report a 503 Service Unavailable HTTP status.
- #
- # The default behavior is 'Resist'.
-
- OverCapacity @MK_CONF_OVERCAPACITY@
-
- # FDLimit:
- # --------
- # Defines the maximum number of file descriptors that the server
- # can use, it can be translated to the maximum number of connections.
- # If the value is not set, Monkey will use the soft limit imposed to
- # the process (ulimit -n).
- #
- # If the variable is set, Monkey will try to increase or decrease
- # the limit under it restrictions. For values higher that Hard Limit
- # Monkey needs to be started by root user.
- #
- # FDLimit 4096
diff --git a/fluent-bit/lib/monkey/conf/monkey.mime.in b/fluent-bit/lib/monkey/conf/monkey.mime.in
deleted file mode 100644
index bf474c504..000000000
--- a/fluent-bit/lib/monkey/conf/monkey.mime.in
+++ /dev/null
@@ -1,145 +0,0 @@
-[MIMETYPES]
- html text/html
- jpg image/jpeg
- png image/png
- js application/x-javascript
- css text/css
- xml text/xml
- gif image/gif
- flv video/x-flv
- jpe image/jpeg
-
- deb application/x-debian-package
- jpeg image/jpeg
- htm text/html
- bmp image/bmp
- ief image/ief
- tiff image/tiff
- tif image/tiff
- wbmp image/vnd.wap.wbmp
- ras image/x-cmu-raster
- ico image/x-icon
- pnm image/x-portable-anymap
- pbm image/x-portable-bitmap
- pgm image/x-portable-graymap
- ppm image/x-portable-pixmap
- rgb image/x-rgb
- xbm image/x-xbitmap
- xpm image/x-xpixmap
- xwd image/x-xwindowdump
- svg image/svg+xml
- svgz image/svg+xml
-
- json application/json
- ez application/andrew-inset
- hqx application/mac-binhex40
- cpt application/mac-compactpro
- doc application/msword
- bin application/octet-stream
- dms application/octet-stream
- lha application/octet-stream
- lhz application/octet-stream
- exe application/octet-stream
- oda application/oda
- pdf application/pdf
- api application/postscript
- eps application/postscript
- ps application/postscript
- smi application/smil
- smil application/smil
- mif application/vnd.mif
- xls application/vnd.ms-excel
- ppt application/vnd.ms-powerpoint
- vbxml application/vnd.wap.wbxml
- wmlc application/vnd.wap.wmlc
- wmlsc application/vnd.wap.wmlscriptc
- bcpio application/x-bcpio
- vcd application/x-cdlink
- pgn application/x-chess-pgn
- cpio application/x-cpio
- csh application/x-csh
- dcr application/x-director
- dir application/x-director
- dxr application/x-director
- dvi application/x-dvi
- spl application/x-futuresplash
- gtar application/x-gtar
- gz application/x-gzip
- hdf application/x-hdf
- skp application/x-koan
- skd application/x-koan
- skt application/x-koan
- skm application/x-koan
- latex application/x-latex
- nc application/x-netcdf
- cdf application/x-netcdf
- sh application/x-sh
- shar application/x-shar
- swf application/x-shockwave-flash
- sit application/x-stuffit
- sv4cpio application/x-sv4cpio
- sv4crc application/x-sv4crc
- tar application/x-tar
- tcl application/x-tcl
- tex application/x-tex
- texinfo application/x-texinfo
- texi application/x-texinfo
- t application/x-troff
- tr application/x-troff
- roff application/x-troff
- man application/x-troff-man
- me application/x-troff-me
- ms application/x-troff-ms
- untar application/x-ustar
- src application/x-wais-source
- zip application/zip
-
- au audio/basic
- snd audio/basic
- mid audio/midi
- midi audio/midi
- kar audio/midi
- mpga audio/mpeg
- mp2 audio/mpeg
- mp3 audio/mpeg
- aif audio/x-aiff
- aiff audio/x-aiff
- aifc audio/x-aiff
- ram audio/x-pn-realaudio
- rm audio/x-pn-realaudio
- rpm audio/x-pn-realaudio-plugin
- ra audio/x-realaudio
- wav audio/x-wav
-
- pdb chemical/x-pdb
- xyz chemical/x-pdb
-
- igs model/iges
- iges model/iges
- msh model/mesh
- mesh model/mesh
- silo model/mesh
- wrl model/vrml
- vmrl model/vrml
-
- asc text/plain
- txt text/plain
- rtx text/richtext
- rtf text/rtf
- sgml text/sgml
- sgm text/sgml
- tsv text/tab-separated-values
- wml text/vnd.wap.wml
- wmls text/vnd.wap.wmlscript
- etx text/x-setext
- xsl text/xml
-
- mpeg video/mpeg
- mpg video/mpeg
- mpe video/mpeg
- qt video/quicktime
- mov video/quicktime
- avi video/x-msvideo
- movie video/x-sgi-movie
-
- ice x-conference/x-cooltalk
diff --git a/fluent-bit/lib/monkey/conf/plugins.load.in b/fluent-bit/lib/monkey/conf/plugins.load.in
deleted file mode 100644
index 54019a010..000000000
--- a/fluent-bit/lib/monkey/conf/plugins.load.in
+++ /dev/null
@@ -1,10 +0,0 @@
-# Monkey Plugins Loader
-# =====================
-# Monkey plugins are extended functionalities for Monkey,
-# the main directive to load a plugin is LoadPlugin plus
-# the absolute path for the desired plugin.
-#
-# Please check the following list of available plugins:
-
-[PLUGINS]
-@MK_LOAD_PLUGINS@
diff --git a/fluent-bit/lib/monkey/conf/sites/default.in b/fluent-bit/lib/monkey/conf/sites/default.in
deleted file mode 100644
index 0d259ae9e..000000000
--- a/fluent-bit/lib/monkey/conf/sites/default.in
+++ /dev/null
@@ -1,57 +0,0 @@
-# Default Host - Configuration
-# ============================
-# Here the variable principals of the program are defined in respect
-# to the configuration of the different types of directives.
-
-[HOST]
- # ServerName:
- # -----------
- # Allow you to set a host and domain name (e.g monkey.linuxchile.cl). If
- # you are working in a local network just set your IP address or if you
- # are working like localhost set your loopback address (127.0.0.1).
-
- ServerName @MK_VH_SERVERNAME@
-
- # DocumentRoot:
- # -------------
- # This variable corresponds to the location of the main server directory
- # of the web pages, where the files of your site are located.
- #
- # Example:
- # DocumentRoot /home/krypton/htdocs
-
- DocumentRoot @MK_PATH_WWW@
-
- # Redirect:
- # ---------
- # Under specific conditions, you may want the server performs a HTTP
- # redirect when this Virtual Host is reach. If that is the case, append
- # to the Redirect key the value of the address where to redirect the
- # HTTP client.
- #
- # Redirect http://monkey-project.com
-
-[LOGGER]
- # AccessLog:
- # ----------
- # Registration file of correct request.
-
- AccessLog @MK_PATH_LOG@/access.log
-
- # ErrorLog:
- # ---------
- # Registration file of incorrect request.
-
- ErrorLog @MK_PATH_LOG@/error.log
-
-[ERROR_PAGES]
- 404 404.html
-
-[HANDLERS]
- # FastCGI
- # =======
- # Match /.*\.php fastcgi
-
- # CGI
- # ===
- # Match /cgi-bin/.*\.cgi cgi