summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types
diff options
context:
space:
mode:
Diffstat (limited to 'fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types')
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/CMakeLists.txt139
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/src/hello.c288
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/src/hello.wat44
3 files changed, 471 insertions, 0 deletions
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/CMakeLists.txt b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/CMakeLists.txt
new file mode 100644
index 000000000..325699b20
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/CMakeLists.txt
@@ -0,0 +1,139 @@
+# Copyright (C) 2019 Intel Corporation. All rights reserved.
+# SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
+
+cmake_minimum_required (VERSION 3.14)
+
+include(CheckPIESupported)
+
+if (NOT WAMR_BUILD_PLATFORM STREQUAL "windows")
+ project(ref-types)
+else()
+ project (ref-types C ASM)
+ enable_language (ASM_MASM)
+endif()
+
+################ runtime settings ################
+string (TOLOWER ${CMAKE_HOST_SYSTEM_NAME} WAMR_BUILD_PLATFORM)
+if (APPLE)
+ add_definitions(-DBH_PLATFORM_DARWIN)
+endif ()
+
+# Resetdefault linker flags
+set(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
+set(CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS "")
+
+# WAMR features switch
+
+# Set WAMR_BUILD_TARGET, currently values supported:
+# "X86_64", "AMD_64", "X86_32", "AARCH64[sub]", "ARM[sub]", "THUMB[sub]",
+# "MIPS", "XTENSA", "RISCV64[sub]", "RISCV32[sub]"
+if (NOT DEFINED WAMR_BUILD_TARGET)
+ if (CMAKE_SYSTEM_PROCESSOR MATCHES "^(arm64|aarch64)")
+ set (WAMR_BUILD_TARGET "AARCH64")
+ elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "riscv64")
+ set (WAMR_BUILD_TARGET "RISCV64")
+ elseif (CMAKE_SIZEOF_VOID_P EQUAL 8)
+ # Build as X86_64 by default in 64-bit platform
+ set (WAMR_BUILD_TARGET "X86_64")
+ elseif (CMAKE_SIZEOF_VOID_P EQUAL 4)
+ # Build as X86_32 by default in 32-bit platform
+ set (WAMR_BUILD_TARGET "X86_32")
+ else ()
+ message(SEND_ERROR "Unsupported build target platform!")
+ endif ()
+endif ()
+
+if (NOT CMAKE_BUILD_TYPE)
+ set (CMAKE_BUILD_TYPE Release)
+endif ()
+
+if(NOT DEFINED WAMR_BUILD_INTERP)
+ set(WAMR_BUILD_INTERP 1)
+endif()
+
+if(NOT DEFINED WAMR_BUILD_AOT)
+ set(WAMR_BUILD_AOT 0)
+endif()
+
+if(NOT DEFINED WAMR_BUILD_JOT)
+ set(WAMR_BUILD_JIT 0)
+endif()
+
+if(NOT DEFINED WAMR_BUILD_FAST_INTERP)
+ set(WAMR_BUILD_FAST_INTERP 1)
+endif()
+
+if(NOT DEFINED WAMR_BUILD_LIBC_BUILTIN)
+ set(WAMR_BUILD_LIBC_BUILTIN 1)
+endif()
+
+# Enable reference-types feature
+set(WAMR_BUILD_REF_TYPES 1)
+
+if (NOT MSVC)
+ # compiling and linking flags
+ if (NOT (CMAKE_C_COMPILER MATCHES ".*clang.*" OR CMAKE_C_COMPILER_ID MATCHES ".*Clang"))
+ set (CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--gc-sections")
+ endif ()
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wformat -Wformat-security")
+ if (WAMR_BUILD_TARGET MATCHES "X86_.*" OR WAMR_BUILD_TARGET STREQUAL "AMD_64")
+ if (NOT (CMAKE_C_COMPILER MATCHES ".*clang.*" OR CMAKE_C_COMPILER_ID MATCHES ".*Clang"))
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mindirect-branch-register")
+ endif ()
+ endif ()
+endif()
+# build out vmlib
+set(WAMR_ROOT_DIR ${CMAKE_CURRENT_LIST_DIR}/../..)
+set(WAMRC ${WAMR_ROOT_DIR}/wamr-compiler/build/wamrc)
+include (${WAMR_ROOT_DIR}/build-scripts/runtime_lib.cmake)
+
+add_library(vmlib STATIC ${WAMR_RUNTIME_LIB_SOURCE})
+if (MSVC)
+ target_compile_definitions(vmlib PRIVATE WASM_API_EXTERN=)
+endif()
+
+################ application related ################
+## locate wat2wasm
+find_program(WAT2WASM
+ wat2wasm
+ PATHS /opt/wabt/bin
+ REQUIRED
+)
+
+if(NOT WAT2WASM)
+ message(SEND_ERROR "can not find wat2wasm")
+else ()
+ execute_process(COMMAND ${WAT2WASM} --version
+ OUTPUT_VARIABLE WAT2WASM_VERSION_OUTPUT)
+ string(STRIP ${WAT2WASM_VERSION_OUTPUT} WAT2WASM_VERSION)
+ message("-- Found wat2wasm ${WAT2WASM_VERSION}")
+endif()
+
+if (${WAT2WASM_VERSION} VERSION_LESS 1.0.26)
+ set(WAT2WASM_FLAGS "--enable-reference-types")
+endif ()
+
+include (${SHARED_DIR}/utils/uncommon/shared_uncommon.cmake)
+
+add_executable(hello src/hello.c ${UNCOMMON_SHARED_SOURCE})
+
+check_pie_supported()
+set_target_properties (hello PROPERTIES POSITION_INDEPENDENT_CODE ON)
+
+target_include_directories(hello PRIVATE ${UNCOMMON_SHARED_DIR})
+
+target_link_libraries(hello vmlib -lpthread -lm)
+
+if (MSVC)
+ target_compile_definitions(hello PRIVATE WASM_API_EXTERN=)
+endif()
+
+# wat to wasm
+file(GLOB WAT_FILE src/hello.wat)
+add_custom_target(hello_wasm ALL
+ COMMAND ${WAT2WASM} ${WAT_FILE} ${WAT2WASM_FLAGS} -o ${PROJECT_BINARY_DIR}/hello.wasm
+ DEPENDS ${WAT_FILE}
+ BYPRODUCTS ${PROJECT_BINARY_DIR}/hello.wasm
+ VERBATIM
+ SOURCES ${WAT_FILE}
+)
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/src/hello.c b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/src/hello.c
new file mode 100644
index 000000000..db2f7997f
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/src/hello.c
@@ -0,0 +1,288 @@
+/*
+ * Copyright (C) 2019 Intel Corporation. All rights reserved.
+ * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
+ */
+
+#include "bh_platform.h"
+#include "bh_read_file.h"
+#include "wasm_export.h"
+
+#define USE_GLOBAL_HEAP_BUF 0
+
+#if USE_GLOBAL_HEAP_BUF != 0
+static char global_heap_buf[10 * 1024 * 1024] = { 0 };
+#endif
+
+static uintptr_t global_objects[10] = { 0 };
+
+int32
+local_cmp_externref(wasm_exec_env_t exec_env, uintptr_t externref_a,
+ uintptr_t externref_b)
+{
+ return externref_a == externref_b;
+}
+
+int32
+local_chk_externref(wasm_exec_env_t exec_env, int32 index, uintptr_t externref)
+{
+ return externref == global_objects[index];
+}
+
+/* clang-format off */
+static NativeSymbol native_symbols[] = {
+ { "native-cmp-externref", local_cmp_externref, "(rr)i", NULL },
+ { "native-chk-externref", local_chk_externref, "(ir)i", NULL },
+};
+/* clang-format on */
+
+static inline void
+local_set_externref(int32 index, uintptr_t externref)
+{
+ global_objects[index] = externref;
+}
+
+static WASMFunctionInstanceCommon *wasm_set_externref_ptr;
+static WASMFunctionInstanceCommon *wasm_get_externref_ptr;
+static WASMFunctionInstanceCommon *wasm_cmp_externref_ptr;
+
+static bool
+wasm_set_externref(wasm_exec_env_t exec_env, wasm_module_inst_t inst,
+ int32 index, uintptr_t externref)
+{
+ union {
+ uintptr_t val;
+ uint32 parts[2];
+ } u;
+ uint32 argv[3] = { 0 };
+
+ if (!exec_env || !wasm_set_externref_ptr) {
+ return false;
+ }
+
+ u.val = externref;
+ argv[0] = index;
+ argv[1] = u.parts[0];
+ argv[2] = u.parts[1];
+ if (!wasm_runtime_call_wasm(exec_env, wasm_set_externref_ptr, 2, argv)) {
+ const char *exception;
+ if ((exception = wasm_runtime_get_exception(inst))) {
+ printf("Exception: %s\n", exception);
+ }
+ return false;
+ }
+
+ return true;
+}
+
+static bool
+wasm_get_externref(wasm_exec_env_t exec_env, wasm_module_inst_t inst,
+ int32 index, uintptr_t *ret_externref)
+{
+ wasm_val_t results[1] = { 0 };
+
+ if (!exec_env || !wasm_get_externref_ptr || !ret_externref) {
+ return false;
+ }
+
+ if (!wasm_runtime_call_wasm_v(exec_env, wasm_get_externref_ptr, 1, results,
+ 1, index)) {
+ const char *exception;
+ if ((exception = wasm_runtime_get_exception(inst))) {
+ printf("Exception: %s\n", exception);
+ }
+ return false;
+ }
+
+ if (WASM_ANYREF != results[0].kind) {
+ return false;
+ }
+
+ *ret_externref = results[0].of.foreign;
+ return true;
+}
+
+static bool
+wasm_cmp_externref(wasm_exec_env_t exec_env, wasm_module_inst_t inst,
+ int32 index, uintptr_t externref, int32 *ret_result)
+{
+ wasm_val_t results[1] = { 0 };
+ wasm_val_t arguments[2] = {
+ { .kind = WASM_I32, .of.i32 = index },
+ { .kind = WASM_ANYREF, .of.foreign = externref },
+ };
+
+ if (!exec_env || !wasm_cmp_externref_ptr || !ret_result) {
+ return false;
+ }
+
+ if (!wasm_runtime_call_wasm_a(exec_env, wasm_cmp_externref_ptr, 1, results,
+ 2, arguments)) {
+ const char *exception;
+ if ((exception = wasm_runtime_get_exception(inst))) {
+ printf("Exception: %s\n", exception);
+ }
+ return false;
+ }
+
+ if (results[0].kind != WASM_I32) {
+ return false;
+ }
+
+ *ret_result = results[0].of.i32;
+ return true;
+}
+
+static bool
+set_and_cmp(wasm_exec_env_t exec_env, wasm_module_inst_t inst, int32 i,
+ uintptr_t externref)
+{
+ int32 cmp_result = 0;
+ uintptr_t wasm_externref = 0;
+
+ wasm_set_externref(exec_env, inst, i, externref);
+ local_set_externref(i, externref);
+
+ wasm_get_externref(exec_env, inst, 0, &wasm_externref);
+ if (!local_chk_externref(exec_env, 0, wasm_externref)) {
+ printf("#%d, In host language world Wasm Externref 0x%lx Vs. Native "
+ "Externref 0x%lx FAILED\n",
+ i, wasm_externref, externref);
+ return false;
+ }
+
+ if (!wasm_cmp_externref(exec_env, inst, i, global_objects[i], &cmp_result)
+ || !cmp_result) {
+ printf("#%d, In Wasm world Native Externref 0x%lx Vs, Wasm Externref "
+ "FAILED\n",
+ i, global_objects[i]);
+ return false;
+ }
+
+ return true;
+}
+
+int
+main(int argc, char *argv[])
+{
+ char *wasm_file = "hello.wasm";
+ uint8 *wasm_file_buf = NULL;
+ uint32 wasm_file_size;
+ uint32 stack_size = 16 * 1024, heap_size = 16 * 1024;
+ wasm_module_t wasm_module = NULL;
+ wasm_module_inst_t wasm_module_inst = NULL;
+ wasm_exec_env_t exec_env = NULL;
+ RuntimeInitArgs init_args;
+ char error_buf[128] = { 0 };
+#if WASM_ENABLE_LOG != 0
+ int log_verbose_level = 2;
+#endif
+ const uint64 big_number = 0x123456789abc;
+
+ memset(&init_args, 0, sizeof(RuntimeInitArgs));
+
+#if USE_GLOBAL_HEAP_BUF != 0
+ init_args.mem_alloc_type = Alloc_With_Pool;
+ init_args.mem_alloc_option.pool.heap_buf = global_heap_buf;
+ init_args.mem_alloc_option.pool.heap_size = sizeof(global_heap_buf);
+#else
+ init_args.mem_alloc_type = Alloc_With_Allocator;
+ init_args.mem_alloc_option.allocator.malloc_func = malloc;
+ init_args.mem_alloc_option.allocator.realloc_func = realloc;
+ init_args.mem_alloc_option.allocator.free_func = free;
+#endif
+
+ init_args.n_native_symbols = sizeof(native_symbols) / sizeof(NativeSymbol);
+ init_args.native_module_name = "env";
+ init_args.native_symbols = native_symbols;
+
+ /* initialize runtime environment */
+ if (!wasm_runtime_full_init(&init_args)) {
+ printf("Init runtime environment failed.\n");
+ return -1;
+ }
+
+#if WASM_ENABLE_LOG != 0
+ bh_log_set_verbose_level(log_verbose_level);
+#endif
+
+ /* load WASM byte buffer from WASM bin file */
+ if (!(wasm_file_buf =
+ (uint8 *)bh_read_file_to_buffer(wasm_file, &wasm_file_size)))
+ goto fail;
+
+ /* load WASM module */
+ if (!(wasm_module = wasm_runtime_load(wasm_file_buf, wasm_file_size,
+ error_buf, sizeof(error_buf)))) {
+ printf("%s\n", error_buf);
+ goto fail;
+ }
+
+ /* instantiate the module */
+ if (!(wasm_module_inst =
+ wasm_runtime_instantiate(wasm_module, stack_size, heap_size,
+ error_buf, sizeof(error_buf)))) {
+ printf("%s\n", error_buf);
+ goto fail;
+ }
+
+ /* create an execution env */
+ if (!(exec_env =
+ wasm_runtime_create_exec_env(wasm_module_inst, stack_size))) {
+ printf("%s\n", "create exec env failed");
+ goto fail;
+ }
+
+ /* lookup function instance */
+ if (!(wasm_cmp_externref_ptr = wasm_runtime_lookup_function(
+ wasm_module_inst, "cmp-externref", NULL))) {
+ printf("%s\n", "lookup function cmp-externref failed");
+ goto fail;
+ }
+
+ if (!(wasm_get_externref_ptr = wasm_runtime_lookup_function(
+ wasm_module_inst, "get-externref", NULL))) {
+ printf("%s\n", "lookup function get-externref failed");
+ goto fail;
+ }
+
+ if (!(wasm_set_externref_ptr = wasm_runtime_lookup_function(
+ wasm_module_inst, "set-externref", NULL))) {
+ printf("%s\n", "lookup function set-externref failed");
+ goto fail;
+ }
+
+ /* test with NULL */
+ if (!set_and_cmp(exec_env, wasm_module_inst, 0, 0)
+ || !set_and_cmp(exec_env, wasm_module_inst, 1, big_number + 1)
+ || !set_and_cmp(exec_env, wasm_module_inst, 2, big_number + 2)
+ || !set_and_cmp(exec_env, wasm_module_inst, 3, big_number + 3)) {
+ goto fail;
+ }
+
+ printf("GREAT! PASS ALL CHKs\n");
+
+fail:
+ /* destroy exec env */
+ if (exec_env) {
+ wasm_runtime_destroy_exec_env(exec_env);
+ }
+
+ /* destroy the module instance */
+ if (wasm_module_inst) {
+ wasm_runtime_deinstantiate(wasm_module_inst);
+ }
+
+ /* unload the module */
+ if (wasm_module) {
+ wasm_runtime_unload(wasm_module);
+ }
+
+ /* free the file buffer */
+ if (wasm_file_buf) {
+ wasm_runtime_free(wasm_file_buf);
+ }
+
+ /* destroy runtime environment */
+ wasm_runtime_destroy();
+ return 0;
+}
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/src/hello.wat b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/src/hello.wat
new file mode 100644
index 000000000..3c2d2f96d
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/ref-types/src/hello.wat
@@ -0,0 +1,44 @@
+;; Copyright (C) 2019 Intel Corporation. All rights reserved.
+;; SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
+
+(module
+ (type $t0 (func (param i32 externref) (result i32)))
+
+ (import "env" "native-cmp-externref"
+ (func $native-cmp-externref (param externref externref) (result i32))
+ )
+
+ (import "env" "native-chk-externref"
+ (func $native-chk-externref (param i32 externref) (result i32))
+ )
+
+ (table $t1 8 8 externref)
+ (table $t2 funcref
+ (elem
+ $native-cmp-externref
+ $native-chk-externref
+ )
+ )
+
+ (func (export "set-externref") (param $i i32) (param $r externref)
+ (table.set $t1 (local.get $i) (local.get $r))
+ )
+
+ (func (export "get-externref") (param $i i32) (result externref)
+ (table.get $t1 (local.get $i))
+ )
+
+ (func (export "cmp-externref") (param $i i32) (param $r externref) (result i32)
+ (table.get $t1 (local.get $i))
+ (local.get $r)
+ (call $native-cmp-externref)
+ )
+
+ (func (export "chk-externref") (param $i i32) (param $r externref) (result i32)
+ (call_indirect $t2 (type $t0)
+ (local.get $i)
+ (local.get $r)
+ (i32.const 1)
+ )
+ )
+)