summaryrefslogtreecommitdiffstats
path: root/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps
diff options
context:
space:
mode:
Diffstat (limited to 'fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps')
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/CMakeLists.txt46
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/no_pthread.c74
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/wasi_thread_start.S22
-rw-r--r--fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/wasi_thread_start.h32
4 files changed, 174 insertions, 0 deletions
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/CMakeLists.txt b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/CMakeLists.txt
new file mode 100644
index 000000000..87f21e9fd
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/CMakeLists.txt
@@ -0,0 +1,46 @@
+# Copyright (C) 2022 Amazon.com, Inc. or its affiliates. All Rights Reserved.
+# SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
+
+if (APPLE)
+ set (HAVE_FLAG_SEARCH_PATHS_FIRST 0)
+ set (CMAKE_C_LINK_FLAGS "")
+ set (CMAKE_CXX_LINK_FLAGS "")
+endif ()
+
+if (NOT DEFINED WASI_SDK_DIR)
+ set (WASI_SDK_DIR "/opt/wasi-sdk")
+endif ()
+
+if (DEFINED WASI_SYSROOT)
+ set (CMAKE_SYSROOT "${WASI_SYSROOT}")
+endif ()
+
+set (CMAKE_C_COMPILER "${WASI_SDK_DIR}/bin/clang")
+set (CMAKE_ASM_COMPILER "${WASI_SDK_DIR}/bin/clang")
+set (CMAKE_EXE_LINKER_FLAGS "-target wasm32-wasi-threads")
+
+if ("$ENV{COLLECT_CODE_COVERAGE}" STREQUAL "1" OR COLLECT_CODE_COVERAGE EQUAL 1)
+ set (CMAKE_C_FLAGS "")
+ set (CMAKE_CXX_FLAGS "")
+endif ()
+
+function (compile_sample SOURCE_FILE)
+ get_filename_component (FILE_NAME ${SOURCE_FILE} NAME_WLE)
+ set (WASM_MODULE ${FILE_NAME}.wasm)
+ add_executable (${WASM_MODULE} ${SOURCE_FILE} ${ARGN})
+
+ target_compile_options (${WASM_MODULE} PRIVATE
+ -pthread -ftls-model=local-exec)
+
+ target_link_options (${WASM_MODULE} PRIVATE
+ -z stack-size=32768
+ LINKER:--export=__heap_base
+ LINKER:--export=__data_end
+ LINKER:--shared-memory,--max-memory=1966080
+ LINKER:--export=wasi_thread_start
+ LINKER:--export=malloc
+ LINKER:--export=free
+ )
+endfunction ()
+
+compile_sample(no_pthread.c wasi_thread_start.S) \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/no_pthread.c b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/no_pthread.c
new file mode 100644
index 000000000..dc3c95530
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/no_pthread.c
@@ -0,0 +1,74 @@
+/*
+ * Copyright (C) 2022 Amazon.com Inc. or its affiliates. All rights reserved.
+ * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
+ */
+#ifndef __wasi__
+#error This example only compiles to WASM/WASI target
+#endif
+
+#include <stdlib.h>
+#include <stdio.h>
+#include <assert.h>
+
+#include "wasi_thread_start.h"
+
+static const int64_t SECOND = 1000 * 1000 * 1000;
+
+typedef struct {
+ start_args_t base;
+ int th_ready;
+ int value;
+ int thread_id;
+} shared_t;
+
+void
+__wasi_thread_start_C(int thread_id, int *start_arg)
+{
+ shared_t *data = (shared_t *)start_arg;
+
+ printf("New thread ID: %d, starting parameter: %d\n", thread_id,
+ data->value);
+
+ data->thread_id = thread_id;
+ data->value += 8;
+ printf("Updated value: %d\n", data->value);
+
+ __atomic_store_n(&data->th_ready, 1, __ATOMIC_SEQ_CST);
+ __builtin_wasm_memory_atomic_notify(&data->th_ready, 1);
+}
+
+int
+main(int argc, char **argv)
+{
+ shared_t data = { { NULL }, 0, 52, -1 };
+ int thread_id;
+ int ret = EXIT_SUCCESS;
+
+ if (!start_args_init(&data.base)) {
+ printf("Stack allocation for thread failed\n");
+ return EXIT_FAILURE;
+ }
+
+ thread_id = __wasi_thread_spawn(&data);
+ if (thread_id < 0) {
+ printf("Failed to create thread: %d\n", thread_id);
+ ret = EXIT_FAILURE;
+ goto final;
+ }
+
+ if (__builtin_wasm_memory_atomic_wait32(&data.th_ready, 0, SECOND) == 2) {
+ printf("Timeout\n");
+ ret = EXIT_FAILURE;
+ goto final;
+ }
+
+ printf("Thread completed, new value: %d, thread id: %d\n", data.value,
+ data.thread_id);
+
+ assert(thread_id == data.thread_id);
+
+final:
+ start_args_deinit(&data.base);
+
+ return ret;
+}
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/wasi_thread_start.S b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/wasi_thread_start.S
new file mode 100644
index 000000000..ea8fd1400
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/wasi_thread_start.S
@@ -0,0 +1,22 @@
+# A slightly modified copy of the wasi-libc implementation
+# https://github.com/WebAssembly/wasi-libc/pull/376/
+ .globaltype __stack_pointer, i32
+ .functype __wasi_thread_start_C (i32, i32) -> ()
+
+ .globl wasi_thread_start
+
+wasi_thread_start:
+ .functype wasi_thread_start (i32, i32) -> ()
+
+ # Set up the minimum C environment.
+ # Note: offsetof(start_arg, stack) == 0
+ local.get 1 # start_arg
+ i32.load 0 # stack
+ global.set __stack_pointer
+
+ # Make the C function do the rest of work.
+ local.get 0 # tid
+ local.get 1 # start_arg
+ call __wasi_thread_start_C
+
+ end_function \ No newline at end of file
diff --git a/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/wasi_thread_start.h b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/wasi_thread_start.h
new file mode 100644
index 000000000..a46917d0a
--- /dev/null
+++ b/fluent-bit/lib/wasm-micro-runtime-WAMR-1.2.2/samples/wasi-threads/wasm-apps/wasi_thread_start.h
@@ -0,0 +1,32 @@
+/*
+ * Copyright (C) 2022 Amazon.com Inc. or its affiliates. All rights reserved.
+ * SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
+ */
+#ifndef WASI_THREAD_START_H
+#define WASI_THREAD_START_H
+
+#define STACK_SIZE 32 * 1024 // same as the main stack
+
+typedef struct {
+ void *stack;
+} start_args_t;
+
+static inline int
+start_args_init(start_args_t *start_args)
+{
+ start_args->stack = malloc(STACK_SIZE);
+ if (!start_args->stack) {
+ return 0;
+ }
+
+ start_args->stack += STACK_SIZE;
+ return 1;
+}
+
+static inline void
+start_args_deinit(start_args_t *start_args)
+{
+ free(start_args->stack - STACK_SIZE);
+}
+
+#endif \ No newline at end of file