summaryrefslogtreecommitdiffstats
path: root/health/notifications/opsgenie
diff options
context:
space:
mode:
Diffstat (limited to 'health/notifications/opsgenie')
-rw-r--r--health/notifications/opsgenie/Makefile.inc12
-rw-r--r--health/notifications/opsgenie/README.md98
-rw-r--r--health/notifications/opsgenie/metadata.yaml60
3 files changed, 0 insertions, 170 deletions
diff --git a/health/notifications/opsgenie/Makefile.inc b/health/notifications/opsgenie/Makefile.inc
deleted file mode 100644
index c85bb7c32..000000000
--- a/health/notifications/opsgenie/Makefile.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# THIS IS NOT A COMPLETE Makefile
-# IT IS INCLUDED BY ITS PARENT'S Makefile.am
-# IT IS REQUIRED TO REFERENCE ALL FILES RELATIVE TO THE PARENT
-
-# install these files
-dist_noinst_DATA += \
- opsgenie/README.md \
- opsgenie/Makefile.inc \
- $(NULL)
-
diff --git a/health/notifications/opsgenie/README.md b/health/notifications/opsgenie/README.md
deleted file mode 100644
index 1b61597e6..000000000
--- a/health/notifications/opsgenie/README.md
+++ /dev/null
@@ -1,98 +0,0 @@
-<!--startmeta
-custom_edit_url: "https://github.com/netdata/netdata/edit/master/health/notifications/opsgenie/README.md"
-meta_yaml: "https://github.com/netdata/netdata/edit/master/health/notifications/opsgenie/metadata.yaml"
-sidebar_label: "OpsGenie"
-learn_status: "Published"
-learn_rel_path: "Alerting/Notifications/Agent Dispatched Notifications"
-message: "DO NOT EDIT THIS FILE DIRECTLY, IT IS GENERATED BY THE NOTIFICATION'S metadata.yaml FILE"
-endmeta-->
-
-# OpsGenie
-
-
-<img src="https://netdata.cloud/img/opsgenie.png" width="150"/>
-
-
-Opsgenie is an alerting and incident response tool. It is designed to group and filter alarms, build custom routing rules for on-call teams, and correlate deployments and commits to incidents.
-You can send notifications to Opsgenie using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
-
-
-
-<img src="https://img.shields.io/badge/maintained%20by-Netdata-%2300ab44" />
-
-## Setup
-
-### Prerequisites
-
-####
-
-- An Opsgenie integration. You can create an [integration](https://docs.opsgenie.com/docs/api-integration) in the [Opsgenie](https://www.atlassian.com/software/opsgenie) dashboard.
-- Access to the terminal where Netdata Agent is running
-
-
-
-### Configuration
-
-#### File
-
-The configuration file name for this integration is `health_alarm_notify.conf`.
-
-
-You can edit the configuration file using the `edit-config` script from the
-Netdata [config directory](https://github.com/netdata/netdata/blob/master/docs/configure/nodes.md#the-netdata-config-directory).
-
-```bash
-cd /etc/netdata 2>/dev/null || cd /opt/netdata/etc/netdata
-sudo ./edit-config health_alarm_notify.conf
-```
-#### Options
-
-The following options can be defined for this notification
-
-<details><summary>Config Options</summary>
-
-| Name | Description | Default | Required |
-|:----|:-----------|:-------|:--------:|
-| SEND_OPSGENIE | Set `SEND_OPSGENIE` to YES | YES | yes |
-| OPSGENIE_API_KEY | Set `OPSGENIE_API_KEY` to your API key. | | yes |
-| OPSGENIE_API_URL | Set `OPSGENIE_API_URL` to the corresponding URL if required, for example there are region-specific API URLs such as `https://eu.api.opsgenie.com`. | https://api.opsgenie.com | no |
-
-</details>
-
-#### Examples
-
-##### Basic Configuration
-
-
-
-```yaml
-SEND_OPSGENIE="YES"
-OPSGENIE_API_KEY="11111111-2222-3333-4444-555555555555"
-OPSGENIE_API_URL=""
-
-```
-
-
-## Troubleshooting
-
-### Test Notification
-
-You can run the following command by hand, to test alerts configuration:
-
-```bash
-# become user netdata
-sudo su -s /bin/bash netdata
-
-# enable debugging info on the console
-export NETDATA_ALARM_NOTIFY_DEBUG=1
-
-# send test alarms to sysadmin
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test
-
-# send test alarms to any role
-/usr/libexec/netdata/plugins.d/alarm-notify.sh test "ROLE"
-```
-
-Note that this will test _all_ alert mechanisms for the selected role.
-
-
diff --git a/health/notifications/opsgenie/metadata.yaml b/health/notifications/opsgenie/metadata.yaml
deleted file mode 100644
index 78bd8c2bd..000000000
--- a/health/notifications/opsgenie/metadata.yaml
+++ /dev/null
@@ -1,60 +0,0 @@
-# yamllint disable rule:line-length
----
-- id: 'notify-opsgenie'
- meta:
- name: 'OpsGenie'
- link: 'https://www.atlassian.com/software/opsgenie'
- categories:
- - notify.agent
- icon_filename: 'opsgenie.png'
- keywords:
- - OpsGenie
- overview:
- notification_description: |
- Opsgenie is an alerting and incident response tool. It is designed to group and filter alarms, build custom routing rules for on-call teams, and correlate deployments and commits to incidents.
- You can send notifications to Opsgenie using Netdata's Agent alert notification feature, which supports dozens of endpoints, user roles, and more.
- notification_limitations: ''
- setup:
- prerequisites:
- list:
- - title: ''
- description: |
- - An Opsgenie integration. You can create an [integration](https://docs.opsgenie.com/docs/api-integration) in the [Opsgenie](https://www.atlassian.com/software/opsgenie) dashboard.
- - Access to the terminal where Netdata Agent is running
- configuration:
- file:
- name: 'health_alarm_notify.conf'
- options:
- description: 'The following options can be defined for this notification'
- folding:
- title: 'Config Options'
- enabled: true
- list:
- - name: 'SEND_OPSGENIE'
- default_value: 'YES'
- description: "Set `SEND_OPSGENIE` to YES"
- required: true
- - name: 'OPSGENIE_API_KEY'
- default_value: ''
- description: "Set `OPSGENIE_API_KEY` to your API key."
- required: true
- - name: 'OPSGENIE_API_URL'
- default_value: 'https://api.opsgenie.com'
- description: "Set `OPSGENIE_API_URL` to the corresponding URL if required, for example there are region-specific API URLs such as `https://eu.api.opsgenie.com`."
- required: false
- examples:
- folding:
- enabled: true
- title: ''
- list:
- - name: 'Basic Configuration'
- folding:
- enabled: false
- description: ''
- config: |
- SEND_OPSGENIE="YES"
- OPSGENIE_API_KEY="11111111-2222-3333-4444-555555555555"
- OPSGENIE_API_URL=""
- troubleshooting:
- problems:
- list: []