summaryrefslogtreecommitdiffstats
path: root/node.d
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--collectors/node.d.plugin/fronius/fronius.node.js (renamed from node.d/fronius.node.js)5
-rw-r--r--collectors/node.d.plugin/named/named.node.js (renamed from node.d/named.node.js)9
-rw-r--r--collectors/node.d.plugin/node_modules/asn1-ber.js (renamed from node.d/node_modules/asn1-ber.js)1
-rw-r--r--collectors/node.d.plugin/node_modules/extend.js (renamed from node.d/node_modules/extend.js)1
-rw-r--r--collectors/node.d.plugin/node_modules/lib/ber/errors.js (renamed from node.d/node_modules/lib/ber/errors.js)1
-rw-r--r--collectors/node.d.plugin/node_modules/lib/ber/index.js (renamed from node.d/node_modules/lib/ber/index.js)1
-rw-r--r--collectors/node.d.plugin/node_modules/lib/ber/reader.js (renamed from node.d/node_modules/lib/ber/reader.js)1
-rw-r--r--collectors/node.d.plugin/node_modules/lib/ber/types.js (renamed from node.d/node_modules/lib/ber/types.js)1
-rw-r--r--collectors/node.d.plugin/node_modules/lib/ber/writer.js (renamed from node.d/node_modules/lib/ber/writer.js)1
-rw-r--r--collectors/node.d.plugin/node_modules/net-snmp.js (renamed from node.d/node_modules/net-snmp.js)16
-rw-r--r--collectors/node.d.plugin/node_modules/netdata.js (renamed from node.d/node_modules/netdata.js)2
-rw-r--r--collectors/node.d.plugin/node_modules/pixl-xml.js (renamed from node.d/node_modules/pixl-xml.js)1
-rw-r--r--collectors/node.d.plugin/sma_webbox/sma_webbox.node.js (renamed from node.d/sma_webbox.node.js)5
-rw-r--r--collectors/node.d.plugin/snmp/snmp.node.js (renamed from node.d/snmp.node.js)17
-rw-r--r--collectors/node.d.plugin/stiebeleltron/stiebeleltron.node.js (renamed from node.d/stiebeleltron.node.js)5
-rw-r--r--collectors/statsd.plugin/Makefile.in (renamed from node.d/Makefile.in)149
-rw-r--r--node.d/Makefile.am28
-rw-r--r--node.d/README.md118
18 files changed, 106 insertions, 256 deletions
diff --git a/node.d/fronius.node.js b/collectors/node.d.plugin/fronius/fronius.node.js
index fc49e5d38..436f3a325 100644
--- a/node.d/fronius.node.js
+++ b/collectors/node.d.plugin/fronius/fronius.node.js
@@ -1,12 +1,13 @@
"use strict";
+// SPDX-License-Identifier: GPL-3.0-or-later
// This program will connect to one or more Fronius Symo Inverters.
// to get the Solar Power Generated (current, today).
// example configuration in netdata/conf.d/node.d/fronius.conf.md
-var url = require("url");
-var http = require("http");
+require("url");
+require("http");
var netdata = require("netdata");
netdata.debug("loaded " + __filename + " plugin");
diff --git a/node.d/named.node.js b/collectors/node.d.plugin/named/named.node.js
index 02c890c60..d13c608cb 100644
--- a/node.d/named.node.js
+++ b/collectors/node.d.plugin/named/named.node.js
@@ -1,4 +1,5 @@
'use strict';
+// SPDX-License-Identifier: GPL-3.0-or-later
// collect statistics from bind (named) v9.10+
//
@@ -36,8 +37,8 @@ statistics-channels {
};
*/
-var url = require('url');
-var http = require('http');
+require('url');
+require('http');
var XML = require('pixl-xml');
var netdata = require('netdata');
@@ -79,11 +80,11 @@ var named = {
multiplier: multiplier, // the multiplier
divisor: divisor, // the divisor
hidden: false // is hidden (boolean)
- }
+ };
}
}
- if(found === false)
+ if(!found)
return null;
chart = service.chart(id, chart);
diff --git a/node.d/node_modules/asn1-ber.js b/collectors/node.d.plugin/node_modules/asn1-ber.js
index 57809f486..55c8f688e 100644
--- a/node.d/node_modules/asn1-ber.js
+++ b/collectors/node.d.plugin/node_modules/asn1-ber.js
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: MIT
var Ber = require('./lib/ber/index')
diff --git a/node.d/node_modules/extend.js b/collectors/node.d.plugin/node_modules/extend.js
index 0fdd8be22..3cd2e9155 100644
--- a/node.d/node_modules/extend.js
+++ b/collectors/node.d.plugin/node_modules/extend.js
@@ -1,4 +1,5 @@
// https://github.com/justmoon/node-extend
+// SPDX-License-Identifier: MIT
'use strict';
diff --git a/node.d/node_modules/lib/ber/errors.js b/collectors/node.d.plugin/node_modules/lib/ber/errors.js
index 0106747e6..1c0df7b13 100644
--- a/node.d/node_modules/lib/ber/errors.js
+++ b/collectors/node.d.plugin/node_modules/lib/ber/errors.js
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: MIT
module.exports = {
InvalidAsn1Error: function(msg) {
diff --git a/node.d/node_modules/lib/ber/index.js b/collectors/node.d.plugin/node_modules/lib/ber/index.js
index 65985c1e1..eb69ec526 100644
--- a/node.d/node_modules/lib/ber/index.js
+++ b/collectors/node.d.plugin/node_modules/lib/ber/index.js
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: MIT
var errors = require('./errors')
var types = require('./types')
diff --git a/node.d/node_modules/lib/ber/reader.js b/collectors/node.d.plugin/node_modules/lib/ber/reader.js
index f93d829aa..06decf4b9 100644
--- a/node.d/node_modules/lib/ber/reader.js
+++ b/collectors/node.d.plugin/node_modules/lib/ber/reader.js
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: MIT
var assert = require('assert');
diff --git a/node.d/node_modules/lib/ber/types.js b/collectors/node.d.plugin/node_modules/lib/ber/types.js
index 345824bb1..7519ddcf5 100644
--- a/node.d/node_modules/lib/ber/types.js
+++ b/collectors/node.d.plugin/node_modules/lib/ber/types.js
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: MIT
module.exports = {
EOC: 0,
diff --git a/node.d/node_modules/lib/ber/writer.js b/collectors/node.d.plugin/node_modules/lib/ber/writer.js
index bf9805886..d3a718f14 100644
--- a/node.d/node_modules/lib/ber/writer.js
+++ b/collectors/node.d.plugin/node_modules/lib/ber/writer.js
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: MIT
var assert = require('assert');
var ASN1 = require('./types');
diff --git a/node.d/node_modules/net-snmp.js b/collectors/node.d.plugin/node_modules/net-snmp.js
index ac9a8d350..484597dcb 100644
--- a/node.d/node_modules/net-snmp.js
+++ b/collectors/node.d.plugin/node_modules/net-snmp.js
@@ -1,5 +1,6 @@
// Copyright 2013 Stephen Vickers <stephen.vickers.sv@gmail.com>
+// SPDX-License-Identifier: MIT
var ber = require ("asn1-ber").Ber;
var dgram = require ("dgram");
@@ -577,6 +578,10 @@ var Session = function (target, community, options) {
? parseInt(options.sourcePort)
: undefined;
+ this.idBitsSize = (options && options.idBitsSize)
+ ? parseInt(options.idBitsSize)
+ : 32;
+
this.reqs = {};
this.reqCount = 0;
@@ -608,8 +613,11 @@ Session.prototype.cancelRequests = function (error) {
}
};
-function _generateId () {
- return Math.floor (Math.random () + Math.random () * 10000000)
+function _generateId (bitSize) {
+ if (bitSize === 16) {
+ return Math.floor(Math.random() * 10000) % 65535;
+ }
+ return Math.floor(Math.random() * 100000000) % 4294967295;
}
Session.prototype.get = function (oids, responseCb) {
@@ -1043,7 +1051,7 @@ Session.prototype.simpleGet = function (pduClass, feedCb, varbinds,
var req = {};
try {
- var id = _generateId ();
+ var id = _generateId (this.idBitsSize);
var pdu = new pduClass (id, varbinds, options);
var message = new RequestMessage (this.version, this.community, pdu);
@@ -1289,7 +1297,7 @@ Session.prototype.trap = function () {
pduVarbinds.push (varbind);
}
- var id = _generateId ();
+ var id = _generateId (this.idBitsSize);
if (this.version == Version2c) {
if (typeof typeOrOid != "string")
diff --git a/node.d/node_modules/netdata.js b/collectors/node.d.plugin/node_modules/netdata.js
index 4ab8308c1..603922c6e 100644
--- a/node.d/node_modules/netdata.js
+++ b/collectors/node.d.plugin/node_modules/netdata.js
@@ -3,7 +3,7 @@
// netdata
// real-time performance and health monitoring, done right!
// (C) 2016 Costa Tsaousis <costa@tsaousis.gr>
-// GPL v3+
+// SPDX-License-Identifier: GPL-3.0-or-later
var url = require('url');
var http = require('http');
diff --git a/node.d/node_modules/pixl-xml.js b/collectors/node.d.plugin/node_modules/pixl-xml.js
index 481acbaeb..48de89e77 100644
--- a/node.d/node_modules/pixl-xml.js
+++ b/collectors/node.d.plugin/node_modules/pixl-xml.js
@@ -1,3 +1,4 @@
+// SPDX-License-Identifier: MIT
/*
JavaScript XML Library
Plus a bunch of object utility functions
diff --git a/node.d/sma_webbox.node.js b/collectors/node.d.plugin/sma_webbox/sma_webbox.node.js
index 3d99943d4..b9a168adc 100644
--- a/node.d/sma_webbox.node.js
+++ b/collectors/node.d.plugin/sma_webbox/sma_webbox.node.js
@@ -1,4 +1,5 @@
'use strict';
+// SPDX-License-Identifier: GPL-3.0-or-later
// This program will connect to one or more SMA Sunny Webboxes
// to get the Solar Power Generated (current, today, total).
@@ -23,8 +24,8 @@
}
*/
-var url = require('url');
-var http = require('http');
+require('url');
+require('http');
var netdata = require('netdata');
if(netdata.options.DEBUG === true) netdata.debug('loaded ' + __filename + ' plugin');
diff --git a/node.d/snmp.node.js b/collectors/node.d.plugin/snmp/snmp.node.js
index 3e7027958..a051d3d3a 100644
--- a/node.d/snmp.node.js
+++ b/collectors/node.d.plugin/snmp/snmp.node.js
@@ -1,4 +1,5 @@
'use strict';
+// SPDX-License-Identifier: GPL-3.0-or-later
// netdata snmp module
// This program will connect to one or more SNMP Agents
//
@@ -170,7 +171,7 @@ netdata.processors.snmp = {
var oid = this.fixoid(dim.oid);
var oidname = this.fixoid(dim.oidname);
-
+
if(__DEBUG === true)
netdata.debug(service.module.name + ': ' + service.name + ': indexing ' + this.name + ' chart: ' + c + ', dimension: ' + d + ', OID: ' + oid + ", OID name: " + oidname);
@@ -275,14 +276,16 @@ netdata.processors.snmp = {
switch(varbinds[i].type) {
case net_snmp.ObjectType.OctetString:
- if(service.snmp_oids_index[varbinds[i].oid].type !== 'title')
+ if (service.snmp_oids_index[varbinds[i].oid].type !== 'title' && service.snmp_oids_index[varbinds[i].oid].type !== 'name') {
// parse floating point values, exposed as strings
value = parseFloat(varbinds[i].value) * 1000;
- if(__DEBUG === true) netdata.debug(service.module.name + ': ' + service.name + ': found ' + service.module.name + ' value of OIDs ' + varbinds[i].oid + ", ObjectType " + net_snmp.ObjectType[varbinds[i].type] + " (" + netdata.stringify(varbinds[i].type) + "), typeof(" + typeof(varbinds[i].value) + "), in JSON: " + netdata.stringify(varbinds[i].value) + ", value = " + value.toString() + " (parsed as float in string)");
- else
+ if (__DEBUG === true) netdata.debug(service.module.name + ': ' + service.name + ': found ' + service.module.name + ' value of OIDs ' + varbinds[i].oid + ", ObjectType " + net_snmp.ObjectType[varbinds[i].type] + " (" + netdata.stringify(varbinds[i].type) + "), typeof(" + typeof(varbinds[i].value) + "), in JSON: " + netdata.stringify(varbinds[i].value) + ", value = " + value.toString() + " (parsed as float in string)");
+ }
+ else {
// just use the string
value = varbinds[i].value;
- if(__DEBUG === true) netdata.debug(service.module.name + ': ' + service.name + ': found ' + service.module.name + ' value of OIDs ' + varbinds[i].oid + ", ObjectType " + net_snmp.ObjectType[varbinds[i].type] + " (" + netdata.stringify(varbinds[i].type) + "), typeof(" + typeof(varbinds[i].value) + "), in JSON: " + netdata.stringify(varbinds[i].value) + ", value = " + value.toString() + " (parsed as string)");
+ if (__DEBUG === true) netdata.debug(service.module.name + ': ' + service.name + ': found ' + service.module.name + ' value of OIDs ' + varbinds[i].oid + ", ObjectType " + net_snmp.ObjectType[varbinds[i].type] + " (" + netdata.stringify(varbinds[i].type) + "), typeof(" + typeof(varbinds[i].value) + "), in JSON: " + netdata.stringify(varbinds[i].value) + ", value = " + value.toString() + " (parsed as string)");
+ }
break;
case net_snmp.ObjectType.Counter64:
@@ -306,7 +309,7 @@ netdata.processors.snmp = {
if(value !== null) {
switch(service.snmp_oids_index[varbinds[i].oid].type) {
case 'title': service.snmp_oids_index[varbinds[i].oid].link.title += ' ' + value; break;
- case 'name' : service.snmp_oids_index[varbinds[i].oid].link.name = value; break;
+ case 'name' : service.snmp_oids_index[varbinds[i].oid].link.name = value.toString().replace(/\W/g, '_'); break;
case 'value': service.snmp_oids_index[varbinds[i].oid].link.value = value; break;
}
}
@@ -445,7 +448,7 @@ var snmp = {
var id = c + from.toString();
var chart = extend(true, {}, service_request_chart);
chart.title += from.toString();
-
+
if(typeof chart.titleoid !== 'undefined')
chart.titleoid += from.toString();
diff --git a/node.d/stiebeleltron.node.js b/collectors/node.d.plugin/stiebeleltron/stiebeleltron.node.js
index 77317f2fb..250c26540 100644
--- a/node.d/stiebeleltron.node.js
+++ b/collectors/node.d.plugin/stiebeleltron/stiebeleltron.node.js
@@ -1,12 +1,13 @@
'use strict';
+// SPDX-License-Identifier: GPL-3.0-or-later
// This program will connect to one Stiebel Eltron ISG for heatpump heating
// to get the heat pump metrics.
// example configuration in netdata/conf.d/node.d/stiebeleltron.conf.md
-var url = require("url");
-var http = require("http");
+require("url");
+require("http");
var netdata = require("netdata");
netdata.debug("loaded " + __filename + " plugin");
diff --git a/node.d/Makefile.in b/collectors/statsd.plugin/Makefile.in
index dd572ee8b..5c16a86d1 100644
--- a/node.d/Makefile.in
+++ b/collectors/statsd.plugin/Makefile.in
@@ -14,6 +14,8 @@
@SET_MAKE@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
VPATH = @srcdir@
am__is_gnu_make = test -n '$(MAKEFILE_LIST)' && test -n '$(MAKELEVEL)'
am__make_running_with_option = \
@@ -78,19 +80,21 @@ PRE_UNINSTALL = :
POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
-subdir = node.d
+subdir = collectors/statsd.plugin
DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
- $(dist_node_DATA) $(dist_nodemodules_DATA) \
- $(dist_nodemoduleslibber_DATA)
+ $(dist_noinst_DATA) $(dist_statsdconfig_DATA) \
+ $(dist_userstatsdconfig_DATA)
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-am__aclocal_m4_deps = $(top_srcdir)/m4/ax_c___atomic.m4 \
- $(top_srcdir)/m4/ax_c__generic.m4 $(top_srcdir)/m4/ax_c_lto.m4 \
- $(top_srcdir)/m4/ax_c_mallinfo.m4 \
- $(top_srcdir)/m4/ax_c_mallopt.m4 \
- $(top_srcdir)/m4/ax_check_compile_flag.m4 \
- $(top_srcdir)/m4/ax_gcc_func_attribute.m4 \
- $(top_srcdir)/m4/ax_pthread.m4 $(top_srcdir)/m4/jemalloc.m4 \
- $(top_srcdir)/m4/tcmalloc.m4 $(top_srcdir)/configure.ac
+am__aclocal_m4_deps = $(top_srcdir)/build/m4/ax_c___atomic.m4 \
+ $(top_srcdir)/build/m4/ax_c__generic.m4 \
+ $(top_srcdir)/build/m4/ax_c_lto.m4 \
+ $(top_srcdir)/build/m4/ax_c_mallinfo.m4 \
+ $(top_srcdir)/build/m4/ax_c_mallopt.m4 \
+ $(top_srcdir)/build/m4/ax_check_compile_flag.m4 \
+ $(top_srcdir)/build/m4/ax_gcc_func_attribute.m4 \
+ $(top_srcdir)/build/m4/ax_pthread.m4 \
+ $(top_srcdir)/build/m4/jemalloc.m4 \
+ $(top_srcdir)/build/m4/tcmalloc.m4 $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
mkinstalldirs = $(install_sh) -d
@@ -143,10 +147,10 @@ am__uninstall_files_from_dir = { \
|| { echo " ( cd '$$dir' && rm -f" $$files ")"; \
$(am__cd) "$$dir" && rm -f $$files; }; \
}
-am__installdirs = "$(DESTDIR)$(nodedir)" "$(DESTDIR)$(nodemodulesdir)" \
- "$(DESTDIR)$(nodemoduleslibberdir)"
-DATA = $(dist_node_DATA) $(dist_nodemodules_DATA) \
- $(dist_nodemoduleslibber_DATA)
+am__installdirs = "$(DESTDIR)$(statsdconfigdir)" \
+ "$(DESTDIR)$(userstatsdconfigdir)"
+DATA = $(dist_noinst_DATA) $(dist_statsdconfig_DATA) \
+ $(dist_userstatsdconfig_DATA)
am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) $(LISP)
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
ACLOCAL = @ACLOCAL@
@@ -246,6 +250,7 @@ build = @build@
build_alias = @build_alias@
build_cpu = @build_cpu@
build_os = @build_os@
+build_target = @build_target@
build_vendor = @build_vendor@
builddir = @builddir@
cachedir = @cachedir@
@@ -267,6 +272,7 @@ htmldir = @htmldir@
includedir = @includedir@
infodir = @infodir@
install_sh = @install_sh@
+libconfigdir = @libconfigdir@
libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
@@ -293,33 +299,22 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
varlibdir = @varlibdir@
webdir = @webdir@
+AUTOMAKE_OPTIONS = subdir-objects
MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
-dist_node_DATA = \
+dist_noinst_DATA = \
README.md \
- named.node.js \
- fronius.node.js \
- sma_webbox.node.js \
- snmp.node.js \
- stiebeleltron.node.js \
$(NULL)
-nodemodulesdir = $(nodedir)/node_modules
-dist_nodemodules_DATA = \
- node_modules/netdata.js \
- node_modules/extend.js \
- node_modules/pixl-xml.js \
- node_modules/net-snmp.js \
- node_modules/asn1-ber.js \
- $(NULL)
+statsdconfigdir = $(libconfigdir)/statsd.d
+dist_statsdconfig_DATA = \
+ $(top_srcdir)/installer/.keep \
+ example.conf \
+ $(NULL)
-nodemoduleslibberdir = $(nodedir)/node_modules/lib/ber
-dist_nodemoduleslibber_DATA = \
- node_modules/lib/ber/index.js \
- node_modules/lib/ber/errors.js \
- node_modules/lib/ber/reader.js \
- node_modules/lib/ber/types.js \
- node_modules/lib/ber/writer.js \
- $(NULL)
+userstatsdconfigdir = $(configdir)/statsd.d
+dist_userstatsdconfig_DATA = \
+ $(top_srcdir)/installer/.keep \
+ $(NULL)
all: all-am
@@ -333,9 +328,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(am__confi
exit 1;; \
esac; \
done; \
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu node.d/Makefile'; \
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu collectors/statsd.plugin/Makefile'; \
$(am__cd) $(top_srcdir) && \
- $(AUTOMAKE) --gnu node.d/Makefile
+ $(AUTOMAKE) --gnu collectors/statsd.plugin/Makefile
.PRECIOUS: Makefile
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
@case '$?' in \
@@ -354,69 +349,48 @@ $(top_srcdir)/configure: @MAINTAINER_MODE_TRUE@ $(am__configure_deps)
$(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(am__aclocal_m4_deps)
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
$(am__aclocal_m4_deps):
-install-dist_nodeDATA: $(dist_node_DATA)
- @$(NORMAL_INSTALL)
- @list='$(dist_node_DATA)'; test -n "$(nodedir)" || list=; \
- if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(nodedir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(nodedir)" || exit 1; \
- fi; \
- for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- echo "$$d$$p"; \
- done | $(am__base_list) | \
- while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(nodedir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(nodedir)" || exit $$?; \
- done
-
-uninstall-dist_nodeDATA:
- @$(NORMAL_UNINSTALL)
- @list='$(dist_node_DATA)'; test -n "$(nodedir)" || list=; \
- files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- dir='$(DESTDIR)$(nodedir)'; $(am__uninstall_files_from_dir)
-install-dist_nodemodulesDATA: $(dist_nodemodules_DATA)
+install-dist_statsdconfigDATA: $(dist_statsdconfig_DATA)
@$(NORMAL_INSTALL)
- @list='$(dist_nodemodules_DATA)'; test -n "$(nodemodulesdir)" || list=; \
+ @list='$(dist_statsdconfig_DATA)'; test -n "$(statsdconfigdir)" || list=; \
if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(nodemodulesdir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(nodemodulesdir)" || exit 1; \
+ echo " $(MKDIR_P) '$(DESTDIR)$(statsdconfigdir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(statsdconfigdir)" || exit 1; \
fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(nodemodulesdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(nodemodulesdir)" || exit $$?; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(statsdconfigdir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(statsdconfigdir)" || exit $$?; \
done
-uninstall-dist_nodemodulesDATA:
+uninstall-dist_statsdconfigDATA:
@$(NORMAL_UNINSTALL)
- @list='$(dist_nodemodules_DATA)'; test -n "$(nodemodulesdir)" || list=; \
+ @list='$(dist_statsdconfig_DATA)'; test -n "$(statsdconfigdir)" || list=; \
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- dir='$(DESTDIR)$(nodemodulesdir)'; $(am__uninstall_files_from_dir)
-install-dist_nodemoduleslibberDATA: $(dist_nodemoduleslibber_DATA)
+ dir='$(DESTDIR)$(statsdconfigdir)'; $(am__uninstall_files_from_dir)
+install-dist_userstatsdconfigDATA: $(dist_userstatsdconfig_DATA)
@$(NORMAL_INSTALL)
- @list='$(dist_nodemoduleslibber_DATA)'; test -n "$(nodemoduleslibberdir)" || list=; \
+ @list='$(dist_userstatsdconfig_DATA)'; test -n "$(userstatsdconfigdir)" || list=; \
if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(nodemoduleslibberdir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(nodemoduleslibberdir)" || exit 1; \
+ echo " $(MKDIR_P) '$(DESTDIR)$(userstatsdconfigdir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(userstatsdconfigdir)" || exit 1; \
fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(nodemoduleslibberdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(nodemoduleslibberdir)" || exit $$?; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(userstatsdconfigdir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(userstatsdconfigdir)" || exit $$?; \
done
-uninstall-dist_nodemoduleslibberDATA:
+uninstall-dist_userstatsdconfigDATA:
@$(NORMAL_UNINSTALL)
- @list='$(dist_nodemoduleslibber_DATA)'; test -n "$(nodemoduleslibberdir)" || list=; \
+ @list='$(dist_userstatsdconfig_DATA)'; test -n "$(userstatsdconfigdir)" || list=; \
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- dir='$(DESTDIR)$(nodemoduleslibberdir)'; $(am__uninstall_files_from_dir)
+ dir='$(DESTDIR)$(userstatsdconfigdir)'; $(am__uninstall_files_from_dir)
tags TAGS:
ctags CTAGS:
@@ -458,7 +432,7 @@ check-am: all-am
check: check-am
all-am: Makefile $(DATA)
installdirs:
- for dir in "$(DESTDIR)$(nodedir)" "$(DESTDIR)$(nodemodulesdir)" "$(DESTDIR)$(nodemoduleslibberdir)"; do \
+ for dir in "$(DESTDIR)$(statsdconfigdir)" "$(DESTDIR)$(userstatsdconfigdir)"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-am
@@ -512,8 +486,8 @@ info: info-am
info-am:
-install-data-am: install-dist_nodeDATA install-dist_nodemodulesDATA \
- install-dist_nodemoduleslibberDATA
+install-data-am: install-dist_statsdconfigDATA \
+ install-dist_userstatsdconfigDATA
install-dvi: install-dvi-am
@@ -557,25 +531,24 @@ ps: ps-am
ps-am:
-uninstall-am: uninstall-dist_nodeDATA uninstall-dist_nodemodulesDATA \
- uninstall-dist_nodemoduleslibberDATA
+uninstall-am: uninstall-dist_statsdconfigDATA \
+ uninstall-dist_userstatsdconfigDATA
.MAKE: install-am install-strip
.PHONY: all all-am check check-am clean clean-generic cscopelist-am \
ctags-am distclean distclean-generic distdir dvi dvi-am html \
html-am info info-am install install-am install-data \
- install-data-am install-dist_nodeDATA \
- install-dist_nodemodulesDATA \
- install-dist_nodemoduleslibberDATA install-dvi install-dvi-am \
+ install-data-am install-dist_statsdconfigDATA \
+ install-dist_userstatsdconfigDATA install-dvi install-dvi-am \
install-exec install-exec-am install-html install-html-am \
install-info install-info-am install-man install-pdf \
install-pdf-am install-ps install-ps-am install-strip \
installcheck installcheck-am installdirs maintainer-clean \
maintainer-clean-generic mostlyclean mostlyclean-generic pdf \
pdf-am ps ps-am tags-am uninstall uninstall-am \
- uninstall-dist_nodeDATA uninstall-dist_nodemodulesDATA \
- uninstall-dist_nodemoduleslibberDATA
+ uninstall-dist_statsdconfigDATA \
+ uninstall-dist_userstatsdconfigDATA
# Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/node.d/Makefile.am b/node.d/Makefile.am
deleted file mode 100644
index 7f67faa6a..000000000
--- a/node.d/Makefile.am
+++ /dev/null
@@ -1,28 +0,0 @@
-MAINTAINERCLEANFILES= $(srcdir)/Makefile.in
-
-dist_node_DATA = \
- README.md \
- named.node.js \
- fronius.node.js \
- sma_webbox.node.js \
- snmp.node.js \
- stiebeleltron.node.js \
- $(NULL)
-
-nodemodulesdir=$(nodedir)/node_modules
-dist_nodemodules_DATA = \
- node_modules/netdata.js \
- node_modules/extend.js \
- node_modules/pixl-xml.js \
- node_modules/net-snmp.js \
- node_modules/asn1-ber.js \
- $(NULL)
-
-nodemoduleslibberdir=$(nodedir)/node_modules/lib/ber
-dist_nodemoduleslibber_DATA = \
- node_modules/lib/ber/index.js \
- node_modules/lib/ber/errors.js \
- node_modules/lib/ber/reader.js \
- node_modules/lib/ber/types.js \
- node_modules/lib/ber/writer.js \
- $(NULL)
diff --git a/node.d/README.md b/node.d/README.md
deleted file mode 100644
index 6818d34de..000000000
--- a/node.d/README.md
+++ /dev/null
@@ -1,118 +0,0 @@
-# Disclaimer
-
-Module configurations are written in JSON and **node.js is required**.
-
-to be edited.
-
----
-
-The following node.d modules are supported:
-
-# fronius
-
-This module collects metrics from the configured solar power installation from Fronius Symo.
-See `netdata/conf.d/node.d/fronius.conf.md` for more details.
-
-**Requirements**
- * Configuration file `fronius.conf` in the node.d netdata config dir (default: `/etc/netdata/node.d/fronius.conf`)
- * Fronius Symo with network access (http)
-
-It produces per server:
-
-1. **Power**
- * Current power input from the grid (positive values), output to the grid (negative values), in W
- * Current power input from the solar panels, in W
- * Current power stored in the accumulator (if present), in W (in theory, untested)
-
-2. **Consumption**
- * Local consumption in W
-
-3. **Autonomy**
- * Relative autonomy in %. 100 % autonomy means that the solar panels are delivering more power than it is needed by local consumption.
- * Relative self consumption in %. The lower the better
-
-4. **Energy**
- * The energy produced during the current day, in kWh
- * The energy produced during the current year, in kWh
-
-5. **Inverter**
- * The current power output from the connected inverters, in W, one dimension per inverter. At least one is always present.
-
-
-### configuration
-
-Sample:
-
-```json
-{
- "enable_autodetect": false,
- "update_every": 5,
- "servers": [
- {
- "name": "Symo",
- "hostname": "symo.ip.or.dns",
- "update_every": 5,
- "api_path": "/solar_api/v1/GetPowerFlowRealtimeData.fcgi"
- }
- ]
-}
-```
-
-If no configuration is given, the module will be disabled. Each `update_every` is optional, the default is `5`.
-
----
-
-# stiebel eltron
-
-This module collects metrics from the configured heat pump and hot water installation from Stiebel Eltron ISG web.
-See `netdata/conf.d/node.d/stiebeleltron.conf.md` for more details.
-
-**Requirements**
- * Configuration file `stiebeleltron.conf` in the node.d netdata config dir (default: `/etc/netdata/node.d/stiebeleltron.conf`)
- * Stiebel Eltron ISG web with network access (http), without password login
-
-The charts are configurable, however, the provided default configuration collects the following:
-
-1. **General**
- * Outside temperature in C
- * Condenser temperature in C
- * Heating circuit pressure in bar
- * Flow rate in l/min
- * Output of water and heat pumps in %
-
-2. **Heating**
- * Heat circuit 1 temperature in C (set/actual)
- * Heat circuit 2 temperature in C (set/actual)
- * Flow temperature in C (set/actual)
- * Buffer temperature in C (set/actual)
- * Pre-flow temperature in C
-
-3. **Hot Water**
- * Hot water temperature in C (set/actual)
-
-4. **Room Temperature**
- * Heat circuit 1 room temperature in C (set/actual)
- * Heat circuit 2 room temperature in C (set/actual)
-
-5. **Eletric Reheating**
- * Dual Mode Reheating temperature in C (hot water/heating)
-
-6. **Process Data**
- * Remaining compressor rest time in s
-
-7. **Runtime**
- * Compressor runtime hours (hot water/heating)
- * Reheating runtime hours (reheating 1/reheating 2)
-
-8. **Energy**
- * Compressor today in kWh (hot water/heating)
- * Compressor Total in kWh (hot water/heating)
-
-
-### configuration
-
-The default configuration is provided in [netdata/conf.d/node.d/stiebeleltron.conf.md](https://github.com/firehol/netdata/blob/master/conf.d/node.d/stiebeleltron.conf.md). Just change the `update_every` (if necessary) and hostnames. **You may have to adapt the configuration to suit your needs and setup** (which might be different).
-
-If no configuration is given, the module will be disabled. Each `update_every` is optional, the default is `10`.
-
----