summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/Makefile.in5
-rw-r--r--system/netdata.logrotate.in18
-rw-r--r--system/netdata.service.in3
3 files changed, 19 insertions, 7 deletions
diff --git a/system/Makefile.in b/system/Makefile.in
index b5acce0ba..e8f5eb3c8 100644
--- a/system/Makefile.in
+++ b/system/Makefile.in
@@ -156,6 +156,8 @@ OPTIONAL_MATH_CLFAGS = @OPTIONAL_MATH_CLFAGS@
OPTIONAL_MATH_LIBS = @OPTIONAL_MATH_LIBS@
OPTIONAL_NFACCT_CLFAGS = @OPTIONAL_NFACCT_CLFAGS@
OPTIONAL_NFACCT_LIBS = @OPTIONAL_NFACCT_LIBS@
+OPTIONAL_UUID_CLFAGS = @OPTIONAL_UUID_CLFAGS@
+OPTIONAL_UUID_LIBS = @OPTIONAL_UUID_LIBS@
OPTIONAL_ZLIB_CLFAGS = @OPTIONAL_ZLIB_CLFAGS@
OPTIONAL_ZLIB_LIBS = @OPTIONAL_ZLIB_LIBS@
PACKAGE = @PACKAGE@
@@ -177,6 +179,8 @@ PTHREAD_LIBS = @PTHREAD_LIBS@
SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
STRIP = @STRIP@
+UUID_CFLAGS = @UUID_CFLAGS@
+UUID_LIBS = @UUID_LIBS@
VERSION = @VERSION@
ZLIB_CFLAGS = @ZLIB_CFLAGS@
ZLIB_LIBS = @ZLIB_LIBS@
@@ -237,6 +241,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
+varlibdir = @varlibdir@
webdir = @webdir@
#
diff --git a/system/netdata.logrotate.in b/system/netdata.logrotate.in
index 763eb09c9..e77d5ff72 100644
--- a/system/netdata.logrotate.in
+++ b/system/netdata.logrotate.in
@@ -6,10 +6,16 @@
delaycompress
notifempty
sharedscripts
- postrotate
- if service netdata status > /dev/null ; then \
- service netdata restart > /dev/null; \
- fi;
- endscript
+ #
+ # if you add netdata to your init.d/system.d
+ # comment su & copytruncate and uncomment postrotate
+ # to have netdata restart when logs are rotated
+ su netdata
+ copytruncate
+ #
+ #postrotate
+ # if service netdata status > /dev/null ; then \
+ # service netdata restart > /dev/null; \
+ # fi;
+ #endscript
}
-
diff --git a/system/netdata.service.in b/system/netdata.service.in
index bc26cc9dc..91db6122d 100644
--- a/system/netdata.service.in
+++ b/system/netdata.service.in
@@ -9,7 +9,8 @@ User=root
Group=root
PIDFile=@localstatedir_POST@/run/netdata.pid
ExecStart=@sbindir_POST@/netdata -pidfile @localstatedir_POST@/run/netdata.pid
-ExecStop=/bin/kill -SIGTERM $MAINPID
+KillMode=mixed
+KillSignal=SIGTERM
TimeoutStopSec=30
[Install]