summaryrefslogtreecommitdiffstats
path: root/web/api/queries/des
diff options
context:
space:
mode:
Diffstat (limited to 'web/api/queries/des')
-rw-r--r--web/api/queries/des/Makefile.am8
-rw-r--r--web/api/queries/des/README.md77
-rw-r--r--web/api/queries/des/des.c8
-rw-r--r--web/api/queries/des/des.h138
4 files changed, 0 insertions, 231 deletions
diff --git a/web/api/queries/des/Makefile.am b/web/api/queries/des/Makefile.am
deleted file mode 100644
index 161784b8f..000000000
--- a/web/api/queries/des/Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-AUTOMAKE_OPTIONS = subdir-objects
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
-
-dist_noinst_DATA = \
- README.md \
- $(NULL)
diff --git a/web/api/queries/des/README.md b/web/api/queries/des/README.md
deleted file mode 100644
index 0cc1a918e..000000000
--- a/web/api/queries/des/README.md
+++ /dev/null
@@ -1,77 +0,0 @@
-<!--
-title: "double exponential smoothing"
-sidebar_label: "double exponential smoothing"
-custom_edit_url: https://github.com/netdata/netdata/edit/master/web/api/queries/des/README.md
-learn_status: "Published"
-learn_topic_type: "References"
-learn_rel_path: "Developers/Web/Api/Queries"
--->
-
-# double exponential smoothing
-
-Exponential smoothing is one of many window functions commonly applied to smooth data in signal
-processing, acting as low-pass filters to remove high frequency noise.
-
-Simple exponential smoothing does not do well when there is a trend in the data.
-In such situations, several methods were devised under the name "double exponential smoothing"
-or "second-order exponential smoothing.", which is the recursive application of an exponential
-filter twice, thus being termed "double exponential smoothing".
-
-In simple terms, this is like an average value, but more recent values are given more weight
-and the trend of the values influences significantly the result.
-
-> **IMPORTANT**
->
-> It is common for `des` to provide "average" values that far beyond the minimum or the maximum
-> values found in the time-series.
-> `des` estimates these values because of it takes into account the trend.
-
-This module implements the "Holt-Winters double exponential smoothing".
-
-Netdata automatically adjusts the weight (`alpha`) and the trend (`beta`) based on the number
-of values processed, using the formula:
-
-```
-window = max(number of values, 15)
-alpha = 2 / (window + 1)
-beta = 2 / (window + 1)
-```
-
-You can change the fixed value `15` by setting in `netdata.conf`:
-
-```
-[web]
- des max window = 15
-```
-
-## how to use
-
-Use it in alerts like this:
-
-```
- alarm: my_alert
- on: my_chart
-lookup: des -1m unaligned of my_dimension
- warn: $this > 1000
-```
-
-`des` does not change the units. For example, if the chart units is `requests/sec`, the result
-will be again expressed in the same units.
-
-It can also be used in APIs and badges as `&group=des` in the URL.
-
-## Examples
-
-Examining last 1 minute `successful` web server responses:
-
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=min&after=-60&label=min)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=average&after=-60&label=average&value_color=yellow)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=ses&after=-60&label=single+exponential+smoothing&value_color=yellow)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=des&after=-60&label=double+exponential+smoothing&value_color=orange)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=max&after=-60&label=max)
-
-## References
-
-- <https://en.wikipedia.org/wiki/Exponential_smoothing>.
-
-
diff --git a/web/api/queries/des/des.c b/web/api/queries/des/des.c
deleted file mode 100644
index d0e234e23..000000000
--- a/web/api/queries/des/des.c
+++ /dev/null
@@ -1,8 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#include <web/api/queries/rrdr.h>
-#include "des.h"
-
-
-// ----------------------------------------------------------------------------
-// single exponential smoothing
diff --git a/web/api/queries/des/des.h b/web/api/queries/des/des.h
deleted file mode 100644
index 3153d497c..000000000
--- a/web/api/queries/des/des.h
+++ /dev/null
@@ -1,138 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#ifndef NETDATA_API_QUERIES_DES_H
-#define NETDATA_API_QUERIES_DES_H
-
-#include "../query.h"
-#include "../rrdr.h"
-
-struct tg_des {
- NETDATA_DOUBLE alpha;
- NETDATA_DOUBLE alpha_other;
- NETDATA_DOUBLE beta;
- NETDATA_DOUBLE beta_other;
-
- NETDATA_DOUBLE level;
- NETDATA_DOUBLE trend;
-
- size_t count;
-};
-
-static size_t tg_des_max_window_size = 15;
-
-static inline void tg_des_init(void) {
- long long ret = config_get_number(CONFIG_SECTION_WEB, "des max tg_des_window", (long long)tg_des_max_window_size);
- if(ret <= 1) {
- config_set_number(CONFIG_SECTION_WEB, "des max tg_des_window", (long long)tg_des_max_window_size);
- }
- else {
- tg_des_max_window_size = (size_t) ret;
- }
-}
-
-static inline NETDATA_DOUBLE tg_des_window(RRDR *r, struct tg_des *g) {
- (void)g;
-
- NETDATA_DOUBLE points;
- if(r->view.group == 1) {
- // provide a running DES
- points = (NETDATA_DOUBLE)r->time_grouping.points_wanted;
- }
- else {
- // provide a SES with flush points
- points = (NETDATA_DOUBLE)r->view.group;
- }
-
- // https://en.wikipedia.org/wiki/Moving_average#Exponential_moving_average
- // A commonly used value for alpha is 2 / (N + 1)
- return (points > (NETDATA_DOUBLE)tg_des_max_window_size) ? (NETDATA_DOUBLE)tg_des_max_window_size : points;
-}
-
-static inline void tg_des_set_alpha(RRDR *r, struct tg_des *g) {
- // https://en.wikipedia.org/wiki/Moving_average#Exponential_moving_average
- // A commonly used value for alpha is 2 / (N + 1)
-
- g->alpha = 2.0 / (tg_des_window(r, g) + 1.0);
- g->alpha_other = 1.0 - g->alpha;
-
- //info("alpha for chart '%s' is " CALCULATED_NUMBER_FORMAT, r->st->name, g->alpha);
-}
-
-static inline void tg_des_set_beta(RRDR *r, struct tg_des *g) {
- // https://en.wikipedia.org/wiki/Moving_average#Exponential_moving_average
- // A commonly used value for alpha is 2 / (N + 1)
-
- g->beta = 2.0 / (tg_des_window(r, g) + 1.0);
- g->beta_other = 1.0 - g->beta;
-
- //info("beta for chart '%s' is " CALCULATED_NUMBER_FORMAT, r->st->name, g->beta);
-}
-
-static inline void tg_des_create(RRDR *r, const char *options __maybe_unused) {
- struct tg_des *g = (struct tg_des *)onewayalloc_mallocz(r->internal.owa, sizeof(struct tg_des));
- tg_des_set_alpha(r, g);
- tg_des_set_beta(r, g);
- g->level = 0.0;
- g->trend = 0.0;
- g->count = 0;
- r->time_grouping.data = g;
-}
-
-// resets when switches dimensions
-// so, clear everything to restart
-static inline void tg_des_reset(RRDR *r) {
- struct tg_des *g = (struct tg_des *)r->time_grouping.data;
- g->level = 0.0;
- g->trend = 0.0;
- g->count = 0;
-
- // fprintf(stderr, "\nDES: ");
-
-}
-
-static inline void tg_des_free(RRDR *r) {
- onewayalloc_freez(r->internal.owa, r->time_grouping.data);
- r->time_grouping.data = NULL;
-}
-
-static inline void tg_des_add(RRDR *r, NETDATA_DOUBLE value) {
- struct tg_des *g = (struct tg_des *)r->time_grouping.data;
-
- if(likely(g->count > 0)) {
- // we have at least a number so far
-
- if(unlikely(g->count == 1)) {
- // the second value we got
- g->trend = value - g->trend;
- g->level = value;
- }
-
- // for the values, except the first
- NETDATA_DOUBLE last_level = g->level;
- g->level = (g->alpha * value) + (g->alpha_other * (g->level + g->trend));
- g->trend = (g->beta * (g->level - last_level)) + (g->beta_other * g->trend);
- }
- else {
- // the first value we got
- g->level = g->trend = value;
- }
-
- g->count++;
-
- //fprintf(stderr, "value: " CALCULATED_NUMBER_FORMAT ", level: " CALCULATED_NUMBER_FORMAT ", trend: " CALCULATED_NUMBER_FORMAT "\n", value, g->level, g->trend);
-}
-
-static inline NETDATA_DOUBLE tg_des_flush(RRDR *r, RRDR_VALUE_FLAGS *rrdr_value_options_ptr) {
- struct tg_des *g = (struct tg_des *)r->time_grouping.data;
-
- if(unlikely(!g->count || !netdata_double_isnumber(g->level))) {
- *rrdr_value_options_ptr |= RRDR_VALUE_EMPTY;
- return 0.0;
- }
-
- //fprintf(stderr, " RESULT for %zu values = " CALCULATED_NUMBER_FORMAT " \n", g->count, g->level);
-
- return g->level;
-}
-
-#endif //NETDATA_API_QUERIES_DES_H