summaryrefslogtreecommitdiffstats
path: root/web/api/queries/ses
diff options
context:
space:
mode:
Diffstat (limited to 'web/api/queries/ses')
-rw-r--r--web/api/queries/ses/Makefile.am8
-rw-r--r--web/api/queries/ses/README.md65
-rw-r--r--web/api/queries/ses/ses.c8
-rw-r--r--web/api/queries/ses/ses.h92
4 files changed, 0 insertions, 173 deletions
diff --git a/web/api/queries/ses/Makefile.am b/web/api/queries/ses/Makefile.am
deleted file mode 100644
index 161784b8f..000000000
--- a/web/api/queries/ses/Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-AUTOMAKE_OPTIONS = subdir-objects
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
-
-dist_noinst_DATA = \
- README.md \
- $(NULL)
diff --git a/web/api/queries/ses/README.md b/web/api/queries/ses/README.md
deleted file mode 100644
index a06f646ef..000000000
--- a/web/api/queries/ses/README.md
+++ /dev/null
@@ -1,65 +0,0 @@
-<!--
-title: "Single (or Simple) Exponential Smoothing (`ses`)"
-sidebar_label: "Single (or Simple) Exponential Smoothing (`ses`)"
-custom_edit_url: https://github.com/netdata/netdata/edit/master/web/api/queries/ses/README.md
-learn_status: "Published"
-learn_topic_type: "References"
-learn_rel_path: "Developers/Web/Api/Queries"
--->
-
-# Single (or Simple) Exponential Smoothing (`ses`)
-
-> This query is also available as `ema` and `ewma`.
-
-An exponential moving average (`ema`), also known as an exponentially weighted moving average (`ewma`)
-is a first-order infinite impulse response filter that applies weighting factors which decrease
-exponentially. The weighting for each older datum decreases exponentially, never reaching zero.
-
-In simple terms, this is like an average value, but more recent values are given more weight.
-
-Netdata automatically adjusts the weight (`alpha`) based on the number of values processed,
-using the formula:
-
-```
-window = max(number of values, 15)
-alpha = 2 / (window + 1)
-```
-
-You can change the fixed value `15` by setting in `netdata.conf`:
-
-```
-[web]
- ses max window = 15
-```
-
-## how to use
-
-Use it in alerts like this:
-
-```
- alarm: my_alert
- on: my_chart
-lookup: ses -1m unaligned of my_dimension
- warn: $this > 1000
-```
-
-`ses` does not change the units. For example, if the chart units is `requests/sec`, the exponential
-moving average will be again expressed in the same units.
-
-It can also be used in APIs and badges as `&group=ses` in the URL.
-
-## Examples
-
-Examining last 1 minute `successful` web server responses:
-
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=min&after=-60&label=min)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=average&after=-60&label=average&value_color=yellow)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=ses&after=-60&label=single+exponential+smoothing&value_color=orange)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=max&after=-60&label=max)
-
-## References
-
-- <https://en.wikipedia.org/wiki/Moving_average#exponential-moving-average>
-- <https://en.wikipedia.org/wiki/Exponential_smoothing>.
-
-
diff --git a/web/api/queries/ses/ses.c b/web/api/queries/ses/ses.c
deleted file mode 100644
index 39eb445a0..000000000
--- a/web/api/queries/ses/ses.c
+++ /dev/null
@@ -1,8 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#include "ses.h"
-
-
-// ----------------------------------------------------------------------------
-// single exponential smoothing
-
diff --git a/web/api/queries/ses/ses.h b/web/api/queries/ses/ses.h
deleted file mode 100644
index de8645ff0..000000000
--- a/web/api/queries/ses/ses.h
+++ /dev/null
@@ -1,92 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#ifndef NETDATA_API_QUERIES_SES_H
-#define NETDATA_API_QUERIES_SES_H
-
-#include "../query.h"
-#include "../rrdr.h"
-
-struct tg_ses {
- NETDATA_DOUBLE alpha;
- NETDATA_DOUBLE alpha_other;
- NETDATA_DOUBLE level;
- size_t count;
-};
-
-static size_t tg_ses_max_window_size = 15;
-
-static inline void tg_ses_init(void) {
- long long ret = config_get_number(CONFIG_SECTION_WEB, "ses max tg_des_window", (long long)tg_ses_max_window_size);
- if(ret <= 1) {
- config_set_number(CONFIG_SECTION_WEB, "ses max tg_des_window", (long long)tg_ses_max_window_size);
- }
- else {
- tg_ses_max_window_size = (size_t) ret;
- }
-}
-
-static inline NETDATA_DOUBLE tg_ses_window(RRDR *r, struct tg_ses *g) {
- (void)g;
-
- NETDATA_DOUBLE points;
- if(r->view.group == 1) {
- // provide a running DES
- points = (NETDATA_DOUBLE)r->time_grouping.points_wanted;
- }
- else {
- // provide a SES with flush points
- points = (NETDATA_DOUBLE)r->view.group;
- }
-
- return (points > (NETDATA_DOUBLE)tg_ses_max_window_size) ? (NETDATA_DOUBLE)tg_ses_max_window_size : points;
-}
-
-static inline void tg_ses_set_alpha(RRDR *r, struct tg_ses *g) {
- // https://en.wikipedia.org/wiki/Moving_average#Exponential_moving_average
- // A commonly used value for alpha is 2 / (N + 1)
- g->alpha = 2.0 / (tg_ses_window(r, g) + 1.0);
- g->alpha_other = 1.0 - g->alpha;
-}
-
-static inline void tg_ses_create(RRDR *r, const char *options __maybe_unused) {
- struct tg_ses *g = (struct tg_ses *)onewayalloc_callocz(r->internal.owa, 1, sizeof(struct tg_ses));
- tg_ses_set_alpha(r, g);
- g->level = 0.0;
- r->time_grouping.data = g;
-}
-
-// resets when switches dimensions
-// so, clear everything to restart
-static inline void tg_ses_reset(RRDR *r) {
- struct tg_ses *g = (struct tg_ses *)r->time_grouping.data;
- g->level = 0.0;
- g->count = 0;
-}
-
-static inline void tg_ses_free(RRDR *r) {
- onewayalloc_freez(r->internal.owa, r->time_grouping.data);
- r->time_grouping.data = NULL;
-}
-
-static inline void tg_ses_add(RRDR *r, NETDATA_DOUBLE value) {
- struct tg_ses *g = (struct tg_ses *)r->time_grouping.data;
-
- if(unlikely(!g->count))
- g->level = value;
-
- g->level = g->alpha * value + g->alpha_other * g->level;
- g->count++;
-}
-
-static inline NETDATA_DOUBLE tg_ses_flush(RRDR *r, RRDR_VALUE_FLAGS *rrdr_value_options_ptr) {
- struct tg_ses *g = (struct tg_ses *)r->time_grouping.data;
-
- if(unlikely(!g->count || !netdata_double_isnumber(g->level))) {
- *rrdr_value_options_ptr |= RRDR_VALUE_EMPTY;
- return 0.0;
- }
-
- return g->level;
-}
-
-#endif //NETDATA_API_QUERIES_SES_H