summaryrefslogtreecommitdiffstats
path: root/web/api/queries/sum
diff options
context:
space:
mode:
Diffstat (limited to 'web/api/queries/sum')
-rw-r--r--web/api/queries/sum/Makefile.am8
-rw-r--r--web/api/queries/sum/README.md45
-rw-r--r--web/api/queries/sum/sum.c9
-rw-r--r--web/api/queries/sum/sum.h56
4 files changed, 0 insertions, 118 deletions
diff --git a/web/api/queries/sum/Makefile.am b/web/api/queries/sum/Makefile.am
deleted file mode 100644
index 161784b8f..000000000
--- a/web/api/queries/sum/Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-AUTOMAKE_OPTIONS = subdir-objects
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
-
-dist_noinst_DATA = \
- README.md \
- $(NULL)
diff --git a/web/api/queries/sum/README.md b/web/api/queries/sum/README.md
deleted file mode 100644
index 62e18acab..000000000
--- a/web/api/queries/sum/README.md
+++ /dev/null
@@ -1,45 +0,0 @@
-<!--
-title: "Sum"
-sidebar_label: "Sum"
-custom_edit_url: https://github.com/netdata/netdata/edit/master/web/api/queries/sum/README.md
-learn_status: "Published"
-learn_topic_type: "References"
-learn_rel_path: "Developers/Web/Api/Queries"
--->
-
-# Sum
-
-This module sums all the values in the time-frame requested.
-
-You can use `sum` to find the volume of something over a period.
-
-## how to use
-
-Use it in alarms like this:
-
-```
- alarm: my_alarm
- on: my_chart
-lookup: sum -1m unaligned of my_dimension
- warn: $this > 1000
-```
-
-`sum` does not change the units. For example, if the chart units is `requests/sec`, the result
-will be again expressed in the same units.
-
-It can also be used in APIs and badges as `&group=sum` in the URL.
-
-## Examples
-
-Examining last 1 minute `successful` web server responses:
-
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=min&after=-60&label=min)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=average&after=-60&label=average)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=max&after=-60&label=max)
-- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=sum&after=-60&label=1m+sum&value_color=orange&units=requests)
-
-## References
-
-- <https://en.wikipedia.org/wiki/Summation>.
-
-
diff --git a/web/api/queries/sum/sum.c b/web/api/queries/sum/sum.c
deleted file mode 100644
index cf4484217..000000000
--- a/web/api/queries/sum/sum.c
+++ /dev/null
@@ -1,9 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#include "sum.h"
-
-// ----------------------------------------------------------------------------
-// sum
-
-
-
diff --git a/web/api/queries/sum/sum.h b/web/api/queries/sum/sum.h
deleted file mode 100644
index 5e07f45d6..000000000
--- a/web/api/queries/sum/sum.h
+++ /dev/null
@@ -1,56 +0,0 @@
-// SPDX-License-Identifier: GPL-3.0-or-later
-
-#ifndef NETDATA_API_QUERY_SUM_H
-#define NETDATA_API_QUERY_SUM_H
-
-#include "../query.h"
-#include "../rrdr.h"
-
-struct tg_sum {
- NETDATA_DOUBLE sum;
- size_t count;
-};
-
-static inline void tg_sum_create(RRDR *r, const char *options __maybe_unused) {
- r->time_grouping.data = onewayalloc_callocz(r->internal.owa, 1, sizeof(struct tg_sum));
-}
-
-// resets when switches dimensions
-// so, clear everything to restart
-static inline void tg_sum_reset(RRDR *r) {
- struct tg_sum *g = (struct tg_sum *)r->time_grouping.data;
- g->sum = 0;
- g->count = 0;
-}
-
-static inline void tg_sum_free(RRDR *r) {
- onewayalloc_freez(r->internal.owa, r->time_grouping.data);
- r->time_grouping.data = NULL;
-}
-
-static inline void tg_sum_add(RRDR *r, NETDATA_DOUBLE value) {
- struct tg_sum *g = (struct tg_sum *)r->time_grouping.data;
- g->sum += value;
- g->count++;
-}
-
-static inline NETDATA_DOUBLE tg_sum_flush(RRDR *r, RRDR_VALUE_FLAGS *rrdr_value_options_ptr) {
- struct tg_sum *g = (struct tg_sum *)r->time_grouping.data;
-
- NETDATA_DOUBLE value;
-
- if(unlikely(!g->count)) {
- value = 0.0;
- *rrdr_value_options_ptr |= RRDR_VALUE_EMPTY;
- }
- else {
- value = g->sum;
- }
-
- g->sum = 0.0;
- g->count = 0;
-
- return value;
-}
-
-#endif //NETDATA_API_QUERY_SUM_H